summaryrefslogtreecommitdiff
path: root/app-misc/detox/detox-1.4.5.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'app-misc/detox/detox-1.4.5.ebuild')
-rw-r--r--app-misc/detox/detox-1.4.5.ebuild38
1 files changed, 38 insertions, 0 deletions
diff --git a/app-misc/detox/detox-1.4.5.ebuild b/app-misc/detox/detox-1.4.5.ebuild
new file mode 100644
index 000000000000..8966cb7d4b6d
--- /dev/null
+++ b/app-misc/detox/detox-1.4.5.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit autotools
+
+MY_P="${PN}-${PV/_/-}"
+
+DESCRIPTION="Safely remove spaces and strange characters from filenames"
+HOMEPAGE="http://detox.sourceforge.net/ https://github.com/dharple/detox"
+SRC_URI="https://github.com/dharple/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+S="${WORKDIR}"/${MY_P}
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~hppa ~mips ~ppc ~x86 ~amd64-linux ~x86-linux"
+
+RDEPEND="!dev-python/detox"
+DEPEND="${RDEPEND}"
+BDEPEND="sys-devel/bison
+ sys-devel/flex"
+
+src_prepare() {
+ default
+
+ sed \
+ -e '/detoxrc.sample/d' \
+ -i Makefile.am || die
+
+ eautoreconf
+}
+
+src_install() {
+ default
+
+ dodoc etc/${PN}rc.sample
+}