summaryrefslogtreecommitdiff
path: root/app-misc/cpipe/cpipe-3.0.3.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'app-misc/cpipe/cpipe-3.0.3.ebuild')
-rw-r--r--app-misc/cpipe/cpipe-3.0.3.ebuild32
1 files changed, 32 insertions, 0 deletions
diff --git a/app-misc/cpipe/cpipe-3.0.3.ebuild b/app-misc/cpipe/cpipe-3.0.3.ebuild
new file mode 100644
index 000000000000..6e1c286b1d2d
--- /dev/null
+++ b/app-misc/cpipe/cpipe-3.0.3.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit eutils toolchain-funcs
+
+DESCRIPTION="Counting pipe, measures data transfered over pipe"
+HOMEPAGE="https://github.com/HaraldKi/cpipe"
+SRC_URI="https://github.com/HaraldKi/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+src_prepare() {
+ default
+
+ sed -i \
+ -e "s/CFLAGS =/CFLAGS =${CFLAGS} /" \
+ -e "s/-lm/-lm ${LDFLAGS}/" \
+ -e "s/744/644/" makefile || die "sed failed"
+}
+
+src_compile() {
+ emake CC="$(tc-getCC)" CFLAGS="${CFLAGS}"
+}
+
+src_install() {
+ dobin "${PN}"
+ doman "${PN}.1"
+}