summaryrefslogtreecommitdiff
path: root/app-misc/bottlerocket/bottlerocket-0.04c-r1.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'app-misc/bottlerocket/bottlerocket-0.04c-r1.ebuild')
-rw-r--r--app-misc/bottlerocket/bottlerocket-0.04c-r1.ebuild44
1 files changed, 44 insertions, 0 deletions
diff --git a/app-misc/bottlerocket/bottlerocket-0.04c-r1.ebuild b/app-misc/bottlerocket/bottlerocket-0.04c-r1.ebuild
new file mode 100644
index 000000000000..4bebb91dd777
--- /dev/null
+++ b/app-misc/bottlerocket/bottlerocket-0.04c-r1.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="2"
+
+inherit toolchain-funcs
+
+DESCRIPTION="CLI interface to the X-10 Firecracker Kit"
+HOMEPAGE="http://www.linuxha.com/bottlerocket/"
+SRC_URI="http://www.linuxha.com/${PN}/${P}.tar.gz"
+
+LICENSE="LGPL-2"
+SLOT="0"
+KEYWORDS="amd64 ~ppc ~sparc x86"
+IUSE=""
+
+src_prepare() {
+ # inset LDFLAGS
+ sed -i Makefile.in \
+ -e 's| -O2 ||g' \
+ -e '/ -o br /s|${CFLAGS}|& $(LDFLAGS)|g' \
+ || die "sed Makefile.in"
+}
+
+src_configure() {
+ econf --with-x10port=/dev/firecracker
+}
+
+src_compile() {
+ emake CC="$(tc-getCC)" || die "emake failed"
+}
+
+src_install() {
+ einstall || die "einstall"
+ dodoc README
+}
+
+pkg_postinst() {
+ elog
+ elog "Be sure to create a /dev/firecracker symlink to the"
+ elog "serial port that has the Firecracker serial interface"
+ elog "installed on it."
+ elog
+}