summaryrefslogtreecommitdiff
path: root/app-metrics/nginx-vts-exporter/nginx-vts-exporter-0.10.0.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'app-metrics/nginx-vts-exporter/nginx-vts-exporter-0.10.0.ebuild')
-rw-r--r--app-metrics/nginx-vts-exporter/nginx-vts-exporter-0.10.0.ebuild47
1 files changed, 47 insertions, 0 deletions
diff --git a/app-metrics/nginx-vts-exporter/nginx-vts-exporter-0.10.0.ebuild b/app-metrics/nginx-vts-exporter/nginx-vts-exporter-0.10.0.ebuild
new file mode 100644
index 000000000000..761f9630f63c
--- /dev/null
+++ b/app-metrics/nginx-vts-exporter/nginx-vts-exporter-0.10.0.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+inherit user golang-build golang-vcs-snapshot
+
+EGO_PN="github.com/hnlq715/nginx-vts-exporter"
+EXPORTER_COMMIT="f5b3491cd0a8cc2df7088470f2727b0ae39a2700"
+ARCHIVE_URI="https://${EGO_PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+KEYWORDS="~amd64"
+
+DESCRIPTION="Nginx virtual host traffic stats exporter for Prometheus"
+HOMEPAGE="https://github.com/hnlq715/nginx-vts-exporter"
+SRC_URI="${ARCHIVE_URI}"
+LICENSE="MIT"
+SLOT="0"
+IUSE=""
+
+DEPEND="dev-util/promu"
+
+pkg_setup() {
+ enewgroup ${PN}
+ enewuser ${PN} -1 -1 -1 ${PN}
+}
+
+src_prepare() {
+ default
+ sed -i -e "/-s$/d" -e "s/{{.Revision}}/${EXPORTER_COMMIT}/" src/${EGO_PN}/.promu.yml || die
+}
+
+src_compile() {
+ pushd src/${EGO_PN} || die
+ mkdir -p bin || die
+ GOPATH="${S}" promu build -v --prefix bin || die
+ popd || die
+}
+
+src_install() {
+ pushd src/${EGO_PN} || die
+ dobin bin/${PN}
+ dodoc README.md
+ popd || die
+ keepdir /var/log/${PN}
+ fowners ${PN}:${PN} /var/log/${PN}
+ newinitd "${FILESDIR}"/${PN}.initd ${PN}
+ newconfd "${FILESDIR}"/${PN}.confd ${PN}
+}