summaryrefslogtreecommitdiff
path: root/app-laptop/rogauracore/rogauracore-1.5.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'app-laptop/rogauracore/rogauracore-1.5.ebuild')
-rw-r--r--app-laptop/rogauracore/rogauracore-1.5.ebuild14
1 files changed, 11 insertions, 3 deletions
diff --git a/app-laptop/rogauracore/rogauracore-1.5.ebuild b/app-laptop/rogauracore/rogauracore-1.5.ebuild
index a6678b687a8b..06b0cf8b4207 100644
--- a/app-laptop/rogauracore/rogauracore-1.5.ebuild
+++ b/app-laptop/rogauracore/rogauracore-1.5.ebuild
@@ -1,16 +1,16 @@
-# Copyright 1999-2021 Gentoo Authors
+# Copyright 1999-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
-inherit autotools
+inherit autotools udev
if [[ ${PV} = "9999" ]]; then
EGIT_REPO_URI="https://github.com/wroberts/rogauracore.git"
inherit git-r3
else
SRC_URI="https://github.com/wroberts/${PN}/archive/refs/tags/${PV}.tar.gz -> ${P}.tar.gz"
- KEYWORDS="~amd64"
+ KEYWORDS="amd64"
fi
DESCRIPTION="RGB keyboard control for Asus ROG laptops"
@@ -33,3 +33,11 @@ src_configure() {
src_compile() {
emake
}
+
+pkg_postinst() {
+ udev_reload
+}
+
+pkg_postrm() {
+ udev_reload
+}