summaryrefslogtreecommitdiff
path: root/app-laptop/mbpfan
diff options
context:
space:
mode:
Diffstat (limited to 'app-laptop/mbpfan')
-rw-r--r--app-laptop/mbpfan/Manifest8
-rw-r--r--app-laptop/mbpfan/mbpfan-1.9.1.ebuild33
-rw-r--r--app-laptop/mbpfan/mbpfan-2.0.0.ebuild45
-rw-r--r--app-laptop/mbpfan/mbpfan-2.0.1.ebuild44
-rw-r--r--app-laptop/mbpfan/mbpfan-9999.ebuild44
-rw-r--r--app-laptop/mbpfan/metadata.xml18
6 files changed, 192 insertions, 0 deletions
diff --git a/app-laptop/mbpfan/Manifest b/app-laptop/mbpfan/Manifest
new file mode 100644
index 000000000000..326e74f66504
--- /dev/null
+++ b/app-laptop/mbpfan/Manifest
@@ -0,0 +1,8 @@
+DIST mbpfan-1.9.1.tar.gz 24393 BLAKE2B 9fd96f6903aa360a86e2813d9bf3e57fe28dacc7bbfb25c94eba90a41de1bbf48adb840ec664e9ab3dccafcb361a8799d14ccc258fa377fac88a510c1063a92d SHA512 04f1f70697ccd182c329588623c6664979e1cc25db8a39a2ea9f6d1ec49f3914172c3ada392fabc9ac51a811f36087dc600426c34c201d02a5d7b791b04f0f3b
+DIST mbpfan-2.0.0.tar.gz 37912 BLAKE2B 8d2ce41d8f6a724e28ace0c23047dde4a0a60ae10beeec3e3d7194bbd6b87ae0c340cf025deca896208e225083e0bb67043c6b00135544f2d78e39fbf55b3fcd SHA512 9a7f930afe0a151fe50bf3ef1a06a5cecaced0c47f7088a83b91e25dff85d4b0d53494eac5eb1b624bde6ff1d3307a0d9fe6ba392fdacbe58e241d93d11cda6d
+DIST mbpfan-2.0.1.tar.gz 37805 BLAKE2B 0988a9b5cd359b4e64fdb1e63322dea7582fdc9a9dda0760550945282ef6142dbcab8aeb78ec1a725b5f9aebcda72386e3fa4b8b5f7ecdf078106d229fb7e2af SHA512 8fd2e37b9b81720ff7efa490d285da5980ef5dcc858fef4b0c24166a8f0df46aa230ea18fca5775b222271918e5ca6df1bfbbdced068182c20eeb86192ed2019
+EBUILD mbpfan-1.9.1.ebuild 766 BLAKE2B c8bcc93a3b0a26f6b17b320f0eba11cbe01995314f78e6feef34f3a35c6e089fb71300efe88badc975b4cf747a9103cd27d7144e0a0f16e977b5e990b587bd82 SHA512 e805289f5db3b918a975028a2d16e3eef35f48ccb3db18c9f3cc12b51b4871e5420f8d90c2729e90b6b607a12aac95e88b45ed7ebf3de2e6c2818e7383d2c18b
+EBUILD mbpfan-2.0.0.ebuild 1239 BLAKE2B 58302c6ffab70950fbfeda28331b702749d12908ab65e6637ec16e550f79cdd31502dc9d59e98b63e46c042ccd158d46cfce3916d584faff6fa7ca59bdbaf3c5 SHA512 84a5ff0e5f7bd141a13177760baf22d6e5c0f156aff187600b9b1c803d6616d6d9528c61303b40792d59b9a8f905c2d214b2e568b62c7da120b8e3b86cd298bb
+EBUILD mbpfan-2.0.1.ebuild 1175 BLAKE2B a3a1263571fe29d67bee6ef96e8a4ba92d7259cdeb2f294e254823885b9d898f80ed97d6b8149f4630ee9ecf2145ac0f86a24371b17cbc517d37703d5b209e51 SHA512 82368d46789134ec2b7c86d671096c9a5e64db7956075dd599b858400d069a2ca07db94b41c89152493b577409aa5f458abd5caf502df472ac4c82a6fc6514a9
+EBUILD mbpfan-9999.ebuild 1175 BLAKE2B a3a1263571fe29d67bee6ef96e8a4ba92d7259cdeb2f294e254823885b9d898f80ed97d6b8149f4630ee9ecf2145ac0f86a24371b17cbc517d37703d5b209e51 SHA512 82368d46789134ec2b7c86d671096c9a5e64db7956075dd599b858400d069a2ca07db94b41c89152493b577409aa5f458abd5caf502df472ac4c82a6fc6514a9
+MISC metadata.xml 689 BLAKE2B 27fd22350963186cbee04938bcd8e14e7662ea0d0d432c45ae1a6d352588e13d33cee3f461ffcef5b0c7fd0dccee8b63eb806ca05c8887d4f8c98940d93521b3 SHA512 8edd05f68f3781e684706e61cc28a1d8d5877746c7022ed5a247bb5e686de7f75cbcca2253962b51ccfc06d47445d553399e90b465a9ae466d45cd47d7d05c36
diff --git a/app-laptop/mbpfan/mbpfan-1.9.1.ebuild b/app-laptop/mbpfan/mbpfan-1.9.1.ebuild
new file mode 100644
index 000000000000..58ae75eb0cb0
--- /dev/null
+++ b/app-laptop/mbpfan/mbpfan-1.9.1.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit linux-info systemd toolchain-funcs
+
+DESCRIPTION="A simple daemon to control fan speed on all Macbook/Macbook Pros"
+HOMEPAGE="https://github.com/dgraziotin/mbpfan"
+SRC_URI="https://github.com/dgraziotin/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+LICENSE="GPL-3+"
+SLOT="0"
+KEYWORDS="~amd64"
+RESTRICT="test" # will fail if the hardware is unavailable, not useful
+
+CONFIG_CHECK="~SENSORS_APPLESMC ~SENSORS_CORETEMP"
+
+src_prepare() {
+ sed -i -e "s:g++:$(tc-getCXX):g" Makefile || die
+ default
+}
+
+src_install() {
+ dosbin bin/mbpfan
+
+ insinto /etc
+ doins ${PN}.conf
+
+ newinitd ${PN}.init.gentoo ${PN}
+ systemd_dounit ${PN}.service
+
+ einstalldocs
+}
diff --git a/app-laptop/mbpfan/mbpfan-2.0.0.ebuild b/app-laptop/mbpfan/mbpfan-2.0.0.ebuild
new file mode 100644
index 000000000000..fb1fc7c3f9dc
--- /dev/null
+++ b/app-laptop/mbpfan/mbpfan-2.0.0.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit linux-info systemd toolchain-funcs
+
+DESCRIPTION="A simple daemon to control fan speed on all Macbook/Macbook Pros"
+HOMEPAGE="https://github.com/dgraziotin/mbpfan"
+LICENSE="GPL-3+"
+SLOT="0"
+RESTRICT="test" # will fail if the hardware is unavailable, not useful
+
+if [[ "${PV}" = 9999 ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/dgraziotin/${PN}.git"
+ KEYWORDS=""
+else
+ SRC_URI="https://github.com/dgraziotin/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64"
+fi
+
+CONFIG_CHECK="~SENSORS_APPLESMC ~SENSORS_CORETEMP"
+
+src_compile() {
+ emake CC="$(tc-getCC)"
+}
+
+src_install() {
+ # There's a double linking problem in install
+ emake DESTDIR="${ED}" CC="$(tc-getCC)" install
+
+ # Remove the empty systemd unit directory
+ # It doesn't actually install the unit file
+ rmdir --ignore-fail-on-non-empty -p "${ED%/}/lib/systemd/system" || die
+ # Actually install the sytstemd unit file
+ systemd_dounit ${PN}.service
+ # Install openrc init file
+ newinitd ${PN}.init.gentoo ${PN}
+
+ # make install doesn't install the docs in the right place
+ rm -rf "${ED%/}/usr/share/doc/${PN}" || die
+
+ einstalldocs
+}
diff --git a/app-laptop/mbpfan/mbpfan-2.0.1.ebuild b/app-laptop/mbpfan/mbpfan-2.0.1.ebuild
new file mode 100644
index 000000000000..357bf95cf287
--- /dev/null
+++ b/app-laptop/mbpfan/mbpfan-2.0.1.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit linux-info systemd toolchain-funcs
+
+DESCRIPTION="A simple daemon to control fan speed on all Macbook/Macbook Pros"
+HOMEPAGE="https://github.com/dgraziotin/mbpfan"
+LICENSE="GPL-3+"
+SLOT="0"
+RESTRICT="test" # will fail if the hardware is unavailable, not useful
+
+if [[ "${PV}" = 9999 ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/dgraziotin/${PN}.git"
+ KEYWORDS=""
+else
+ SRC_URI="https://github.com/dgraziotin/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64"
+fi
+
+CONFIG_CHECK="~SENSORS_APPLESMC ~SENSORS_CORETEMP"
+
+src_compile() {
+ emake CC="$(tc-getCC)"
+}
+
+src_install() {
+ emake DESTDIR="${ED}" install
+
+ # Remove the empty systemd unit directory
+ # It doesn't actually install the unit file
+ rmdir --ignore-fail-on-non-empty -p "${ED%/}/lib/systemd/system" || die
+ # Actually install the sytstemd unit file
+ systemd_dounit ${PN}.service
+ # Install openrc init file
+ newinitd ${PN}.init.gentoo ${PN}
+
+ # make install doesn't install the docs in the right place
+ rm -rf "${ED%/}/usr/share/doc/${PN}" || die
+
+ einstalldocs
+}
diff --git a/app-laptop/mbpfan/mbpfan-9999.ebuild b/app-laptop/mbpfan/mbpfan-9999.ebuild
new file mode 100644
index 000000000000..357bf95cf287
--- /dev/null
+++ b/app-laptop/mbpfan/mbpfan-9999.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit linux-info systemd toolchain-funcs
+
+DESCRIPTION="A simple daemon to control fan speed on all Macbook/Macbook Pros"
+HOMEPAGE="https://github.com/dgraziotin/mbpfan"
+LICENSE="GPL-3+"
+SLOT="0"
+RESTRICT="test" # will fail if the hardware is unavailable, not useful
+
+if [[ "${PV}" = 9999 ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/dgraziotin/${PN}.git"
+ KEYWORDS=""
+else
+ SRC_URI="https://github.com/dgraziotin/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64"
+fi
+
+CONFIG_CHECK="~SENSORS_APPLESMC ~SENSORS_CORETEMP"
+
+src_compile() {
+ emake CC="$(tc-getCC)"
+}
+
+src_install() {
+ emake DESTDIR="${ED}" install
+
+ # Remove the empty systemd unit directory
+ # It doesn't actually install the unit file
+ rmdir --ignore-fail-on-non-empty -p "${ED%/}/lib/systemd/system" || die
+ # Actually install the sytstemd unit file
+ systemd_dounit ${PN}.service
+ # Install openrc init file
+ newinitd ${PN}.init.gentoo ${PN}
+
+ # make install doesn't install the docs in the right place
+ rm -rf "${ED%/}/usr/share/doc/${PN}" || die
+
+ einstalldocs
+}
diff --git a/app-laptop/mbpfan/metadata.xml b/app-laptop/mbpfan/metadata.xml
new file mode 100644
index 000000000000..95aa53e5c65e
--- /dev/null
+++ b/app-laptop/mbpfan/metadata.xml
@@ -0,0 +1,18 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>gokturk@gentoo.org</email>
+ <name>Göktürk Yüksek</name>
+ </maintainer>
+ <longdescription>
+ mbpfan is a daemon that uses input from coretemp module and sets
+ the fan speed using the applesmc module. This is an enhanced
+ version of Allan McRae mbpfan. This enhanced version assumes any
+ number of processors and fans.
+ </longdescription>
+ <upstream>
+ <bugs-to>https://github.com/dgraziotin/mbpfan/issues</bugs-to>
+ <remote-id type="github">dgraziotin/mbpfan</remote-id>
+ </upstream>
+</pkgmetadata>