summaryrefslogtreecommitdiff
path: root/app-laptop/hdaps-gl/hdaps-gl-0.0.5-r1.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'app-laptop/hdaps-gl/hdaps-gl-0.0.5-r1.ebuild')
-rw-r--r--app-laptop/hdaps-gl/hdaps-gl-0.0.5-r1.ebuild32
1 files changed, 32 insertions, 0 deletions
diff --git a/app-laptop/hdaps-gl/hdaps-gl-0.0.5-r1.ebuild b/app-laptop/hdaps-gl/hdaps-gl-0.0.5-r1.ebuild
new file mode 100644
index 000000000000..6e145279052f
--- /dev/null
+++ b/app-laptop/hdaps-gl/hdaps-gl-0.0.5-r1.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit toolchain-funcs
+
+DESCRIPTION="OpenGL visualization for HDAPS data"
+HOMEPAGE="http://hdaps.sourceforge.net"
+SRC_URI="mirror://sourceforge/hdaps/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+BDEPEND=""
+DEPEND="virtual/opengl
+ media-libs/freeglut"
+RDEPEND="${DEPEND}"
+
+PATCHES=( "${FILESDIR}/${P}-as-needed.diff" )
+
+src_compile() {
+ emake CC="$(tc-getCC)" \
+ CFLAGS="${CFLAGS} ${LDFLAGS}" \
+ || die "emake failed"
+}
+
+src_install() {
+ dobin "${PN}"
+}