summaryrefslogtreecommitdiff
path: root/app-i18n/mozc/mozc-9999.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'app-i18n/mozc/mozc-9999.ebuild')
-rw-r--r--app-i18n/mozc/mozc-9999.ebuild8
1 files changed, 6 insertions, 2 deletions
diff --git a/app-i18n/mozc/mozc-9999.ebuild b/app-i18n/mozc/mozc-9999.ebuild
index d7c66b558d92..e82d56df3360 100644
--- a/app-i18n/mozc/mozc-9999.ebuild
+++ b/app-i18n/mozc/mozc-9999.ebuild
@@ -1,8 +1,8 @@
-# Copyright 2010-2019 Gentoo Authors
+# Copyright 2010-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI="7"
-PYTHON_COMPAT=(python2_7)
+PYTHON_COMPAT=(python{3_6,3_7,3_8})
inherit elisp-common multiprocessing python-any-r1 toolchain-funcs
@@ -105,6 +105,10 @@ src_unpack() {
}
src_prepare() {
+ eapply -p2 "${FILESDIR}/${PN}-2.23.2815.102-python-3_1.patch"
+ eapply -p2 "${FILESDIR}/${PN}-2.23.2815.102-python-3_2.patch"
+ eapply -p2 "${FILESDIR}/${PN}-2.23.2815.102-python-3_3.patch"
+ eapply -p2 "${FILESDIR}/${PN}-2.23.2815.102-python-3_4.patch"
eapply -p2 "${FILESDIR}/${PN}-2.23.2815.102-system_libraries.patch"
eapply -p2 "${FILESDIR}/${PN}-2.23.2815.102-gcc-8.patch"
eapply -p2 "${FILESDIR}/${PN}-2.23.2815.102-protobuf_generated_classes_no_inheritance.patch"