summaryrefslogtreecommitdiff
path: root/app-i18n/ibus-typing-booster
diff options
context:
space:
mode:
Diffstat (limited to 'app-i18n/ibus-typing-booster')
-rw-r--r--app-i18n/ibus-typing-booster/Manifest2
-rw-r--r--app-i18n/ibus-typing-booster/ibus-typing-booster-2.14.4.ebuild48
2 files changed, 50 insertions, 0 deletions
diff --git a/app-i18n/ibus-typing-booster/Manifest b/app-i18n/ibus-typing-booster/Manifest
index 26b7cfdc9b53..621fc00d6001 100644
--- a/app-i18n/ibus-typing-booster/Manifest
+++ b/app-i18n/ibus-typing-booster/Manifest
@@ -1,5 +1,7 @@
DIST ibus-typing-booster-2.11.5.tar.gz 9485824 BLAKE2B 41d9aa2ba310e2db725e7809a67988fa69fee117b560d945a3cd935e7b2bbc372f448a531ed4ebd2a131dc1ffe3cb7d86b7d10fdbce56a2e241157f08a84ca69 SHA512 a30c81903b3d99f23a606f7f083615283ba64a0e62ac54183327447c33f6f7212472742036634522d36776a45ac72ce7874bcada624361f930785e2823652f0c
DIST ibus-typing-booster-2.14.0.tar.gz 10048272 BLAKE2B 638978811e6c7f4fa6607a7925aaf89636390391359c3e312a40ab759fff81066ea980995a3ec33f51dcb6fed5009d11bb90409c37b65c8f005b9769333e0cfb SHA512 5db5791e25caba4fa845c33198c20365c1e07cbbbfd6fe2d1d3145771b16031cc9baa55f950870fc11d4079ce04dac246603e45285550e856fc403342ae51676
+DIST ibus-typing-booster-2.14.4.tar.gz 10053545 BLAKE2B d0f941b937c1230ed9a947730fdc1bf9c3b5a255b1d3a63071fbe6c0595cf2d016aecaad4480770df34d1380c23b9db297fc57911dfb65e57952678593b2c05b SHA512 c8ab41fbc2bb401e342b317b0b20e0e9cd5c6ba529d0389b2b025db4295568b6f4ccadd639f622bd25078b6c2b8d5e336145c5397c580fb13012d4072333f523
EBUILD ibus-typing-booster-2.11.5.ebuild 1067 BLAKE2B a880c11bdd9d4d8ff1a1bfb707e0a7e17f490fab6e36a80c8c442d65aacd46303f7920e1f6a8fb1b2aac4b66dd5f9f577097d99334adf2db1108111624a0e775 SHA512 724c53725bf813dd05d956863f9672725459bc506aaaef30e2336562e41d47df1890cca6af2c1adbb76988eba82a2e9b9299288aa9daaaa85fc981f1d1f809d7
EBUILD ibus-typing-booster-2.14.0.ebuild 1069 BLAKE2B 7ddc93761c9e1007c0f4d9e09ccf8693d956d7f04a759b42187cfadb67b8f3de369dac596f4a0979caeb149f842565f633653d154675bc2bc7000941bb07176d SHA512 762f465a512bf1b62eba82dc0b6ccf494987ec12afa24c13f2a7a950cfa139977b9b7a2e37044c396cdd52bd34469cc1883a59b2ffa40b5f264060e4b49fb6d2
+EBUILD ibus-typing-booster-2.14.4.ebuild 1069 BLAKE2B 7ddc93761c9e1007c0f4d9e09ccf8693d956d7f04a759b42187cfadb67b8f3de369dac596f4a0979caeb149f842565f633653d154675bc2bc7000941bb07176d SHA512 762f465a512bf1b62eba82dc0b6ccf494987ec12afa24c13f2a7a950cfa139977b9b7a2e37044c396cdd52bd34469cc1883a59b2ffa40b5f264060e4b49fb6d2
MISC metadata.xml 240 BLAKE2B 3e01f599fdbafa5c02b594007c673bcfcccb41559bd2f42d7ea60a1f13932335cecf353c1216e8feba4bb091385b57f05c4c8b3c62eed6c7bea41e308fc6115c SHA512 12aaa73d9b690de68a5c7b20e214ceb099efa87884b784eafd994f26032b44dcb66e7feac8a5b1df7f349ac05c5a198a7593dff2cc686de158cb21e4c54f38dd
diff --git a/app-i18n/ibus-typing-booster/ibus-typing-booster-2.14.4.ebuild b/app-i18n/ibus-typing-booster/ibus-typing-booster-2.14.4.ebuild
new file mode 100644
index 000000000000..4e8cb0ffc7f7
--- /dev/null
+++ b/app-i18n/ibus-typing-booster/ibus-typing-booster-2.14.4.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="7"
+PYTHON_COMPAT=( python3_{8,9} )
+PYTHON_REQ_USE="sqlite(+)"
+
+inherit gnome2-utils python-single-r1 xdg
+
+DESCRIPTION="Completion input method for IBus"
+HOMEPAGE="https://mike-fabian.github.io/ibus-typing-booster"
+SRC_URI="https://github.com/mike-fabian/${PN}/releases/download/${PV}/${P}.tar.gz"
+
+LICENSE="GPL-3+"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+RESTRICT="test"
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+DEPEND="${PYTHON_DEPS}
+ dev-libs/m17n-lib
+ $(python_gen_cond_dep '
+ app-i18n/ibus[python(+),${PYTHON_USEDEP}]
+ dev-python/dbus-python[${PYTHON_USEDEP}]
+ dev-python/pyenchant[${PYTHON_USEDEP}]
+ dev-python/pygobject:3[${PYTHON_USEDEP}]
+ dev-python/pyxdg[${PYTHON_USEDEP}]
+ ')"
+RDEPEND="${DEPEND}
+ >=dev-db/m17n-db-1.7"
+BDEPEND="sys-devel/gettext
+ virtual/pkgconfig"
+
+pkg_preinst() {
+ xdg_pkg_preinst
+ gnome2_schemas_savelist
+}
+
+pkg_postinst() {
+ xdg_pkg_postinst
+ gnome2_schemas_update
+}
+
+pkg_postrm() {
+ xdg_pkg_postrm
+ gnome2_schemas_update
+}