summaryrefslogtreecommitdiff
path: root/app-i18n/ibus-typing-booster/ibus-typing-booster-2.14.0.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'app-i18n/ibus-typing-booster/ibus-typing-booster-2.14.0.ebuild')
-rw-r--r--app-i18n/ibus-typing-booster/ibus-typing-booster-2.14.0.ebuild48
1 files changed, 48 insertions, 0 deletions
diff --git a/app-i18n/ibus-typing-booster/ibus-typing-booster-2.14.0.ebuild b/app-i18n/ibus-typing-booster/ibus-typing-booster-2.14.0.ebuild
new file mode 100644
index 000000000000..4e8cb0ffc7f7
--- /dev/null
+++ b/app-i18n/ibus-typing-booster/ibus-typing-booster-2.14.0.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="7"
+PYTHON_COMPAT=( python3_{8,9} )
+PYTHON_REQ_USE="sqlite(+)"
+
+inherit gnome2-utils python-single-r1 xdg
+
+DESCRIPTION="Completion input method for IBus"
+HOMEPAGE="https://mike-fabian.github.io/ibus-typing-booster"
+SRC_URI="https://github.com/mike-fabian/${PN}/releases/download/${PV}/${P}.tar.gz"
+
+LICENSE="GPL-3+"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+RESTRICT="test"
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+DEPEND="${PYTHON_DEPS}
+ dev-libs/m17n-lib
+ $(python_gen_cond_dep '
+ app-i18n/ibus[python(+),${PYTHON_USEDEP}]
+ dev-python/dbus-python[${PYTHON_USEDEP}]
+ dev-python/pyenchant[${PYTHON_USEDEP}]
+ dev-python/pygobject:3[${PYTHON_USEDEP}]
+ dev-python/pyxdg[${PYTHON_USEDEP}]
+ ')"
+RDEPEND="${DEPEND}
+ >=dev-db/m17n-db-1.7"
+BDEPEND="sys-devel/gettext
+ virtual/pkgconfig"
+
+pkg_preinst() {
+ xdg_pkg_preinst
+ gnome2_schemas_savelist
+}
+
+pkg_postinst() {
+ xdg_pkg_postinst
+ gnome2_schemas_update
+}
+
+pkg_postrm() {
+ xdg_pkg_postrm
+ gnome2_schemas_update
+}