summaryrefslogtreecommitdiff
path: root/app-forensics/yara/yara-4.1.3.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'app-forensics/yara/yara-4.1.3.ebuild')
-rw-r--r--app-forensics/yara/yara-4.1.3.ebuild52
1 files changed, 0 insertions, 52 deletions
diff --git a/app-forensics/yara/yara-4.1.3.ebuild b/app-forensics/yara/yara-4.1.3.ebuild
deleted file mode 100644
index e11e07efff40..000000000000
--- a/app-forensics/yara/yara-4.1.3.ebuild
+++ /dev/null
@@ -1,52 +0,0 @@
-# Copyright 1999-2022 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-inherit autotools
-
-DESCRIPTION="A malware identification and classification tool"
-HOMEPAGE="http://virustotal.github.io/yara/"
-SRC_URI="https://github.com/virustotal/yara/archive/v${PV}.tar.gz -> ${P}.tar.gz"
-
-LICENSE="Apache-2.0"
-SLOT="0/8"
-KEYWORDS="~amd64 ~x86"
-IUSE="+dex +dotnet +cuckoo +macho +magic profiling python test"
-RESTRICT="!test? ( test )"
-
-DEPEND="
- dev-libs/openssl:=
- cuckoo? ( dev-libs/jansson:= )
- magic? ( sys-apps/file:= )
-"
-RDEPEND="${DEPEND}"
-PDEPEND="python? ( =dev-python/yara-python-$(ver_cut 1)* )"
-
-src_prepare() {
- default
- eautoreconf
-}
-
-src_configure() {
- econf \
- $(use_enable profiling) \
- $(use_enable cuckoo) \
- $(use_enable magic) \
- $(use_enable dotnet) \
- $(use_enable macho) \
- $(use_enable dex) \
- $(use_enable test static)
-}
-
-src_test() {
- emake check
-}
-
-src_install() {
- default
-
- # TODO: Allow tests to work against dyn. lib rather than building
- # statically just for tests.
- find "${ED}" -name '*.a' -delete || die
-}