summaryrefslogtreecommitdiff
path: root/app-eselect/eselect-php/eselect-php-9999.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'app-eselect/eselect-php/eselect-php-9999.ebuild')
-rw-r--r--app-eselect/eselect-php/eselect-php-9999.ebuild12
1 files changed, 9 insertions, 3 deletions
diff --git a/app-eselect/eselect-php/eselect-php-9999.ebuild b/app-eselect/eselect-php/eselect-php-9999.ebuild
index 34d741711590..aaf4cb6fd250 100644
--- a/app-eselect/eselect-php/eselect-php-9999.ebuild
+++ b/app-eselect/eselect-php/eselect-php-9999.ebuild
@@ -1,9 +1,10 @@
-# Copyright 1999-2020 Gentoo Authors
+# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
-inherit git-r3 autotools
+TMPFILES_OPTIONAL="yes"
+inherit autotools git-r3 tmpfiles
DESCRIPTION="PHP eselect module"
HOMEPAGE="https://gitweb.gentoo.org/proj/eselect-php.git/"
@@ -16,7 +17,8 @@ IUSE="fpm apache2"
# The "DirectoryIndex" line in 70_mod_php.conf requires mod_dir.
RDEPEND="app-admin/eselect
- apache2? ( www-servers/apache[apache2_modules_dir] )"
+ apache2? ( www-servers/apache[apache2_modules_dir] )
+ fpm? ( virtual/tmpfiles )"
src_prepare() {
default
@@ -36,3 +38,7 @@ src_configure() {
$(use_enable apache2) \
$(use_enable fpm)
}
+
+pkg_postinst() {
+ use fpm && tmpfiles_process php-fpm.conf
+}