summaryrefslogtreecommitdiff
path: root/app-eselect/eselect-iptables/eselect-iptables-20211203.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'app-eselect/eselect-iptables/eselect-iptables-20211203.ebuild')
-rw-r--r--app-eselect/eselect-iptables/eselect-iptables-20211203.ebuild24
1 files changed, 24 insertions, 0 deletions
diff --git a/app-eselect/eselect-iptables/eselect-iptables-20211203.ebuild b/app-eselect/eselect-iptables/eselect-iptables-20211203.ebuild
new file mode 100644
index 000000000000..d0c4b6ab4f07
--- /dev/null
+++ b/app-eselect/eselect-iptables/eselect-iptables-20211203.ebuild
@@ -0,0 +1,24 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DESCRIPTION="Manages the {,/usr}/sbin/iptables symlink"
+HOMEPAGE="https://wiki.gentoo.org/wiki/No_homepage"
+SRC_URI="https://dev.gentoo.org/~chutzpah/dist/iptables/${P}.tar.xz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha amd64 arm arm64 ~hppa ~ia64 ~m68k ~mips ppc ppc64 ~riscv ~s390 sparc x86"
+
+RDEPEND="app-admin/eselect"
+
+src_install() {
+ insinto /usr/share/eselect/modules
+ doins iptables.eselect
+
+ local symlink
+ for symlink in {eb,arp}tables; do
+ dosym iptables.eselect /usr/share/eselect/modules/${symlink}.eselect
+ done
+}