summaryrefslogtreecommitdiff
path: root/app-eselect/eselect-cblas
diff options
context:
space:
mode:
Diffstat (limited to 'app-eselect/eselect-cblas')
-rw-r--r--app-eselect/eselect-cblas/Manifest4
-rw-r--r--app-eselect/eselect-cblas/eselect-cblas-0.1.ebuild25
-rw-r--r--app-eselect/eselect-cblas/files/cblas.eselect-0.114
-rw-r--r--app-eselect/eselect-cblas/files/cblas.eselect.565
-rw-r--r--app-eselect/eselect-cblas/metadata.xml8
5 files changed, 116 insertions, 0 deletions
diff --git a/app-eselect/eselect-cblas/Manifest b/app-eselect/eselect-cblas/Manifest
new file mode 100644
index 000000000000..b18ff5c03cad
--- /dev/null
+++ b/app-eselect/eselect-cblas/Manifest
@@ -0,0 +1,4 @@
+AUX cblas.eselect-0.1 352 BLAKE2B 37d0a10ae67971ff3282620343b971e6ab495c69017b9bf37e0d94f7ac1672e9d861d5f86958483a526ed1e0b2b76f2ca61a352238db349370ae298fc435e9ca SHA512 3f030c57d59a48817ee1eeafb3e967395c57f7f46724ffe134fcc58e6b4a3f37cad368fb4ab7f7e3cecf9a91bee4f7e1ef315dfcae6d0abbd80c7f85decc4f76
+AUX cblas.eselect.5 2084 BLAKE2B e53c8453fb20a575affa39a8d8980f4726561aa0ddbf16e59e9ad715c8c0d333bb23a767a415bb726099d2e2fb1ea943ca7421fb09d90c94922aa7a3d06b801d SHA512 1cc53334d65439a00bd3836bfaa5e130d946d0878d6a440974ff218d79aa10d3099edc7a84c94b300d742b96153d535649cd1580e2bd226d784a4dddc4a3cd41
+EBUILD eselect-cblas-0.1.ebuild 735 BLAKE2B dc5b954cb350a68c064a7bc50ae465a7a0869aa67d4481b2c785ce843d5939aec7dae678d6c1fc056df152526311f6b8c1fb38459359f71e464acda97312a807 SHA512 9d7c0798ed731d60193f1d90d5866b0b104f35ac418902d6f3083143f8a79aa019bf2defb62d6928cd28ffb0b5da11c4404c0f551e199cbd1a0f2c3264e92cdd
+MISC metadata.xml 249 BLAKE2B 03207049d5e7c62319639b2c37769d9d8c0d9cbf1e44fbc6cab9ea006e60bff3526193fea60902a0e64a362b02463104969700074602e31d8fb8f86a042d1ed8 SHA512 29a9c1817fd4299246d5fa995b73b9f1996b112b70f468139cf9cd8f07077d831e0788d3b93aaba67bb38dce5850830c27543fccbddbac02b0da4ff899def519
diff --git a/app-eselect/eselect-cblas/eselect-cblas-0.1.ebuild b/app-eselect/eselect-cblas/eselect-cblas-0.1.ebuild
new file mode 100644
index 000000000000..91a1679d74ff
--- /dev/null
+++ b/app-eselect/eselect-cblas/eselect-cblas-0.1.ebuild
@@ -0,0 +1,25 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=0
+
+DESCRIPTION="C-language BLAS module for eselect"
+HOMEPAGE="https://www.gentoo.org/proj/en/eselect/"
+SRC_URI=""
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="alpha amd64 arm ~arm64 hppa ia64 ~mips ppc ppc64 s390 sh sparc x86 ~amd64-fbsd ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~x86-solaris"
+IUSE=""
+
+# Need skel.bash lib
+RDEPEND=">=app-admin/eselect-1.0.5"
+DEPEND="${RDEPEND}"
+
+src_install() {
+ local MODULEDIR="/usr/share/eselect/modules"
+ local MODULE="cblas"
+ insinto ${MODULEDIR}
+ newins "${FILESDIR}"/${MODULE}.eselect-${PVR} ${MODULE}.eselect
+ doman "${FILESDIR}"/cblas.eselect.5
+}
diff --git a/app-eselect/eselect-cblas/files/cblas.eselect-0.1 b/app-eselect/eselect-cblas/files/cblas.eselect-0.1
new file mode 100644
index 000000000000..2fff5981450a
--- /dev/null
+++ b/app-eselect/eselect-cblas/files/cblas.eselect-0.1
@@ -0,0 +1,14 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+inherit skel
+
+MODULE="CBLAS"
+IFACE="cblas"
+
+DESCRIPTION="Manage installed $MODULE implementations"
+MAINTAINER="spyderous@gentoo.org"
+SVN_DATE='$Date: 2015/03/31 16:47:06 $'
+VERSION=$(svn_date_to_version "${SVN_DATE}" )
+
+# vim: set ft=eselect :
diff --git a/app-eselect/eselect-cblas/files/cblas.eselect.5 b/app-eselect/eselect-cblas/files/cblas.eselect.5
new file mode 100644
index 000000000000..6409002d74b6
--- /dev/null
+++ b/app-eselect/eselect-cblas/files/cblas.eselect.5
@@ -0,0 +1,65 @@
+.TH "ESELECT" "5" "June 2006" "Gentoo Linux" "eselect"
+.SH "NAME"
+cblas.eselect \- The CBLAS management module for Gentoo's eselect
+.SH "SYNOPSIS"
+\fBeselect cblas\fR [\fBhelp\fR|\fBusage\fR]
+.br
+\fBeselect cblas\fR \fBlist\fR [\fIoptions\fR]
+.br
+\fBeselect cblas\fR \fBadd\fR
+.br
+\fBeselect cblas\fR \fBset\fR \fIimplementation\fR [\fIoptions\fR]
+.br
+\fBeselect cblas\fR \fBshow\fR [\fIoptions\fR]
+
+.SH "DESCRIPTION"
+\fBeselect\fR is Gentoo's configuration and management tool. It features
+modules that care for the individual administrative tasks.
+.SH "ACTION: LIST"
+\fBeselect cblas list\fR [\fIoptions\fR]
+.br
+Displays an ordered list of installed CBLAS implementations. It distinguishes between versions with different
+Application Binary Interfaces (e.g. x86/AMD64). Furthermore, it also distinguishes
+between interfaces to high-level programming languages. Each line holds
+a number and the implementation's name. An asterisk next to one of the list
+elements denotes an active implementation.
+
+phi / # eselect cblas list
+.br
+Installed CBLAS for libdir \fBlib\fR
+.br
+ [1] atlas *
+ [2] reference
+
+Possible \fIoptions\fR to the \fBlist\fR action are restrictions to
+handle only certain ABI\-specific library directories. For example,
+
+\fBeselect cblas list lib64\fR
+
+lists only CBLAS implementations found in \fB/usr/lib64\fR.
+
+.SH "ACTION: SHOW"
+\fBeselect cblas show\fR [\fIoptions\fR]
+.br
+Shows your system's currently active CBLAS implementations.
+
+phi / # eselect cblas show
+.br
+lib: atlas
+.br
+lib64: reference
+
+The same \fIoptions\fR that apply to the \fBlist\fR action can be used
+with the \fBshow\fR action to restrict it to given ABIs.
+.SH "ACTION: SET"
+\fBeselect cblas set\fR \fIimplementation\fR [\fIoptions\fR]
+.br
+Sets your system's currently active CBLAS implementations to \fIimplementation\fR.
+The same \fIoptions\fR that apply to the \fBlist\fR action can be used
+with the \fBset\fR action to restrict it to given ABIs.
+
+phi / # eselect cblas set atlas
+.SH "AUTHOR"
+Danny van Dyk <kugelfang@gentoo.org>
+.br
+Donnie Berkholz <spyderous@gentoo.org>
diff --git a/app-eselect/eselect-cblas/metadata.xml b/app-eselect/eselect-cblas/metadata.xml
new file mode 100644
index 000000000000..0c6991d7902b
--- /dev/null
+++ b/app-eselect/eselect-cblas/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<maintainer type="project">
+ <email>sci@gentoo.org</email>
+ <name>Gentoo Science Project</name>
+</maintainer>
+</pkgmetadata>