summaryrefslogtreecommitdiff
path: root/app-emulation
diff options
context:
space:
mode:
Diffstat (limited to 'app-emulation')
-rw-r--r--app-emulation/Manifest.gzbin15503 -> 15509 bytes
-rw-r--r--app-emulation/punes/Manifest2
-rw-r--r--app-emulation/punes/files/punes-0.111-qt6.7_Q_OBJECT.patch17
-rw-r--r--app-emulation/punes/punes-0.111-r1.ebuild56
4 files changed, 75 insertions, 0 deletions
diff --git a/app-emulation/Manifest.gz b/app-emulation/Manifest.gz
index e31ed218f68a..c0083a349025 100644
--- a/app-emulation/Manifest.gz
+++ b/app-emulation/Manifest.gz
Binary files differ
diff --git a/app-emulation/punes/Manifest b/app-emulation/punes/Manifest
index e46b3766305c..0d640fbf91f3 100644
--- a/app-emulation/punes/Manifest
+++ b/app-emulation/punes/Manifest
@@ -1,4 +1,6 @@
AUX punes-0.111-FULLSCREEN_RESFREQ-fix.patch 985 BLAKE2B b68b81b68eabcab5af17a2a9852eb542f4b81866de94552fd0d12b45b72effaf7bb197bf87e083126dd30a0d757774fbdcbe579c73087e5214968c8c7d240ada SHA512 70a868177c62fc9f03332995104cc72dedef83d75524f53c3c057ac3ccbc8c0e667d33e5eee9a53a8bbe63e5bffbe7335e27c7e361b988b7ce91cbbc5b00551a
+AUX punes-0.111-qt6.7_Q_OBJECT.patch 559 BLAKE2B 7e6858bbe360d1d22374e03803cd421c4e66605a20daa35627c4551de61858e911a937ba5c63f4db8eb59a2686b57282aecb2e57ec84685253d924d9d14f3393 SHA512 c9fddb201de54efeedf020f60d42583d5dce62998ba42003c8b021ecd148f3cb1834b3839dd4f8eab2e1fe8742a3630b8e50f61bbef35ef0ca1825cc01a498e5
DIST punes-0.111.tar.gz 57538299 BLAKE2B a900fe2bc9117e6739e58a43e457bfa466053d5a96ae5ad1333d7e0bc11eafb2408a96dc7e35ddf1a3cee50cafe99549a43d2abb629b106bbb1082878a845cc6 SHA512 6388cdf2b303e217adfe43b1b3b1ef66a75b6adfdb0363b213c47fc129b5815f3e96814ee25a3637147dc184203cef0438930c280f0c6249085ecac1220b435c
+EBUILD punes-0.111-r1.ebuild 1152 BLAKE2B cfb97f142a3bb99bca86902480ab1c7055f07c1b28d182703cf8dda9decee400fdc093e4cf21e187f54106dddc6d7e699c4494cbecc8eb328b395c36a85c5e32 SHA512 09888a38aebec448824eafd8f39a3ab8c3f3fb45be9de0bbb1027e86786486c58f62bfe2d9d3614ab7ea2fb3f225e4604f5873b6e25b178189389c00a9e8e03f
EBUILD punes-0.111.ebuild 1277 BLAKE2B 1907cfcfe82be3469eecb941c7ab720a14d05a1380b449fac1a7f3f6e55f3fe7e7ae3b87ff5660e2508380032f2607f3b13488ac02ab52bf404d1ccd823d5ea0 SHA512 75a8e5876df8e677bc3b818462aaf621abccf0a9bae025d92556acef14579a25b3c3a66d33c7077c0d6808a69ca034c93b505ae22792937cf3a6a7d6ebae40c2
MISC metadata.xml 560 BLAKE2B ea221c8fefa3fc3e9f8942ae7cfd642384cde9ec10949bc148e17727e0633f718140fa15675a3268674c80e6b55177ff5573460abd687bc76420673f76aecc8a SHA512 7676ca51eb1d02c6564dfd9ef47975f349856ae9536e3f1d9771bf4c56a2aebe86622461ae50b5989c56fffa1cfa92fc6185f1d62d933c4db5016acc4c280a8f
diff --git a/app-emulation/punes/files/punes-0.111-qt6.7_Q_OBJECT.patch b/app-emulation/punes/files/punes-0.111-qt6.7_Q_OBJECT.patch
new file mode 100644
index 000000000000..4b368c980112
--- /dev/null
+++ b/app-emulation/punes/files/punes-0.111-qt6.7_Q_OBJECT.patch
@@ -0,0 +1,17 @@
+https://github.com/punesemu/puNES/commit/6e51b1a6107ad3de97edd40ae4ec2d41b32d804f.patch
+From: Cosima Neidahl <opna2608@protonmail.com>
+Date: Fri, 31 May 2024 14:48:50 +0200
+Subject: [PATCH] Fix compatibility with Qt 6.7.1 (#403)
+
+Upstream QTBUG-105023 fix made it mandatory that arguments to QObject::findChild[ren] calls must be Q_OBJECTs.
+--- a/src/gui/dlgStdPad.hpp
++++ b/src/gui/dlgStdPad.hpp
+@@ -47,6 +47,8 @@ typedef struct _joy_list {
+ extern _joy_list joy_list;
+
+ class pixmapButton: public QPushButton {
++ Q_OBJECT
++
+ private:
+ QPixmap pixmap;
+
diff --git a/app-emulation/punes/punes-0.111-r1.ebuild b/app-emulation/punes/punes-0.111-r1.ebuild
new file mode 100644
index 000000000000..8396e9844c88
--- /dev/null
+++ b/app-emulation/punes/punes-0.111-r1.ebuild
@@ -0,0 +1,56 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit cmake xdg
+
+DESCRIPTION="Nintendo Entertainment System (NES) emulator"
+HOMEPAGE="https://github.com/punesemu/puNES"
+SRC_URI="https://github.com/punesemu/puNES/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+S="${WORKDIR}/puNES-${PV}"
+
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="X cg ffmpeg"
+
+RDEPEND="
+ dev-qt/qtbase:6[gui,network,opengl,widgets]
+ dev-qt/qtsvg:6
+ media-libs/alsa-lib
+ media-libs/libglvnd[X?]
+ virtual/glu
+ virtual/udev
+ X? (
+ x11-libs/libX11
+ x11-libs/libXrandr
+ )
+ cg? ( media-gfx/nvidia-cg-toolkit )
+ ffmpeg? ( media-video/ffmpeg:= )
+"
+
+DEPEND="
+ ${RDEPEND}
+ X? ( x11-base/xorg-proto )"
+BDEPEND="
+ virtual/pkgconfig
+ dev-qt/qttools[linguist]
+"
+
+PATCHES=(
+ "${FILESDIR}/punes-0.111-FULLSCREEN_RESFREQ-fix.patch"
+ "${FILESDIR}/punes-0.111-qt6.7_Q_OBJECT.patch"
+)
+
+src_configure() {
+ local mycmakeargs=(
+ -DENABLE_GIT_INFO=OFF
+ -DENABLE_QT6_LIBS=ON
+ -DDISABLE_PORTABLE_MODE=OFF
+ -DENABLE_FFMPEG=$(usex ffmpeg)
+ -DENABLE_FULLSCREEN_RESFREQ=$(usex X)
+ -DENABLE_OPENGL_CG=$(usex cg)
+ )
+ cmake_src_configure
+}