summaryrefslogtreecommitdiff
path: root/app-emulation
diff options
context:
space:
mode:
Diffstat (limited to 'app-emulation')
-rw-r--r--app-emulation/Manifest.gzbin15320 -> 15318 bytes
-rw-r--r--app-emulation/vagrant/Manifest4
-rw-r--r--app-emulation/vagrant/files/vagrant.in2
-rw-r--r--app-emulation/vagrant/vagrant-2.3.7.ebuild121
4 files changed, 125 insertions, 2 deletions
diff --git a/app-emulation/Manifest.gz b/app-emulation/Manifest.gz
index ab24610922d8..6124725d45ee 100644
--- a/app-emulation/Manifest.gz
+++ b/app-emulation/Manifest.gz
Binary files differ
diff --git a/app-emulation/vagrant/Manifest b/app-emulation/vagrant/Manifest
index ac587c50cb67..fccb9bf6295c 100644
--- a/app-emulation/vagrant/Manifest
+++ b/app-emulation/vagrant/Manifest
@@ -1,4 +1,6 @@
-AUX vagrant.in 1872 BLAKE2B 691c0f55c937eb895b26a95f34053f547ce7511c2ba21cbc1c58f14578559bac91cb33a47dd401dcbada0c34f8ba89be379bb294ba2e7e3efa08cccf8fdf01b9 SHA512 89ff931b4fe4ebc58d026f3af17e2bcbef008e50d3b52d7aa7c56b6f51a24d4408767f09b34a7d231643da59b54e3949d4b010ce9f4b1c3b639ba3ba4785a776
+AUX vagrant.in 1886 BLAKE2B 44015e7648cd32b26eb1b1901d3fc13a3eef83a3028332c7bcfd171162eec7b79e0ed7a1b4197a9425a9f53e4ded255d6fc6ab9bb211c6ee13b794cb58c8cc90 SHA512 08ebb998cbe882cd14b2801eea044423f80dad08cb46010b3afc5dc98dcd323028442ac3061c82269d0639ff2af751b25a3aeccadcd6205c64436707dd2930a5
DIST vagrant-2.2.19.tar.gz 1838272 BLAKE2B cb707254379f52db8571bfe132e5b852a11998d86b43ee707e03d442ca1313da7b2612af027a58f806e0b551a6f415d121dab51cf7ea5da4292e5c2afd198ab9 SHA512 24a2e5baeac5cf8c45c012cf70dd4132b1dc7a6a5bab19d1046c91cc88e669356e2e5676d96eda6ed7293ff19ada974954969a4a59b9e4a30e2d95de27fa64e4
+DIST vagrant-2.3.7.tar.gz 3296042 BLAKE2B 720e16bed6f9088558f7a8a2af7925946c71d771fc732fd43fc277f160faa1d2c86bdb3eaab6ec0cf569e945a30593655f3551608f708ee74203392ba61ce11f SHA512 a65b1c48fad6eb04fc0097dc7c8dc4e37467c5e6406d1d384a017b127704ebd6872cd0cc69ef38b393c98d6fd58c39c806e7ef439c2b55a15bf66c3647595cc2
EBUILD vagrant-2.2.19-r2.ebuild 2412 BLAKE2B fc275e640f5924fd75d15a156cec8ce8fcf229ff2c99ce65232041c4dc4c0186e1dab8c2c1875aab74762388acfad47f21aa87ea3387090c75f5dda3feceba8d SHA512 a3c367f6292d503fc92af7fac79cb40a17d6f2ff9d00e6e706cbc987cfbb45ecad36ffc6b32371ce7b7b29840908a91d835eb252eeca323507c9d6c35bc38c96
+EBUILD vagrant-2.3.7.ebuild 3378 BLAKE2B 1fec2008b52a3634cde5e922ed7b330dd7fdf44324843f7514a12ff813b9bae49646baae8a001d82cc0e4030b0fff9987565ca228e05369a2122aeaaf0b28bb0 SHA512 971543d0972d4ddd5442a874f0c9952569fe381ce8c07c284ab013a65b715b48271c1f9f92077219a5613bf800c80b7bcbab2f7b3643002103ef7ca43284820f
MISC metadata.xml 455 BLAKE2B 01bf09c745e55dcdf7241dfdae1349fbb403f61249c0b05944347cb2f5cdf7d6a5fc7807a3f351145a41e4a5a94a5ba22195acee7c352539144277fff4696faf SHA512 1117ae7aca289842ab10ec2cf4443bf36ef7bdcd9efd0b6d1df1879f253cc137fea027a939c52f8d6990cae7a83bffafeb69f7b10660f27d278f19578ecccabd
diff --git a/app-emulation/vagrant/files/vagrant.in b/app-emulation/vagrant/files/vagrant.in
index d77c39d06045..0dfd12d10148 100644
--- a/app-emulation/vagrant/files/vagrant.in
+++ b/app-emulation/vagrant/files/vagrant.in
@@ -4,7 +4,7 @@
# Vagrant installation directory. This sets up proper environmental variables
# so that everything loads and compiles to proper directories.
-for r in ruby30 ruby27 ruby26; do
+for r in ruby32 ruby31 ruby30 ruby27 ruby26; do
# not all ruby versions are guaranteed to be installed
if ! command -v "${r}" >/dev/null 2>&1; then
continue
diff --git a/app-emulation/vagrant/vagrant-2.3.7.ebuild b/app-emulation/vagrant/vagrant-2.3.7.ebuild
new file mode 100644
index 000000000000..7778433218ed
--- /dev/null
+++ b/app-emulation/vagrant/vagrant-2.3.7.ebuild
@@ -0,0 +1,121 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+USE_RUBY="ruby31"
+
+RUBY_FAKEGEM_EXTENSIONS=(ext/vagrant_ssl/extconf.rb)
+RUBY_FAKEGEM_EXTRADOC="CHANGELOG.md README.md"
+RUBY_FAKEGEM_GEMSPEC="vagrant.gemspec"
+RUBY_FAKEGEM_EXTRAINSTALL="keys plugins templates version.txt"
+RUBY_FAKEGEM_TASK_DOC=""
+RUBY_FAKEGEM_TASK_TEST=test:unit
+RUBY_FAKEGEM_RECIPE_TEST=rake
+
+inherit bash-completion-r1 optfeature ruby-fakegem
+
+DESCRIPTION="A tool for building and distributing development environments"
+HOMEPAGE="https://vagrantup.com/"
+SRC_URI="https://github.com/hashicorp/vagrant/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+RDEPEND="
+ ${RDEPEND}
+ app-arch/libarchive
+ net-misc/curl
+"
+
+ruby_add_rdepend "
+ >=dev-ruby/bcrypt_pbkdf-1.1.0
+ >=dev-ruby/childprocess-4.1.0
+ >=dev-ruby/ed25519-1.3.0
+ dev-ruby/erubi
+ >=dev-ruby/googleapis-common-protos-types-1.3.0
+ dev-ruby/grpc
+ >=dev-ruby/hashicorp-checkpoint-0.1.5
+ >=dev-ruby/i18n-1.12:1
+ >=dev-ruby/listen-3.7
+ >=dev-ruby/log4r-1.1.9
+ <dev-ruby/log4r-1.1.11
+ >=dev-ruby/mime-types-3.3:*
+ >=dev-ruby/net-ftp-0.2.0
+ >=dev-ruby/net-ssh-7.0.0
+ >=dev-ruby/net-sftp-4.0.0
+ >=dev-ruby/net-scp-4.0.0
+ >=dev-ruby/rexml-3.2.0
+ >=dev-ruby/rgl-0.5.10
+ >=dev-ruby/rubyzip-2.3.2
+ >=dev-ruby/vagrant_cloud-3.0.5
+ >=dev-ruby/ipaddr-1.2.4
+"
+
+ruby_add_bdepend "
+ >=dev-ruby/rake-13.0.0
+ test? (
+ ~app-emulation/vagrant-${PV}
+ dev-ruby/rake-compiler
+ >=dev-ruby/rspec-3.11
+ >=dev-ruby/rspec-its-1.3.0
+ >=dev-ruby/webrick-1.7.0
+ )
+"
+
+all_ruby_prepare() {
+ # remove bundler support
+ sed -e '/[Bb]undler/ s:^:#:' \
+ -e '/extensiontask/ s:^:#:' \
+ -e '/ExtensionTask/,/^end/ s:^:#:' \
+ -i Rakefile || die
+ rm Gemfile || die
+ rm tasks/bundler.rake || die
+
+ sed -e ':rake\|rspec: s:~>:>=:' \
+ -e ':bcrypt_pbkdf\|hashicorp-checkpoint\|i18n\|listen\|net-ssh\|net-scp\|net-sftp\|childprocess: s:~>:>=:' \
+ -e '/fake_ftp/ s:^#*:#:' \
+ -e '/wdm/ s:^#*:#:' \
+ -e '/winrm/ s:^#*:#:' \
+ -e '/rb-kqueue/ s:^#*:#:' \
+ -e '/ruby_dep/ s:^#*:#:' \
+ -i ${PN}.gemspec || die
+
+ sed -e "s/@VAGRANT_VERSION@/${PV}/g" "${FILESDIR}/${PN}.in" > "${PN}" || die
+
+ sed -i -e 's/format documentation/format progress/' tasks/test.rake || die
+
+ # Avoid tests confused by the environment
+ rm -f test/unit/vagrant/util/env_test.rb || die
+
+ # Avoid tests for Windows-specific components
+ rm -rf test/unit/plugins/communicators/winrm || die
+ sed -e '/eager loads WinRM/askip "Windows component"' \
+ -e '/should return the specified communicator if given/askip "Windows component"' \
+ -i test/unit/vagrant/machine_test.rb || die
+ sed -e '/with winrm communicator/ s/context/xcontext/' \
+ -i test/unit/plugins/provisioners/ansible/provisioner_test.rb || die
+}
+
+all_ruby_install() {
+ all_fakegem_install
+
+ newbashcomp contrib/bash/completion.sh ${PN}
+
+ # provide executable similar to upstream:
+ # https://github.com/hashicorp/vagrant-installers/blob/master/substrate/modules/vagrant_installer/templates/vagrant.erb
+ dobin "${PN}"
+
+ # directory for plugins.json
+ keepdir /var/lib/vagrant
+
+ insinto /usr/share/vim/vimfiles/syntax/
+ doins contrib/vim/vagrantfile.vim
+
+ optfeature_header "Optional emulation/container backends:"
+ optfeature "VirtualBox support" app-emulation/virtualbox
+ optfeature "Docker support" app-containers/docker
+}