summaryrefslogtreecommitdiff
path: root/app-emulation/wine-vanilla/wine-vanilla-7.10.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'app-emulation/wine-vanilla/wine-vanilla-7.10.ebuild')
-rw-r--r--app-emulation/wine-vanilla/wine-vanilla-7.10.ebuild4
1 files changed, 3 insertions, 1 deletions
diff --git a/app-emulation/wine-vanilla/wine-vanilla-7.10.ebuild b/app-emulation/wine-vanilla/wine-vanilla-7.10.ebuild
index 2fb6362afb24..ddd54410ad78 100644
--- a/app-emulation/wine-vanilla/wine-vanilla-7.10.ebuild
+++ b/app-emulation/wine-vanilla/wine-vanilla-7.10.ebuild
@@ -297,7 +297,9 @@ src_configure() {
# use *FLAGS for mingw, but strip unsupported (e.g. --hash-style=gnu)
local mingwcc=${CROSSCC:-$(usex x86 i686 x86_64)-w64-mingw32-gcc}
: "${CROSSCFLAGS:=$(CC=${mingwcc} test-flags-CC ${CFLAGS:--O2})}"
- : "${CROSSLDFLAGS:=$(CC=${mingwcc} test-flags-CCLD ${LDFLAGS})}"
+ : "${CROSSLDFLAGS:=$(
+ filter-flags '-fuse-ld=*'
+ CC=${mingwcc} test-flags-CCLD ${LDFLAGS})}"
export CROSS{C,LD}FLAGS
fi