summaryrefslogtreecommitdiff
path: root/app-emulation/wine-staging
diff options
context:
space:
mode:
Diffstat (limited to 'app-emulation/wine-staging')
-rw-r--r--app-emulation/wine-staging/Manifest2
-rw-r--r--app-emulation/wine-staging/wine-staging-9999.ebuild27
2 files changed, 6 insertions, 23 deletions
diff --git a/app-emulation/wine-staging/Manifest b/app-emulation/wine-staging/Manifest
index 74cf1390c0b7..b328b1a6edea 100644
--- a/app-emulation/wine-staging/Manifest
+++ b/app-emulation/wine-staging/Manifest
@@ -11,5 +11,5 @@ DIST wine-staging-9.0.tar.gz 9577631 BLAKE2B 0012978f54c618e73d407dd49dccff02853
EBUILD wine-staging-10.0.ebuild 15622 BLAKE2B c5b6dfd62b9349b62d321c0387e6865a1f57d1aa3618160778988e7bae088ec7150d7159187e2d6c9b6f0975f0adc7a338bb499443a6ba5c4c957dd05e3cc2d3 SHA512 ae7aaac96d218a2e14b7d2cad6c67a4687a4326c24f494ec1b819916b6e4a06f51122bc2dd225e8b9a8df45ee2b8185b954c2a04750fa6e658e21bd3058d5fcb
EBUILD wine-staging-10.1.ebuild 15622 BLAKE2B c5b6dfd62b9349b62d321c0387e6865a1f57d1aa3618160778988e7bae088ec7150d7159187e2d6c9b6f0975f0adc7a338bb499443a6ba5c4c957dd05e3cc2d3 SHA512 ae7aaac96d218a2e14b7d2cad6c67a4687a4326c24f494ec1b819916b6e4a06f51122bc2dd225e8b9a8df45ee2b8185b954c2a04750fa6e658e21bd3058d5fcb
EBUILD wine-staging-9.0.ebuild 15827 BLAKE2B c5943aca5853c48e7738344a4dd3e527af8f9b17f38a4062e16009c51ccbf6b351f4ccee1b9fe06c7a606f7255c0293ee7f8090a6d3e11ca288ef7f41cbfc260 SHA512 e0f743a8d86e93e166f45148780e52c9582fdfd94a93a685c95694469a83c7333129efcc4fd63e9942a41111a6ff5015ca50158c76160494be91829671f4c58f
-EBUILD wine-staging-9999.ebuild 15577 BLAKE2B 89236ab018b719162dcd15ce17e8130983b223596f3a434444cea02716ecce181f059606d90e3344e0aa14dc99582ae45989f9a685a527639dc1ce700ea3c02a SHA512 57ec46c07d740785b9f3322f1efa94fa3b0ec653d4366ad037103433fd58f4d8d6c733adf2bcc990e9f88e532e998dc2d92547800c59585bf7dedc62e0ad8b30
+EBUILD wine-staging-9999.ebuild 14927 BLAKE2B 206cc77280c4c086bdd24c9753a0ac17e94b789e30f813367e6757290d87b1258b35c91200a10072a3202cdb0d460d816cf62ec7597c1d27cc582476c055d037 SHA512 185ece52b99d56c29e309434404d733bfc0158b6009954feb105cc64afb53b727891aaf675f72a9a1c053b96a1df2ab1e93eda06cdce7812b24f7d787fc31cf6
MISC metadata.xml 2718 BLAKE2B 6848ef9723706ba3437fe18dbacf798cc2f266545c9241ceb9b5e83600bd1e82e80e9bc1d963f7a62e3b974af90d6e330305aaa77b9d578e20201ba1172fd775 SHA512 c89ca2bce23e50982f5cf846d58fe9f962da0eb8e13d7065fbba5e07afa072a9df000accf1fdb3829225b1fe3434d706be55749aa6b7d34e1f28ac91f82fa436
diff --git a/app-emulation/wine-staging/wine-staging-9999.ebuild b/app-emulation/wine-staging/wine-staging-9999.ebuild
index 079299786741..a759ced54cf4 100644
--- a/app-emulation/wine-staging/wine-staging-9999.ebuild
+++ b/app-emulation/wine-staging/wine-staging-9999.ebuild
@@ -1,4 +1,4 @@
-# Copyright 2022-2024 Gentoo Authors
+# Copyright 2022-2025 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
@@ -401,27 +401,10 @@ src_install() {
use abi_x86_32 && emake DESTDIR="${D}" -C ../build32 install
use abi_x86_64 && emake DESTDIR="${D}" -C ../build64 install # do last
- # Ensure both wine64 and wine are available if USE=abi_x86_64 (wow64,
- # -abi_x86_32, and/or EXTRA_ECONF could cause varying scenarios where
- # one or the other could be missing and that is unexpected for users
- # and some tools like winetricks)
- if use abi_x86_64; then
- if [[ -e ${ED}${WINE_PREFIX}/bin/wine64 && ! -e ${ED}${WINE_PREFIX}/bin/wine ]]; then
- dosym wine64 ${WINE_PREFIX}/bin/wine
- dosym wine64-preloader ${WINE_PREFIX}/bin/wine-preloader
-
- # also install wine(1) man pages (incl. translations)
- local man
- for man in ../build64/loader/wine.*man; do
- : "${man##*/wine}"
- : "${_%.*}"
- insinto ${WINE_DATADIR}/man/${_:+${_#.}/}man1
- newins ${man} wine.1
- done
- elif [[ ! -e ${ED}${WINE_PREFIX}/bin/wine64 && -e ${ED}${WINE_PREFIX}/bin/wine ]]; then
- dosym wine ${WINE_PREFIX}/bin/wine64
- dosym wine-preloader ${WINE_PREFIX}/bin/wine64-preloader
- fi
+ # "wine64" is no longer provided, but a keep symlink for old scripts
+ # TODO: remove the guard later, only useful for bisecting -9999
+ if [[ ! -e ${ED}${WINE_PREFIX}/bin/wine64 ]]; then
+ use abi_x86_64 && dosym wine ${WINE_PREFIX}/bin/wine64
fi
use perl || rm "${ED}"${WINE_DATADIR}/man/man1/wine{dump,maker}.1 \