summaryrefslogtreecommitdiff
path: root/app-emulation/wine-staging/wine-staging-8.12.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'app-emulation/wine-staging/wine-staging-8.12.ebuild')
-rw-r--r--app-emulation/wine-staging/wine-staging-8.12.ebuild12
1 files changed, 12 insertions, 0 deletions
diff --git a/app-emulation/wine-staging/wine-staging-8.12.ebuild b/app-emulation/wine-staging/wine-staging-8.12.ebuild
index 4c8102d89813..f2f9ddf5ead8 100644
--- a/app-emulation/wine-staging/wine-staging-8.12.ebuild
+++ b/app-emulation/wine-staging/wine-staging-8.12.ebuild
@@ -214,6 +214,18 @@ src_prepare() {
default
+ if tc-is-clang; then
+ if use mingw; then
+ # -mabi=ms was ignored by <clang:16 then turned error in :17
+ # and it still gets used in install phase despite USE=mingw,
+ # drop as a quick fix for now which hopefully should be safe
+ sed -i '/MSVCRTFLAGS=/s/-mabi=ms//' configure.ac || die
+ else
+ # ./configure will abort looking for -mabi=ms, so do it early
+ die "building ${PN} with clang requires USE=mingw to be enabled"
+ fi
+ fi
+
# ensure .desktop calls this variant + slot
sed -i "/^Exec=/s/wine /${P} /" loader/wine.desktop || die