summaryrefslogtreecommitdiff
path: root/app-emulation/wine-staging/wine-staging-7.19.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'app-emulation/wine-staging/wine-staging-7.19.ebuild')
-rw-r--r--app-emulation/wine-staging/wine-staging-7.19.ebuild25
1 files changed, 10 insertions, 15 deletions
diff --git a/app-emulation/wine-staging/wine-staging-7.19.ebuild b/app-emulation/wine-staging/wine-staging-7.19.ebuild
index 8f5c2fb8b316..f4d6cc01a97f 100644
--- a/app-emulation/wine-staging/wine-staging-7.19.ebuild
+++ b/app-emulation/wine-staging/wine-staging-7.19.ebuild
@@ -115,12 +115,13 @@ DEPEND="
X? ( x11-base/xorg-proto )"
BDEPEND="
dev-lang/perl
+ sys-devel/binutils
sys-devel/bison
sys-devel/flex
virtual/pkgconfig
mingw? ( !crossdev-mingw? ( dev-util/mingw64-toolchain[${MULTILIB_USEDEP}] ) )
nls? ( sys-devel/gettext )"
-IDEPEND="app-eselect/eselect-wine"
+IDEPEND=">=app-eselect/eselect-wine-2"
QA_TEXTRELS="usr/lib/*/wine/i386-unix/*.so" # uses -fno-PIC -Wl,-z,notext
@@ -249,6 +250,11 @@ src_configure() {
use custom-cflags || strip-flags # can break in obscure ways, also no lto
use crossdev-mingw || PATH=${BROOT}/usr/lib/mingw64-toolchain/bin:${PATH}
+ # temporary workaround for tc-ld-force-bfd not yet enforcing with mold
+ # https://github.com/gentoo/gentoo/pull/28355
+ [[ $($(tc-getCC) ${LDFLAGS} -Wl,--version 2>/dev/null) == mold* ]] &&
+ append-ldflags -fuse-ld=bfd
+
# build using upstream's way (--with-wine64)
# order matters: configure+compile 64->32, install 32->64
local -i bits
@@ -334,21 +340,10 @@ src_install() {
dodoc ANNOUNCE AUTHORS README* documentation/README*
}
-wine-eselect() {
- ebegin "${1^}ing ${P} using eselect-wine"
- eselect wine ${1} ${P} &&
- eselect wine ${1} --${PN#wine-} ${P} &&
- eselect wine update --if-unset &&
- eselect wine update --${PN#wine-} --if-unset
- eend ${?} || die -n "eselect failed, may need to manually handle ${P}"
-}
-
pkg_postinst() {
- wine-eselect register
+ eselect wine update --if-unset || die
}
-pkg_prerm() {
- if [[ ${REPLACED_BY_VERSION%-r*} != ${PV} ]]; then #881035
- nonfatal wine-eselect deregister
- fi
+pkg_postrm() {
+ eselect wine update --if-unset || die
}