summaryrefslogtreecommitdiff
path: root/app-emulation/wine-gecko/wine-gecko-2.47.2.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'app-emulation/wine-gecko/wine-gecko-2.47.2.ebuild')
-rw-r--r--app-emulation/wine-gecko/wine-gecko-2.47.2.ebuild21
1 files changed, 16 insertions, 5 deletions
diff --git a/app-emulation/wine-gecko/wine-gecko-2.47.2.ebuild b/app-emulation/wine-gecko/wine-gecko-2.47.2.ebuild
index ef4f3027be56..e5a5a8df49a9 100644
--- a/app-emulation/wine-gecko/wine-gecko-2.47.2.ebuild
+++ b/app-emulation/wine-gecko/wine-gecko-2.47.2.ebuild
@@ -6,14 +6,20 @@ EAPI=6
DESCRIPTION="A Mozilla Gecko based version of Internet Explorer for Wine"
HOMEPAGE="https://winehq.org"
SRC_URI="
- abi_x86_32? ( https://dl.winehq.org/wine/${PN}/${PV}/${PN}-${PV}-x86.msi )
- abi_x86_64? ( https://dl.winehq.org/wine/${PN}/${PV}/${PN}-${PV}-x86_64.msi )
+ !shared? (
+ abi_x86_32? ( https://dl.winehq.org/wine/${PN}/${PV}/${PN}-${PV}-x86.msi )
+ abi_x86_64? ( https://dl.winehq.org/wine/${PN}/${PV}/${PN}-${PV}-x86_64.msi )
+ )
+ shared? (
+ abi_x86_32? ( https://dl.winehq.org/wine/${PN}/${PV}/${PN}-${PV}-x86.tar.xz )
+ abi_x86_64? ( https://dl.winehq.org/wine/${PN}/${PV}/${PN}-${PV}-x86_64.tar.xz )
+ )
"
LICENSE="Apache-2.0 BSD BSD-2 MIT MPL-2.0"
SLOT="${PV}"
KEYWORDS="amd64 x86"
-IUSE="abi_x86_32 abi_x86_64"
+IUSE="abi_x86_32 abi_x86_64 +shared"
DEPEND="!!app-emulation/wine:0"
@@ -21,6 +27,11 @@ S="${WORKDIR}"
src_install() {
insinto /usr/share/wine/gecko
- use abi_x86_32 && doins "${DISTDIR}/${PN}-${PV}-x86.msi"
- use abi_x86_64 && doins "${DISTDIR}/${PN}-${PV}-x86_64.msi"
+ if use shared; then
+ use abi_x86_32 && doins -r "${P}-x86"
+ use abi_x86_64 && doins -r "${P}-x86_64"
+ else
+ use abi_x86_32 && doins "${DISTDIR}/${PN}-${PV}-x86.msi"
+ use abi_x86_64 && doins "${DISTDIR}/${PN}-${PV}-x86_64.msi"
+ fi
}