summaryrefslogtreecommitdiff
path: root/app-emulation/vkd3d
diff options
context:
space:
mode:
Diffstat (limited to 'app-emulation/vkd3d')
-rw-r--r--app-emulation/vkd3d/Manifest4
-rw-r--r--app-emulation/vkd3d/metadata.xml15
-rw-r--r--app-emulation/vkd3d/vkd3d-1.0.ebuild42
-rw-r--r--app-emulation/vkd3d/vkd3d-9999.ebuild42
4 files changed, 103 insertions, 0 deletions
diff --git a/app-emulation/vkd3d/Manifest b/app-emulation/vkd3d/Manifest
new file mode 100644
index 000000000000..0296a4f3277f
--- /dev/null
+++ b/app-emulation/vkd3d/Manifest
@@ -0,0 +1,4 @@
+DIST vkd3d-1.0.tar.xz 461884 BLAKE2B 4dbd729f9e795d3d81178abc1a8774c0bbe6a5257c96c97acf1e4b4cdb5b7e30c77235e8b8fa57f7db3196caf30c55c3b0c07e2981629dd6177436a3cd117d33 SHA512 55712528688cdedc63049e168b371b470dbb8e31ddc36d8b23b0655f4a061726eb8556b9abf3cb887f6bd21379959aed9fab93ba0fd53813aec413ebec71d615
+EBUILD vkd3d-1.0.ebuild 1008 BLAKE2B cd9d65a6a8b0bf9d8d78fdac4f4a1c92f65f4492b88f0f05552c6e2244c495a4a3cb68a620173844bfa9aae3ebc05eb9efc28d8429a617fb226d37dae390b3fc SHA512 330c7dd9e298c11575929f8d9c6db51ab509ba87505af0317ab5cf08ce5ca9061262e3f677f0cafa195212e91b93a925c753028dd15a83147c810d64dd07ce84
+EBUILD vkd3d-9999.ebuild 1008 BLAKE2B cd9d65a6a8b0bf9d8d78fdac4f4a1c92f65f4492b88f0f05552c6e2244c495a4a3cb68a620173844bfa9aae3ebc05eb9efc28d8429a617fb226d37dae390b3fc SHA512 330c7dd9e298c11575929f8d9c6db51ab509ba87505af0317ab5cf08ce5ca9061262e3f677f0cafa195212e91b93a925c753028dd15a83147c810d64dd07ce84
+MISC metadata.xml 562 BLAKE2B 2409531d0bc65f547844ae83bfd7aaea4d996f2cdf11ebbf7e95775465d4bed916a39a38a0aae0c6df91a417df484ecaf63b29ea4286fdcfd11b07c8177e3496 SHA512 2150c80fd4315d922521b43c650012008864b3ed1ff7d80e43622ad916e52411c6ef855b46693f96165e9d89fd6a6f18cdc88baab13bec9f7053c0c1795bcd71
diff --git a/app-emulation/vkd3d/metadata.xml b/app-emulation/vkd3d/metadata.xml
new file mode 100644
index 000000000000..cad91c2cdfde
--- /dev/null
+++ b/app-emulation/vkd3d/metadata.xml
@@ -0,0 +1,15 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>wine@gentoo.org</email>
+ <name>Wine</name>
+ <description>
+ This package must be kept in sync with repo/proj/wine repository.
+ Any changes need to be run past the maintainer to ensure the two repositories are kept in sync.
+ </description>
+ </maintainer>
+ <use>
+ <flag name="spirv-tools">Enable SPIRV shader debugging support using <pkg>dev-util/spirv-tools</pkg></flag>
+ </use>
+</pkgmetadata>
diff --git a/app-emulation/vkd3d/vkd3d-1.0.ebuild b/app-emulation/vkd3d/vkd3d-1.0.ebuild
new file mode 100644
index 000000000000..2adf5f15608b
--- /dev/null
+++ b/app-emulation/vkd3d/vkd3d-1.0.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit multilib-minimal
+
+if [[ "${PV}" == "9999" ]]; then
+ EGIT_REPO_URI="https://source.winehq.org/git/vkd3d.git"
+ inherit git-r3
+else
+ KEYWORDS="~amd64"
+ SRC_URI="https://dl.winehq.org/vkd3d/source/${P}.tar.xz"
+fi
+
+IUSE="spirv-tools"
+RDEPEND="spirv-tools? ( dev-util/spirv-tools:=[${MULTILIB_USEDEP}] )
+ media-libs/vulkan-loader[${MULTILIB_USEDEP},X]
+ x11-libs/xcb-util:=[${MULTILIB_USEDEP}]
+ x11-libs/xcb-util-keysyms:=[${MULTILIB_USEDEP}]
+ x11-libs/xcb-util-wm:=[${MULTILIB_USEDEP}]"
+
+DEPEND="${RDEPEND}
+ dev-util/spirv-headers
+ || (
+ dev-util/vulkan-headers
+ <=media-libs/vulkan-loader-1.1.70.0-r999[${MULTILIB_USEDEP}]
+ )"
+
+DESCRIPTION="D3D12 to Vulkan translation library"
+HOMEPAGE="https://source.winehq.org/git/vkd3d.git/"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+
+multilib_src_configure() {
+ local myconf=(
+ $(use_with spirv-tools)
+ )
+
+ ECONF_SOURCE=${S} econf "${myconf[@]}"
+}
diff --git a/app-emulation/vkd3d/vkd3d-9999.ebuild b/app-emulation/vkd3d/vkd3d-9999.ebuild
new file mode 100644
index 000000000000..2adf5f15608b
--- /dev/null
+++ b/app-emulation/vkd3d/vkd3d-9999.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit multilib-minimal
+
+if [[ "${PV}" == "9999" ]]; then
+ EGIT_REPO_URI="https://source.winehq.org/git/vkd3d.git"
+ inherit git-r3
+else
+ KEYWORDS="~amd64"
+ SRC_URI="https://dl.winehq.org/vkd3d/source/${P}.tar.xz"
+fi
+
+IUSE="spirv-tools"
+RDEPEND="spirv-tools? ( dev-util/spirv-tools:=[${MULTILIB_USEDEP}] )
+ media-libs/vulkan-loader[${MULTILIB_USEDEP},X]
+ x11-libs/xcb-util:=[${MULTILIB_USEDEP}]
+ x11-libs/xcb-util-keysyms:=[${MULTILIB_USEDEP}]
+ x11-libs/xcb-util-wm:=[${MULTILIB_USEDEP}]"
+
+DEPEND="${RDEPEND}
+ dev-util/spirv-headers
+ || (
+ dev-util/vulkan-headers
+ <=media-libs/vulkan-loader-1.1.70.0-r999[${MULTILIB_USEDEP}]
+ )"
+
+DESCRIPTION="D3D12 to Vulkan translation library"
+HOMEPAGE="https://source.winehq.org/git/vkd3d.git/"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+
+multilib_src_configure() {
+ local myconf=(
+ $(use_with spirv-tools)
+ )
+
+ ECONF_SOURCE=${S} econf "${myconf[@]}"
+}