summaryrefslogtreecommitdiff
path: root/app-emulation/vkd3d
diff options
context:
space:
mode:
Diffstat (limited to 'app-emulation/vkd3d')
-rw-r--r--app-emulation/vkd3d/Manifest2
-rw-r--r--app-emulation/vkd3d/vkd3d-1.12.ebuild51
2 files changed, 53 insertions, 0 deletions
diff --git a/app-emulation/vkd3d/Manifest b/app-emulation/vkd3d/Manifest
index a2acc690d732..9aafaea9e7b7 100644
--- a/app-emulation/vkd3d/Manifest
+++ b/app-emulation/vkd3d/Manifest
@@ -1,3 +1,5 @@
DIST vkd3d-1.11.tar.xz 1016132 BLAKE2B 634f5f99f7605814d36a90270ddb82a6a11e2b6bfc2cdc6a6d4d31b730b9d5739479770fe00704f27a726c39aa115272c0a79dbcff8baf251188a4b3ead8faeb SHA512 2b14f7f8d4d58c2bfc6c30aa0d24b6789c0887b2869cfb6be98d03b7b001a74a1fbe24439229fa4d3a618a69fe8eeb77d7a520a16276ae494fe6ee2357dd31d0
+DIST vkd3d-1.12.tar.xz 1095416 BLAKE2B 6e5fa5c6a743ab103c6d1564f025689351620d587008eb079517a871aaf9895f9521a4a83e30896c1d7b4a378ff54e193340d4c915dbf91ad6b350746ccdbfd8 SHA512 ac444ebcdbc7bf84cb5726affd7a4f075116b4016f06a9fff47f30182945848ee04ceda587f864fc02c11a064bf7d92e492e2cf30fe53cc7cfe23a61cf85e776
EBUILD vkd3d-1.11.ebuild 971 BLAKE2B 29120204b95e5818a47576e878ba90b63f013ae6dfc33b4fcf2ffeac9baafdaa3812f5a2de45cb36fcf0c42c6cc640b6fea4d9d57d30b8b9735b1e898094027f SHA512 b7a6d3852e877f9da8478eb846c8b7e951cd7f2540781348fd7662471049a17e74fa6c5b9316f715a5624f72f77781741ca4b3c7f0686ebf23ef393691771fc6
+EBUILD vkd3d-1.12.ebuild 1050 BLAKE2B 4309ff19ea556bf595df3bf9bf12cd5fc6587004c549e745fe5ab0c9d606eb31be0250cd8edd144d933e7d74737900da4b092381a5c3b565e26fcbccbfceec48 SHA512 ba81e2ee84895cf75e415d520ca60630d7bd078ae057539311264d16cf9994d5977f0299bcd00ec1e952a96601186aae53134f951321b11f279c2d1282522200
MISC metadata.xml 563 BLAKE2B c976a16a495bdb5863811acda56b2cc628683a63fc2a22c18d2a09775d3a38c845e00f83b97b318d9a0e5267bb470dd56d334dc9f43e3716784254802b8db60b SHA512 3d5afb7890b3b10ad424fcfe3fa2b42a9227ba0b82be8ab85308126966f476798818ee0ecc88c53105b218f465a72b213efe00968112431169884a4a6f48c6a8
diff --git a/app-emulation/vkd3d/vkd3d-1.12.ebuild b/app-emulation/vkd3d/vkd3d-1.12.ebuild
new file mode 100644
index 000000000000..a6965c74656c
--- /dev/null
+++ b/app-emulation/vkd3d/vkd3d-1.12.ebuild
@@ -0,0 +1,51 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit multilib-minimal
+
+DESCRIPTION="D3D12 to Vulkan translation library"
+HOMEPAGE="https://gitlab.winehq.org/wine/vkd3d/"
+SRC_URI="https://dl.winehq.org/vkd3d/source/${P}.tar.xz"
+
+LICENSE="LGPL-2.1+"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="ncurses spirv-tools"
+RESTRICT="test" #838655
+
+RDEPEND="
+ media-libs/vulkan-loader[${MULTILIB_USEDEP}]
+ ncurses? ( sys-libs/ncurses:= )
+ spirv-tools? ( dev-util/spirv-tools[${MULTILIB_USEDEP}] )
+"
+DEPEND="
+ ${RDEPEND}
+ dev-util/spirv-headers
+ dev-util/vulkan-headers
+"
+BDEPEND="
+ sys-devel/flex
+ sys-devel/bison
+ virtual/pkgconfig
+"
+
+multilib_src_configure() {
+ local conf=(
+ $(multilib_native_use_with ncurses)
+ $(use_with spirv-tools)
+ --disable-doxygen-pdf
+ --without-xcb
+ # let users' flags control lto (bug #933178)
+ vkd3d_cv_cflags__flto_auto=
+ )
+
+ ECONF_SOURCE=${S} econf "${conf[@]}"
+}
+
+multilib_src_install_all() {
+ einstalldocs
+
+ find "${ED}" -type f -name '*.la' -delete || die
+}