summaryrefslogtreecommitdiff
path: root/app-emulation/vkd3d-proton/vkd3d-proton-2.6.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'app-emulation/vkd3d-proton/vkd3d-proton-2.6.ebuild')
-rw-r--r--app-emulation/vkd3d-proton/vkd3d-proton-2.6.ebuild6
1 files changed, 6 insertions, 0 deletions
diff --git a/app-emulation/vkd3d-proton/vkd3d-proton-2.6.ebuild b/app-emulation/vkd3d-proton/vkd3d-proton-2.6.ebuild
index 2e3e5c86e2ce..3c960bc15b97 100644
--- a/app-emulation/vkd3d-proton/vkd3d-proton-2.6.ebuild
+++ b/app-emulation/vkd3d-proton/vkd3d-proton-2.6.ebuild
@@ -100,6 +100,12 @@ src_prepare() {
src_configure() {
use crossdev-mingw || PATH=${BROOT}/usr/lib/mingw64-toolchain/bin:${PATH}
+ # -mavx with mingw-gcc has a history of obscure issues and
+ # disabling is seen as safer, e.g. `WINEARCH=win32 winecfg`
+ # crashes with -march=skylake >=wine-8.10, similar issues with
+ # znver4: https://gcc.gnu.org/bugzilla/show_bug.cgi?id=110273
+ append-flags -mno-avx
+
if [[ ${CHOST} != *-mingw* ]]; then
if [[ ! -v MINGW_BYPASS ]]; then
unset AR CC CXX RC STRIP WIDL