summaryrefslogtreecommitdiff
path: root/app-emulation/uae/files
diff options
context:
space:
mode:
Diffstat (limited to 'app-emulation/uae/files')
-rw-r--r--app-emulation/uae/files/sdlgfx.h38
-rw-r--r--app-emulation/uae/files/uae-0.8.25-allow_spaces_in_zip_filenames.diff18
-rw-r--r--app-emulation/uae/files/uae-0.8.25-struct_uae_wrong_fields_name.diff18
-rw-r--r--app-emulation/uae/files/uae-0.8.26-uae_reset_args.diff86
-rw-r--r--app-emulation/uae/files/uae-0.8.26-underlinking.patch19
5 files changed, 179 insertions, 0 deletions
diff --git a/app-emulation/uae/files/sdlgfx.h b/app-emulation/uae/files/sdlgfx.h
new file mode 100644
index 000000000000..30bee2ee4024
--- /dev/null
+++ b/app-emulation/uae/files/sdlgfx.h
@@ -0,0 +1,38 @@
+/*
+ * UAE - The Un*x Amiga Emulator
+ *
+ * SDL graphics support
+ *
+ * Copyright 2004 Richard Drummond
+ */
+
+/*
+ * What graphics platform are we running on . . .?
+ *
+ * Yes, SDL is supposed to abstract away from the underlying
+ * platform, but we need to know this to be able to map raw keys
+ * and to work around any platform-specific quirks . . .
+ */
+enum {
+ SDLGFX_DRIVER_UNKNOWN,
+ SDLGFX_DRIVER_X11,
+ SDLGFX_DRIVER_DGA,
+ SDLGFX_DRIVER_SVGALIB,
+ SDLGFX_DRIVER_FBCON,
+ SDLGFX_DRIVER_DIRECTFB,
+ SDLGFX_DRIVER_QUARTZ,
+ SDLGFX_DRIVER_BWINDOW,
+ SDLGFX_DRIVER_CYBERGFX,
+ SDLGFX_DRIVER_AMIGAOS4
+};
+
+extern int get_sdlgfx_type (void);
+
+/* keyboard support */
+struct uae_input_device_kbr_default *get_default_raw_keymap (int type);
+extern int keysym2amiga (int keycode);
+int modifier_hack (int *scancode, int *pressed);
+
+/* hotkey support */
+struct uae_hotkeyseq *get_default_cooked_hotkeys (void);
+struct uae_hotkeyseq *get_default_raw_hotkeys (void);
diff --git a/app-emulation/uae/files/uae-0.8.25-allow_spaces_in_zip_filenames.diff b/app-emulation/uae/files/uae-0.8.25-allow_spaces_in_zip_filenames.diff
new file mode 100644
index 000000000000..629ae702c520
--- /dev/null
+++ b/app-emulation/uae/files/uae-0.8.25-allow_spaces_in_zip_filenames.diff
@@ -0,0 +1,18 @@
+## 03_allow_spaces_in_zip_filenames.dpatch by Florian Ernst <florian@debian.org>
+##
+## All lines beginning with `## DP:' are a description of the patch.
+## DP: Allow spaces in filenames for zipped files, bug#238678
+
+@DPATCH@
+diff -urNad uae-0.8.25~/src/zfile.c uae-0.8.25/src/zfile.c
+--- uae-0.8.25~/src/zfile.c 2005-07-01 17:53:26.000000000 +0200
++++ uae-0.8.25/src/zfile.c 2005-11-08 01:17:59.000000000 +0100
+@@ -126,7 +126,7 @@
+ if (!dst)
+ return 1;
+ #if defined AMIGA || defined __unix
+- sprintf (cmd, "unzip -p %s '*.adf' >%s", src, dst);
++ sprintf (cmd, "unzip -p \"%s\" '*.adf' >%s", src, dst);
+ return !system (cmd);
+ #endif
+ }
diff --git a/app-emulation/uae/files/uae-0.8.25-struct_uae_wrong_fields_name.diff b/app-emulation/uae/files/uae-0.8.25-struct_uae_wrong_fields_name.diff
new file mode 100644
index 000000000000..cd8d7e00cd8a
--- /dev/null
+++ b/app-emulation/uae/files/uae-0.8.25-struct_uae_wrong_fields_name.diff
@@ -0,0 +1,18 @@
+Somewhere wrong (old) names are used in accessing the preferences structure.
+
+This is just a remainder for the upstream!!
+
+Antonio Ospite <ospite@studenti.unina.it>
+
+diff -pruN uae-0.8.25/src/tui.c uae-0.8.25_patched/src/tui.c
+--- uae-0.8.25/src/tui.c 2006-06-07 17:45:55.000000000 +0200
++++ uae-0.8.25_patched/src/tui.c 2006-06-07 17:55:39.000000000 +0200
+@@ -606,7 +606,7 @@ static void SoundOptions (void)
+ currprefs.sound_freq = atoi (tmp);
+ break;
+ case 5:
+- currprefs.stereo = (currprefs.stereo + 1) % 3;
++ currprefs.sound_stereo = (currprefs.sound_stereo + 1) % 3;
+ break;
+ }
+ }
diff --git a/app-emulation/uae/files/uae-0.8.26-uae_reset_args.diff b/app-emulation/uae/files/uae-0.8.26-uae_reset_args.diff
new file mode 100644
index 000000000000..3df99e4d2a4f
--- /dev/null
+++ b/app-emulation/uae/files/uae-0.8.26-uae_reset_args.diff
@@ -0,0 +1,86 @@
+diff -Naur uae-0.8.26.orig/src/ncurses.c uae-0.8.26/src/ncurses.c
+--- uae-0.8.26.orig/src/ncurses.c 2007-08-05 20:01:58.000000000 +0400
++++ uae-0.8.26/src/ncurses.c 2007-08-12 18:36:33.000000000 +0400
+@@ -595,7 +595,7 @@
+ if (ch == 16) --lastmy; /* ^P */
+ if (ch == 11) {buttonstate[0] = keydelay;ch = 0;} /* ^K */
+ if (ch == 25) {buttonstate[2] = keydelay;ch = 0;} /* ^Y */
+- if (ch == 15) uae_reset (); /* ^O */
++ if (ch == 15) uae_reset (0); /* ^O */
+ if (ch == 17) uae_quit (); /* ^Q */
+ if (ch == KEY_F(1)) {
+ curses_insert_disk();
+diff -Naur uae-0.8.26.orig/src/NeXTwin.m uae-0.8.26/src/NeXTwin.m
+--- uae-0.8.26.orig/src/NeXTwin.m 1997-10-18 17:39:04.000000000 +0400
++++ uae-0.8.26/src/NeXTwin.m 2007-08-12 18:36:33.000000000 +0400
+@@ -86,7 +86,7 @@
+ @implementation AmigaView
+ -reset:sender
+ {
+- uae_reset();
++ uae_reset(0);
+ //m68k_reset();
+ return self;
+ }
+diff -Naur uae-0.8.26.orig/src/od-beos/beos.cpp uae-0.8.26/src/od-beos/beos.cpp
+--- uae-0.8.26.orig/src/od-beos/beos.cpp 2001-02-19 23:59:11.000000000 +0300
++++ uae-0.8.26/src/od-beos/beos.cpp 2007-08-12 18:36:33.000000000 +0400
+@@ -719,7 +719,7 @@
+ uint32 mouse_buttons;
+
+ if (reset_thyself) {
+- uae_reset();
++ uae_reset(0);
+ reset_thyself = false;
+ }
+
+diff -Naur uae-0.8.26.orig/src/od-win32/keyboard.c uae-0.8.26/src/od-win32/keyboard.c
+--- uae-0.8.26.orig/src/od-win32/keyboard.c 2007-08-06 00:23:08.000000000 +0400
++++ uae-0.8.26/src/od-win32/keyboard.c 2007-08-12 18:36:33.000000000 +0400
+@@ -488,8 +488,8 @@
+ record_key ((akey << 1) + 1);
+
+ /* "Affengriff" */
+- if( (keystate[AK_CTRL] || keystate[AK_RCTRL] ) && keystate[AK_LAMI] && keystate[AK_RAMI])uae_reset();
+- //if( (keystate[AK_CTRL] || keystate[AK_RCTRL] ) && keystate[AK_RAMI])uae_reset();
++ if( (keystate[AK_CTRL] || keystate[AK_RCTRL] ) && keystate[AK_LAMI] && keystate[AK_RAMI])uae_reset(0);
++ //if( (keystate[AK_CTRL] || keystate[AK_RCTRL] ) && keystate[AK_RAMI])uae_reset(0);
+
+ return 0;
+ }
+diff -Naur uae-0.8.26.orig/src/od-win32/win32gui.c uae-0.8.26/src/od-win32/win32gui.c
+--- uae-0.8.26.orig/src/od-win32/win32gui.c 2007-08-06 00:23:08.000000000 +0400
++++ uae-0.8.26/src/od-win32/win32gui.c 2007-08-12 18:36:33.000000000 +0400
+@@ -2260,7 +2260,7 @@
+ }
+ break;
+ case IDC_RESETAMIGA:
+- uae_reset();
++ uae_reset(0);
+ break;
+ case IDC_QUITEMU:
+ uae_quit();
+diff -Naur uae-0.8.26.orig/src/svga.c uae-0.8.26/src/svga.c
+--- uae-0.8.26.orig/src/svga.c 2007-08-05 20:01:58.000000000 +0400
++++ uae-0.8.26/src/svga.c 2007-08-12 18:36:33.000000000 +0400
+@@ -438,7 +438,7 @@
+
+ /* "Affengriff" */
+ if ((keystate[AK_CTRL] || keystate[AK_RCTRL]) && keystate[AK_LAMI] && keystate[AK_RAMI])
+- uae_reset ();
++ uae_reset (0);
+ }
+
+ static void leave_graphics_mode (void)
+diff -Naur uae-0.8.26.orig/src/tui.c uae-0.8.26/src/tui.c
+--- uae-0.8.26.orig/src/tui.c 2007-08-12 18:35:41.000000000 +0400
++++ uae-0.8.26/src/tui.c 2007-08-12 18:36:33.000000000 +0400
+@@ -683,7 +683,7 @@
+ case 0: DiskOptions (); break;
+ case 1: OtherOptions (); break;
+ case 2: save_settings (); break;
+- case 3: uae_reset (); break;
++ case 3: uae_reset (0); break;
+ case 4: uae_quit (); break;
+ }
+ }
diff --git a/app-emulation/uae/files/uae-0.8.26-underlinking.patch b/app-emulation/uae/files/uae-0.8.26-underlinking.patch
new file mode 100644
index 000000000000..16bf5744826e
--- /dev/null
+++ b/app-emulation/uae/files/uae-0.8.26-underlinking.patch
@@ -0,0 +1,19 @@
+--- configure.in
++++ configure.in
+@@ -81,6 +81,16 @@
+ AC_CHECK_LIB(audio, alOpenPort, HAVE_SGIAUDIO_LIB=yes, HAVE_SGIAUDIO_LIB=no)
+ AC_CHECK_LIB(asound, snd_pcm_open, HAVE_ALSA=yes, HAVE_ALSA=no)
+
++dnl Check for libm for cos()
++AC_SEARCH_LIBS([cos], [m], [], [
++ AC_MSG_ERROR([unable to find the cos() function])
++])
++
++dnl Check for libm for floor()
++AC_SEARCH_LIBS([floor], [m], [], [
++ AC_MSG_ERROR([unable to find the floor() function])
++])
++
+ AC_PATH_XTRA
+ AC_CONFIG_HEADER(src/sysconfig.h)
+