summaryrefslogtreecommitdiff
path: root/app-emulation/spice/spice-9999.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'app-emulation/spice/spice-9999.ebuild')
-rw-r--r--app-emulation/spice/spice-9999.ebuild14
1 files changed, 9 insertions, 5 deletions
diff --git a/app-emulation/spice/spice-9999.ebuild b/app-emulation/spice/spice-9999.ebuild
index 48cf0c3fa264..d4bf02488571 100644
--- a/app-emulation/spice/spice-9999.ebuild
+++ b/app-emulation/spice/spice-9999.ebuild
@@ -34,18 +34,18 @@ RDEPEND="
media-libs/gst-plugins-base:1.0
)"
DEPEND="${RDEPEND}
- ${PYTHON_DEPS}
~app-emulation/spice-protocol-9999
+ smartcard? ( app-emulation/qemu[smartcard] )"
+BDEPEND="${PYTHON_DEPS}
virtual/pkgconfig
$(python_gen_any_dep '
>=dev-python/pyparsing-1.5.6-r2[${PYTHON_USEDEP}]
dev-python/six[${PYTHON_USEDEP}]
- ')
- smartcard? ( app-emulation/qemu[smartcard] )"
+ ')"
python_check_deps() {
- has_version ">=dev-python/pyparsing-1.5.6-r2[${PYTHON_USEDEP}]"
- has_version "dev-python/six[${PYTHON_USEDEP}]"
+ has_version -b ">=dev-python/pyparsing-1.5.6-r2[${PYTHON_USEDEP}]"
+ has_version -b "dev-python/six[${PYTHON_USEDEP}]"
}
pkg_setup() {
@@ -55,6 +55,10 @@ pkg_setup() {
src_prepare() {
default
+ # Delete repo-only Makefile that causes build to fail.
+ # https://gitlab.freedesktop.org/spice/spice/issues/35
+ rm GNUmakefile || die
+
eautoreconf
}