summaryrefslogtreecommitdiff
path: root/app-emulation/ruffle/ruffle-9999.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'app-emulation/ruffle/ruffle-9999.ebuild')
-rw-r--r--app-emulation/ruffle/ruffle-9999.ebuild11
1 files changed, 8 insertions, 3 deletions
diff --git a/app-emulation/ruffle/ruffle-9999.ebuild b/app-emulation/ruffle/ruffle-9999.ebuild
index 4d1c24f9a31c..135f04109053 100644
--- a/app-emulation/ruffle/ruffle-9999.ebuild
+++ b/app-emulation/ruffle/ruffle-9999.ebuild
@@ -3,7 +3,7 @@
EAPI=8
-inherit cargo desktop git-r3 xdg
+inherit cargo desktop git-r3 optfeature xdg
DESCRIPTION="Flash Player emulator written in Rust"
HOMEPAGE="https://ruffle.rs/"
@@ -20,11 +20,10 @@ RESTRICT="!test? ( test )"
# dlopen: libX* (see winit+x11-dl crates)
RDEPEND="
- dev-libs/glib:2
dev-libs/openssl:=
media-libs/alsa-lib
sys-libs/zlib:=
- x11-libs/gtk+:3
+ virtual/libudev:=
x11-libs/libX11
x11-libs/libXcursor
x11-libs/libXrandr
@@ -88,3 +87,9 @@ src_install() {
newbin exporter ${PN}_exporter
dobin ${PN}_scanner
}
+
+pkg_postinst() {
+ xdg_pkg_postinst
+
+ optfeature "the in-application file picker" sys-apps/xdg-desktop-portal
+}