summaryrefslogtreecommitdiff
path: root/app-emulation/qemu/qemu-9999.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'app-emulation/qemu/qemu-9999.ebuild')
-rw-r--r--app-emulation/qemu/qemu-9999.ebuild31
1 files changed, 3 insertions, 28 deletions
diff --git a/app-emulation/qemu/qemu-9999.ebuild b/app-emulation/qemu/qemu-9999.ebuild
index 671b13b12e50..3616ee03475f 100644
--- a/app-emulation/qemu/qemu-9999.ebuild
+++ b/app-emulation/qemu/qemu-9999.ebuild
@@ -61,7 +61,7 @@ IUSE="accessibility +aio alsa bpf bzip2 capstone +caps +curl debug ${QEMU_DOC_US
plugins +png pulseaudio python rbd sasl +seccomp sdl sdl-image selinux
+slirp
smartcard snappy spice ssh static static-user systemtap test udev usb
- usbredir vde +vhost-net vhost-user-fs virgl virtfs +vnc vte xattr xen
+ usbredir vde +vhost-net virgl virtfs +vnc vte xattr xen
zstd"
COMMON_TARGETS="
@@ -118,7 +118,8 @@ IUSE+=" ${use_softmmu_targets} ${use_user_targets}"
RESTRICT="!test? ( test )"
# Allow no targets to be built so that people can get a tools-only build.
# Block USE flag configurations known to not work.
-REQUIRED_USE="${PYTHON_REQUIRED_USE}
+REQUIRED_USE="caps seccomp
+ ${PYTHON_REQUIRED_USE}
qemu_softmmu_targets_arm? ( fdt )
qemu_softmmu_targets_microblaze? ( fdt )
qemu_softmmu_targets_mips64el? ( fdt )
@@ -130,7 +131,6 @@ REQUIRED_USE="${PYTHON_REQUIRED_USE}
sdl-image? ( sdl )
static? ( static-user !alsa !gtk !jack !opengl !pam !pulseaudio !plugins !rbd !snappy !udev )
static-user? ( !plugins )
- vhost-user-fs? ( caps seccomp )
virgl? ( opengl )
virtfs? ( caps xattr )
vnc? ( gnutls )
@@ -637,16 +637,6 @@ qemu_src_configure() {
--disable-tools
)
local static_flag="static"
-
- for target in ${IUSE_SOFTMMU_TARGETS}; do
- if use "qemu_softmmu_targets_${target}"; then
- conf_opts+=(
- # For some reason, adding this with the setting set
- # to on *or* off makes the build always fail.
- # --with-devices-${target}=gentoo
- )
- fi
- done
;;
tools)
conf_opts+=(
@@ -698,21 +688,6 @@ src_configure() {
if use "qemu_softmmu_targets_${target}"; then
softmmu_targets+=",${target}-softmmu"
softmmu_bins+=( "qemu-system-${target}" )
-
- # Needed to rework vhost-user-fs handling thanks to https://gitlab.com/qemu-project/qemu/-/commit/5166dab
- # The option was converted into being configurable by
- # Kconfig's. So, to enable it, we insert the necessary
- # options into each arch's softmmu target gentoo.mak file,
- # then configure with --with-devices-${target}=gentoo.
- if use vhost-user-fs; then
- echo "CONFIG_VHOST_USER_FS=y for ${target}-softmmu" || die
- echo "CONFIG_VIRTIO=y" >> "configs/devices/${target}-softmmu/gentoo.mak" || die
- echo "CONFIG_VHOST_USER_FS=y" >> "configs/devices/${target}-softmmu/gentoo.mak" || die
- else
- echo "CONFIG_VHOST_USER_FS=n for ${target}-softmmu" || die
- echo "CONFIG_VIRTIO=n" >> "configs/devices/${target}-softmmu/gentoo.mak" || die
- echo "CONFIG_VHOST_USER_FS=n" >> "configs/devices/${target}-softmmu/gentoo.mak" || die
- fi
fi
done