summaryrefslogtreecommitdiff
path: root/app-emulation/libvirt-glib
diff options
context:
space:
mode:
Diffstat (limited to 'app-emulation/libvirt-glib')
-rw-r--r--app-emulation/libvirt-glib/Manifest2
-rw-r--r--app-emulation/libvirt-glib/libvirt-glib-2.0.0.ebuild45
2 files changed, 47 insertions, 0 deletions
diff --git a/app-emulation/libvirt-glib/Manifest b/app-emulation/libvirt-glib/Manifest
index 1ced4ddbb6fc..e6b05f20453f 100644
--- a/app-emulation/libvirt-glib/Manifest
+++ b/app-emulation/libvirt-glib/Manifest
@@ -1,4 +1,6 @@
DIST libvirt-glib-1.0.0.tar.gz 860450 BLAKE2B 417a3bd0df41787fbec456f301af744a04649db02192ef9c80bf42214a112a050a9f054c81549a114e7a1236c86e0066e8002f0c7f09317abb672fe5f6a76789 SHA512 72f53a90d3e40aa93d4afe5b29f631afe859532fbdb4e27086da3bd4cdaf0fb25fc808a82a1994b7c2648a1e864876ce95de28acb3b4876dac47b0f4d1c97ba5
+DIST libvirt-glib-2.0.0.tar.gz 868946 BLAKE2B 1ff4695b25766d6caa603826dcc63e64aa3ce022e6623eb31017fb67a490baeb546a9bc67e16fc16c7b86040db971748b1ef4303a21b5dec098cf732f77c92ec SHA512 6ead4c37c314eb5670c5aa282ce039a0182a71a20b349a5d9c78367381eb674fad0f2ca0f2e20e1e89ff7df2ac9f1640f20fdfa63d599d8a2538fb4c0fba4c3f
EBUILD libvirt-glib-1.0.0-r1.ebuild 1014 BLAKE2B 7e26b59844df689ae0cf1c791ebc61d046eb45afdc014708ae3283a771a537bfc2aa0025cb2379d5bdaa20e4147385cda057a93d7423d7b26a11973878e1d4cb SHA512 fbb757c3e5fe6dc894be136fde13e177704c7fbc1bc5f46dd5a5f64708966fb0919e187ca501335fb3a736e37df26936a22b286a9176f8d6368a44ab6a55b6c7
EBUILD libvirt-glib-1.0.0.ebuild 1234 BLAKE2B b6429e7d6151f44ac3af8db66a43984be934dc01de02cdaf45fce08721a12f63bbd84177bf1a2b847e22ea4c4c5ab800cc308d481dd09a97c68b05365bea4148 SHA512 71973f3d5429257a7434977aece98e2041f0bdada1466324c08c1453a597d0df72249f070e90aeaf987e56a5a18c2f7f3c62cd05a0d19c60602213882f10ed49
+EBUILD libvirt-glib-2.0.0.ebuild 1013 BLAKE2B a8fbfcf90d2537f31b6d3321b494ae00c49851466c9e41e2f1ca9e60de7a34eca97e22643b942f35afc67422b7be20417f381a6772a212fbd84e05707e81a368 SHA512 ba2d418411627ee69950b77d143a14334df0321767f14e2445cf2fb042d1154db9f10b9ebee6c70a259f66e984db78a40f162914031fb0a534c5c80211fa2882
MISC metadata.xml 353 BLAKE2B 84d64fcb26b450371bcdd9ce737aeb5b0337a23d8cd5401094793fc73e63610cda3c04853a6ea98a8d352d990a5067515bff049b86c305d48ed2828e98765e4a SHA512 b32b362e0267da5954557ffde2722311523b93bd84b0f8023671cf12ccd178577007b900e745671ec1aec5cb3c7bf8f538803669efb44865380a0d5010ee8d74
diff --git a/app-emulation/libvirt-glib/libvirt-glib-2.0.0.ebuild b/app-emulation/libvirt-glib/libvirt-glib-2.0.0.ebuild
new file mode 100644
index 000000000000..6b7cab7e2d11
--- /dev/null
+++ b/app-emulation/libvirt-glib/libvirt-glib-2.0.0.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2018 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+GNOME2_LA_PUNT="yes"
+
+inherit gnome2 vala
+
+DESCRIPTION="GLib and GObject mappings for libvirt"
+HOMEPAGE="http://libvirt.org/git/?p=libvirt-glib.git"
+SRC_URI="ftp://libvirt.org/libvirt/glib/${P}.tar.gz"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="+introspection nls +vala"
+REQUIRED_USE="vala? ( introspection )"
+
+# https://bugzilla.redhat.com/show_bug.cgi?id=1093633
+RESTRICT="test"
+
+RDEPEND="
+ dev-libs/libxml2:2
+ >=app-emulation/libvirt-1.2.6:=
+ >=dev-libs/glib-2.38.0:2
+ introspection? ( >=dev-libs/gobject-introspection-0.10.8:= )"
+DEPEND="${RDEPEND}
+ dev-util/gtk-doc-am
+ >=dev-util/intltool-0.35.0
+ virtual/pkgconfig
+ vala? ( $(vala_depend) )"
+
+src_prepare() {
+ gnome2_src_prepare
+ use vala && vala_src_prepare
+}
+
+src_configure() {
+ gnome2_src_configure \
+ --disable-test-coverage \
+ --disable-static \
+ $(use_enable introspection) \
+ $(use_enable nls) \
+ $(use_enable vala)
+}