summaryrefslogtreecommitdiff
path: root/app-emulation/libspectrum
diff options
context:
space:
mode:
Diffstat (limited to 'app-emulation/libspectrum')
-rw-r--r--app-emulation/libspectrum/Manifest3
-rw-r--r--app-emulation/libspectrum/files/remove-local-prefix.patch18
-rw-r--r--app-emulation/libspectrum/libspectrum-1.4.4.ebuild11
3 files changed, 31 insertions, 1 deletions
diff --git a/app-emulation/libspectrum/Manifest b/app-emulation/libspectrum/Manifest
index 6401226708da..f01b6aa408ad 100644
--- a/app-emulation/libspectrum/Manifest
+++ b/app-emulation/libspectrum/Manifest
@@ -1,3 +1,4 @@
+AUX remove-local-prefix.patch 851 BLAKE2B 1e1b787c10499bfbeafca43b08f4cbd8c7525841c641a3fa1211822a7ec3e98b11c9925b1bd9cc8ac3b14e5d0625c34727a330e00f0e3aaf5aba1871a8810647 SHA512 bae42eec33ff2ae00547d8c649b8164fd5665b70e95b07f95cdcce41e342702de559c4b63d6ce95a97407d2e8012c7fe0142b923603c1c1d25b8978f29aaf7a3
DIST libspectrum-1.4.4.tar.gz 568684 BLAKE2B b6ab4fc4173e7de9a7c3b14fda03420a56f02c5c590770158443bc37bee99a55dd3bdf6864f8ca33adb5ed59f4abd5c5b97736456ba2e6e6aaa2b49e07097cc4 SHA512 83bb9242010d49898531bb62e0d4d55439b0b6a548b57a7932f074429aca70cf252dfb195e9751384510b08c98bd6bc8eefd8cb3f82b0c8d07fa245ba66e9fe2
-EBUILD libspectrum-1.4.4.ebuild 926 BLAKE2B 9ed5b4c42f0c7a37c5dae612d11c0797ce52067ba2dcdd370b84f6e5af247ab359f425372e113911ed599c9a20e03b2f2e4851bb6de89ffcdc1ba40987ac9549 SHA512 17f6ee52ce636a618161f098060acba77e4b079628a23d9a01b1ecbe74db7e611837e08c1916a3d8452d04f5e5d4b7b3abc8418e4d4c01c85b06a61f8c11b3ff
+EBUILD libspectrum-1.4.4.ebuild 1040 BLAKE2B c66daea0426b3fbfc816255e49501a9e4162a25436c2dc35519b09e213980f75f3d691b198cc90574d319403f03477efb2ff256a9c9bef7290b65564ed7daa29 SHA512 cc20f0cb9bbfb3d34ba04c4d9a94a58cc14d53363b2a4f8536c0e1368066d3e5970e9a7cafc3f9d564f071b577e3df7e1c008a64168b98912f12208ce6ca9e99
MISC metadata.xml 941 BLAKE2B 7ac8ef35dfa24899f6990e5c92f5c2f70328575196308cd28f6dab967b9c39e73dabfea007c0cbf4a90bf73f5739d9c4a17b22cbe8c670b3a2d5531d47763520 SHA512 79cbe79daa7805ab944614d7d8370bc82e3ce6ecab7218112163ca118198bf176a1a06c87f8e24117f0a293d6dcc1cd0c02477e56655d66eb9b928c7ba7fabdc
diff --git a/app-emulation/libspectrum/files/remove-local-prefix.patch b/app-emulation/libspectrum/files/remove-local-prefix.patch
new file mode 100644
index 000000000000..23e2b5dd041c
--- /dev/null
+++ b/app-emulation/libspectrum/files/remove-local-prefix.patch
@@ -0,0 +1,18 @@
+diff -Naur libspectrum-1.4.4/configure.ac libspectrum-1.4.4-patched/configure.ac
+--- libspectrum-1.4.4/configure.ac 2018-07-01 02:07:44.000000000 +0200
++++ libspectrum-1.4.4-patched/configure.ac 2020-07-28 16:38:22.636459194 +0200
+@@ -113,14 +113,6 @@
+ dnl Check for functions
+ AC_CHECK_FUNCS(_snprintf _stricmp _strnicmp snprintf strcasecmp strncasecmp)
+
+-dnl Allow the user to say that various libraries are in one place
+-AC_ARG_WITH(local-prefix,
+-[ --with-local-prefix=PFX local libraries installed in PFX (optional)],
+-CPPFLAGS="$CPPFLAGS -I$withval/include"; LDFLAGS="$LDFLAGS -L$withval/lib",
+-if test "$prefix" != "NONE"; then
+- CPPFLAGS="$CPPFLAGS -I$prefix/include"; LDFLAGS="$LDFLAGS -L$prefix/lib"
+-fi)
+-
+ dnl Check whether to use zlib (the UNIX version is called z, Win32 zdll)
+ AC_MSG_CHECKING(whether to use zlib)
+ AC_ARG_WITH(zlib,
diff --git a/app-emulation/libspectrum/libspectrum-1.4.4.ebuild b/app-emulation/libspectrum/libspectrum-1.4.4.ebuild
index 7d6cd415f46a..f830494fd23b 100644
--- a/app-emulation/libspectrum/libspectrum-1.4.4.ebuild
+++ b/app-emulation/libspectrum/libspectrum-1.4.4.ebuild
@@ -3,6 +3,8 @@
EAPI=6
+inherit autotools
+
DESCRIPTION="Spectrum emulation library"
HOMEPAGE="http://fuse-emulator.sourceforge.net/libspectrum.php"
SRC_URI="mirror://sourceforge/fuse-emulator/${P}.tar.gz"
@@ -21,6 +23,15 @@ DEPEND="${RDEPEND}
dev-lang/perl
virtual/pkgconfig"
+PATCHES=(
+ "${FILESDIR}"/remove-local-prefix.patch
+)
+
+src_prepare() {
+ default
+ eautoreconf
+}
+
src_configure() {
local myconf=(
--disable-static