summaryrefslogtreecommitdiff
path: root/app-emulation/docker/docker-19.03.5.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'app-emulation/docker/docker-19.03.5.ebuild')
-rw-r--r--app-emulation/docker/docker-19.03.5.ebuild16
1 files changed, 11 insertions, 5 deletions
diff --git a/app-emulation/docker/docker-19.03.5.ebuild b/app-emulation/docker/docker-19.03.5.ebuild
index e6fb4da81b09..b1fb15056e33 100644
--- a/app-emulation/docker/docker-19.03.5.ebuild
+++ b/app-emulation/docker/docker-19.03.5.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2019 Gentoo Authors
+# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=6
@@ -27,7 +27,7 @@ SLOT="0"
IUSE="apparmor aufs btrfs +container-init device-mapper hardened +overlay seccomp"
# https://github.com/docker/docker/blob/master/project/PACKAGERS.md#build-dependencies
-CDEPEND="
+COMMON_DEPEND="
>=dev-db/sqlite-3.7.9:3
device-mapper? (
>=sys-fs/lvm2-2.02.89[thin]
@@ -37,7 +37,7 @@ CDEPEND="
"
DEPEND="
- ${CDEPEND}
+ ${COMMON_DEPEND}
>=dev-lang/go-1.12
dev-go/go-md2man
@@ -50,7 +50,7 @@ DEPEND="
# https://github.com/docker/docker/blob/master/project/PACKAGERS.md#runtime-dependencies
# https://github.com/docker/docker/blob/master/project/PACKAGERS.md#optional-dependencies
RDEPEND="
- ${CDEPEND}
+ ${COMMON_DEPEND}
>=net-firewall/iptables-1.4
sys-process/procps
>=dev-vcs/git-1.7
@@ -74,7 +74,7 @@ CONFIG_CHECK="
~VETH ~BRIDGE ~BRIDGE_NETFILTER
~IP_NF_FILTER ~IP_NF_TARGET_MASQUERADE
~NETFILTER_XT_MATCH_ADDRTYPE ~NETFILTER_XT_MATCH_CONNTRACK ~NETFILTER_XT_MATCH_IPVS
- ~IP_NF_NAT ~NF_NAT ~NF_NAT_NEEDED
+ ~IP_NF_NAT ~NF_NAT
~POSIX_MQUEUE
~USER_NS
@@ -150,6 +150,12 @@ pkg_setup() {
"
fi
+ if kernel_is lt 5 2; then
+ CONFIG_CHECK+="
+ ~NF_NAT_NEEDED
+ "
+ fi
+
if use aufs; then
CONFIG_CHECK+="
~AUFS_FS