summaryrefslogtreecommitdiff
path: root/app-emulation/docker-compose
diff options
context:
space:
mode:
Diffstat (limited to 'app-emulation/docker-compose')
-rw-r--r--app-emulation/docker-compose/Manifest2
-rw-r--r--app-emulation/docker-compose/docker-compose-1.17.1.ebuild71
2 files changed, 0 insertions, 73 deletions
diff --git a/app-emulation/docker-compose/Manifest b/app-emulation/docker-compose/Manifest
index a4105e9230aa..84b8daeeb5bc 100644
--- a/app-emulation/docker-compose/Manifest
+++ b/app-emulation/docker-compose/Manifest
@@ -1,5 +1,3 @@
-DIST docker-compose-1.17.1.tar.gz 219947 BLAKE2B a5438e66f156b98ffc9ecf63a57443610f76713532369d519689b697dbc91bd196e24b831882a4c39a43c5b17640242d98f47a2c337832395dc48019d58e3e90 SHA512 711c0a73546f0b396a920d3310b92fc15e3c13f93439eeda363124c9bd971aa942395b2405ad7441df8982384be367c20a767fe5b9e3e150690b63deda58f553
DIST docker-compose-1.18.0.tar.gz 231256 BLAKE2B be9b57dd89a81734b850f61622a924a3ace5ace907c4d1365a18315ddfbe3f1a9a56b222766980d16d5eddbe6818caf94a5833c5cddac082fa230bf290977ee3 SHA512 9cf29d892f6419e9ef639e1b9edddecb47ddb5ba7f97830f732e463ee510ac5464d6d81f58a2bf4ae5e7aee78b3d2d4afd59e6e1b53974899edb3e090bcb991f
-EBUILD docker-compose-1.17.1.ebuild 2423 BLAKE2B 7433d3916716bc54512a96f7f5c21bea1a9e4adf5c1ae4365c557ad947c9e6b589adc3282be61a7ffb69da539bda12a1ef86b927864e5e1d801e65a971680758 SHA512 0906703570ef80c4bf8283c3700ee63925a15d587b2f5fe67a09787dc4f2ff7727c5533c7a811843398e9dcc256da771e4958f7babc76b0e46b99c3d85fe3d25
EBUILD docker-compose-1.18.0.ebuild 2422 BLAKE2B cf2b623a27b85b61e73bc93834b0027daa525a4c5d636dde1ab73573242330de8164a31528c76139ebef3467bde3c206d6865a2a9e58d0c8db37c505e5ed327d SHA512 48e9c336eea12efcfc1365e819ea09e6dfa0578545410f2a42f9c373780343bebb75e4579be0da71a9a02689ccbce5a42b87b2d97f4bbd46ae59c69d919b5218
MISC metadata.xml 429 BLAKE2B 5fcdac021eec2c1a600a4aaaefde691120f47d20fe1d5b218153e933f92f42d1008fc832139100cde6267f41adc33944efc378fed4205fd68c9240a8bdb46a1c SHA512 f6a0d1a934d1f825144fadbee8ab0fccceaf40af59cc44a90caed059a503672b18a1c16fee9bb045a9ab272ad5553b1d49fff67d43c7a8ff97dc5c31cdea37b6
diff --git a/app-emulation/docker-compose/docker-compose-1.17.1.ebuild b/app-emulation/docker-compose/docker-compose-1.17.1.ebuild
deleted file mode 100644
index e3bff20d7e04..000000000000
--- a/app-emulation/docker-compose/docker-compose-1.17.1.ebuild
+++ /dev/null
@@ -1,71 +0,0 @@
-# Copyright 1999-2017 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-PYTHON_COMPAT=( python{2_7,3_4,3_5,3_6} )
-
-inherit bash-completion-r1 distutils-r1 vcs-snapshot
-
-MY_PV=${PV//_/}
-
-DESCRIPTION="Multi-container orchestration for Docker"
-HOMEPAGE="https://www.docker.com/"
-SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${PN}-${MY_PV}.tar.gz -> ${P}.tar.gz"
-
-LICENSE="Apache-2.0"
-SLOT="0"
-KEYWORDS="~amd64"
-IUSE="test"
-
-CDEPEND="
- dev-python/setuptools[${PYTHON_USEDEP}]
- >=dev-python/cached-property-1.2.0[${PYTHON_USEDEP}]
- <dev-python/cached-property-2[${PYTHON_USEDEP}]
- >=dev-python/dockerpty-0.4.1[${PYTHON_USEDEP}]
- <dev-python/dockerpty-0.5[${PYTHON_USEDEP}]
- >=dev-python/docker-py-2.5.1[${PYTHON_USEDEP}]
- <dev-python/docker-py-3.0[${PYTHON_USEDEP}]
- >=dev-python/docopt-0.6.1[${PYTHON_USEDEP}]
- <dev-python/docopt-0.7[${PYTHON_USEDEP}]
- >=dev-python/jsonschema-2.5.1[${PYTHON_USEDEP}]
- <dev-python/jsonschema-3[${PYTHON_USEDEP}]
- >=dev-python/PySocks-1.5.6[${PYTHON_USEDEP}]
- !~dev-python/PySocks-1.5.7[${PYTHON_USEDEP}]
- <dev-python/PySocks-2[${PYTHON_USEDEP}]
- >=dev-python/pyyaml-3.10[${PYTHON_USEDEP}]
- <dev-python/pyyaml-4[${PYTHON_USEDEP}]
- !~dev-python/requests-2.11.0[${PYTHON_USEDEP}]
- <dev-python/requests-2.12[${PYTHON_USEDEP}]
- >=dev-python/requests-2.6.1[${PYTHON_USEDEP}]
- >=dev-python/six-1.3.0[${PYTHON_USEDEP}]
- <dev-python/six-2[${PYTHON_USEDEP}]
- >=dev-python/texttable-0.9[${PYTHON_USEDEP}]
- <dev-python/texttable-0.10[${PYTHON_USEDEP}]
- >=dev-python/websocket-client-0.32.0[${PYTHON_USEDEP}]
- <dev-python/websocket-client-1.0[${PYTHON_USEDEP}]
- $(python_gen_cond_dep '>=dev-python/enum34-1.0.4[${PYTHON_USEDEP}]' 'python2_7' )
- $(python_gen_cond_dep '<dev-python/enum34-2[${PYTHON_USEDEP}]' 'python2_7' )
- $(python_gen_cond_dep '>=dev-python/ipaddress-1.0.16[${PYTHON_USEDEP}]' 'python2_7' )
- $(python_gen_cond_dep '>=dev-python/backports-ssl-match-hostname-3.5[${PYTHON_USEDEP}]' 'python2_7' )
-"
-DEPEND="
- ${CDEPEND}
- test? (
- dev-python/pytest[${PYTHON_USEDEP}]
- $(python_gen_cond_dep '>=dev-python/mock-1.0.1[${PYTHON_USEDEP}]' 'python2_7' )
- )
-"
-RDEPEND="${CDEPEND}"
-
-python_test() {
- ${PYTHON} -m pytest tests/unit || die "tests failed under ${EPYTHON}"
-}
-
-python_install_all() {
- newbashcomp contrib/completion/bash/docker-compose ${PN}
-
- insinto /usr/share/zsh/site-functions
- doins contrib/completion/zsh/*
-
- distutils-r1_python_install_all
-}