summaryrefslogtreecommitdiff
path: root/app-emulation/docker-compose/docker-compose-1.29.2.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'app-emulation/docker-compose/docker-compose-1.29.2.ebuild')
-rw-r--r--app-emulation/docker-compose/docker-compose-1.29.2.ebuild11
1 files changed, 5 insertions, 6 deletions
diff --git a/app-emulation/docker-compose/docker-compose-1.29.2.ebuild b/app-emulation/docker-compose/docker-compose-1.29.2.ebuild
index cec99a23828b..8b8382057d29 100644
--- a/app-emulation/docker-compose/docker-compose-1.29.2.ebuild
+++ b/app-emulation/docker-compose/docker-compose-1.29.2.ebuild
@@ -3,8 +3,7 @@
EAPI=7
-PYTHON_COMPAT=( python3_{7,8,9} )
-DISTUTILS_USE_SETUPTOOLS=rdepend
+PYTHON_COMPAT=( python3_{8..10} )
inherit bash-completion-r1 distutils-r1
@@ -16,10 +15,8 @@ SRC_URI="https://github.com/docker/compose/archive/${MY_PV}.tar.gz -> ${P}.tar.g
LICENSE="Apache-2.0"
SLOT="0"
KEYWORDS="amd64 arm64"
-IUSE="test"
-RESTRICT="!test? ( test )"
-RDEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
+RDEPEND="
>=dev-python/cached-property-1.2.0[${PYTHON_USEDEP}]
>=dev-python/distro-1.5.0[${PYTHON_USEDEP}]
>=dev-python/docker-py-5[${PYTHON_USEDEP}]
@@ -43,6 +40,8 @@ DEPEND="${RDEPEND}
S="${WORKDIR}/compose-${MY_PV}"
+distutils_enable_tests pytest
+
PATCHES=(
# Bug #679968 -- https://bugs.gentoo.org/679968
# Bug #681002 -- https://bugs.gentoo.org/681002
@@ -60,7 +59,7 @@ src_prepare() {
python_test() {
distutils_install_for_testing
- ${PYTHON} -m pytest tests/unit/ || die "tests failed under ${EPYTHON}"
+ epytest tests/unit/
}
python_install_all() {