summaryrefslogtreecommitdiff
path: root/app-emulation/dlx/dlx-1.5.20-r1.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'app-emulation/dlx/dlx-1.5.20-r1.ebuild')
-rw-r--r--app-emulation/dlx/dlx-1.5.20-r1.ebuild34
1 files changed, 34 insertions, 0 deletions
diff --git a/app-emulation/dlx/dlx-1.5.20-r1.ebuild b/app-emulation/dlx/dlx-1.5.20-r1.ebuild
new file mode 100644
index 000000000000..138eb0ed9f0d
--- /dev/null
+++ b/app-emulation/dlx/dlx-1.5.20-r1.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit toolchain-funcs
+
+DESCRIPTION="DLX Simulator"
+HOMEPAGE="https://www.davidviner.com/dlx"
+SRC_URI="https://www.davidviner.com/zip/dlx/dlx.zip -> ${P}.zip"
+S="${WORKDIR}"/dlx
+
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+
+BDEPEND="app-arch/unzip"
+
+PATCHES=(
+ "${FILESDIR}/${P}-fix-implicit-function-declarations.patch"
+ "${FILESDIR}/${P}-fix-lto-type-mismatch.patch"
+)
+
+src_compile() {
+ # CXX not used
+ emake CC="$(tc-getCC)" LINK="$(tc-getCC)" \
+ CFLAGS="${CFLAGS} ${CPPFLAGS}" \
+ LFLAGS="${CFLAGS} ${LDFLAGS}"
+}
+
+src_install() {
+ dobin masm mon dasm
+ dodoc README.txt MANUAL.TXT
+}