summaryrefslogtreecommitdiff
path: root/app-emulation/diskimage-builder
diff options
context:
space:
mode:
Diffstat (limited to 'app-emulation/diskimage-builder')
-rw-r--r--app-emulation/diskimage-builder/Manifest2
-rw-r--r--app-emulation/diskimage-builder/diskimage-builder-2.33.0.ebuild42
2 files changed, 44 insertions, 0 deletions
diff --git a/app-emulation/diskimage-builder/Manifest b/app-emulation/diskimage-builder/Manifest
index a0ddd67a0541..3541eab0139f 100644
--- a/app-emulation/diskimage-builder/Manifest
+++ b/app-emulation/diskimage-builder/Manifest
@@ -1,4 +1,6 @@
DIST diskimage-builder-2.32.0.tar.gz 435328 BLAKE2B 78f306430819d94045e3b8c424cdf7a0fee9a306a317e44cd363d53bbbcd1af1f06731b83b63e490bb8ad3903630daf84a544878b87d6c7f377786778229f276 SHA512 357b56aba979cabd7a857d6646412893361c05a83e4260d1ef468de1d6fb0fbc2582ab8bf37428c56a52fafcf708b86be470f2c885008b10368bc92a2b679a09
+DIST diskimage-builder-2.33.0.tar.gz 434041 BLAKE2B 16d14c68e7a54b785426516ecced4adb53b4e84f36d36846732ef7c4823644375373249ceacd1371e39262ebc9050f2f86184718dc3fb17b44eaa20f561410c0 SHA512 125bdcc0a2d4249918485115c49482746e4f86cb7883d3689afd4288a0d18ca97bcb669b811034ccb159879520172ca37bd9f9d7ba4ea509f788be0f3cf2259b
EBUILD diskimage-builder-2.32.0.ebuild 1263 BLAKE2B 53663b8d1dbc080a1cf1336ad650fd556981670841a74086ad9f9ca05be86b2fd76c22d5564440b845a4f74fb3465d10934e133f9285a7d75ed16496b16c7e33 SHA512 ff48e15306d9354abc4782b6c375d0c06cff65c61c253d1802f98ef23e2bff87d4c40ec71ef4025e848dcc37f38e6e5eeadc6e81302c9dac170e0765497b954a
+EBUILD diskimage-builder-2.33.0.ebuild 1264 BLAKE2B 82964cc0c5c2883113358048b5beff59606d615eae7572c21243285654d2009809632272e39c3a11d3bf6c4f595d9ae321345687f09477300d00117c26d3ff72 SHA512 f0a6446ac4eacbfc442bd8a9e09f5058ae559ff75de85b0864ce3716b3b81fe51e804b3dd127fe4fb5e290de690fb8a18069ffd323c1708d1dd854f01d381137
EBUILD diskimage-builder-9999.ebuild 1264 BLAKE2B 00d93d1b48edced670654a2f26195f67ae67db5befd49a7092401cfb707ad7ae54275598788fe6dbf554fd4f745985bbcd7bf0739ce4aede410183b0666e76c4 SHA512 2d3d369188dbca871170f564506a71cfc5d55cfc34fd219de00124cbafbfc680158b6d545b473f3829176f1bb9625f27ce0617d51a6da602a77a6c471d78b5f2
MISC metadata.xml 718 BLAKE2B 04a2c90bcae79f187feb346d0b73f1d6dd1c1581123ca26bfd3182d97239a37e81875d7a3a7b03c4aa08f2974bd25be5f3021e2e48195d5d09e18b606b5b4c87 SHA512 8e16e9d92a81049d414ae54eaf7a4467982cbd949230adcfab22b636ba2b91885d80e9b047788ccd07eab547ae2f85a56d989b971b64bd926e6ca70972398277
diff --git a/app-emulation/diskimage-builder/diskimage-builder-2.33.0.ebuild b/app-emulation/diskimage-builder/diskimage-builder-2.33.0.ebuild
new file mode 100644
index 000000000000..17a0c622b03c
--- /dev/null
+++ b/app-emulation/diskimage-builder/diskimage-builder-2.33.0.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{6,7} )
+inherit distutils-r1
+
+DESCRIPTION="Golden Disk Image builder."
+HOMEPAGE="http://docs.openstack.org/developer/diskimage-builder/"
+if [[ ${PV} == 9999* ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://opendev.org/openstack/diskimage-builder.git"
+else
+ SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+ KEYWORDS="~amd64 ~arm64 ~x86 ~amd64-linux ~x86-linux"
+fi
+
+LICENSE="Apache-2.0"
+SLOT="0"
+IUSE=""
+
+CDEPEND=">=dev-python/pbr-2.0.0[${PYTHON_USEDEP}]
+ !~dev-python/pbr-2.1.0[${PYTHON_USEDEP}]"
+DEPEND="${CDEPEND}
+ dev-python/setuptools[${PYTHON_USEDEP}]"
+RDEPEND="${CDEPEND}
+ >=dev-python/Babel-2.3.4[${PYTHON_USEDEP}]
+ !~dev-python/Babel-2.4.0[${PYTHON_USEDEP}]
+ >=dev-python/networkx-1.10[${PYTHON_USEDEP}]
+ <dev-python/networkx-2.3[${PYTHON_USEDEP}]
+ >=dev-python/pyyaml-3.12[${PYTHON_USEDEP}]
+ >=dev-python/flake8-2.5.4[${PYTHON_USEDEP}]
+ <dev-python/flake8-2.6.0[${PYTHON_USEDEP}]
+ >=dev-python/six-1.10.0[${PYTHON_USEDEP}]
+ >=dev-python/stevedore-1.20.0[${PYTHON_USEDEP}]
+ app-emulation/qemu
+ sys-block/parted
+ sys-fs/multipath-tools
+ sys-fs/dosfstools
+ sys-apps/gptfdisk
+ !dev-python/dib-utils[${PYTHON_USEDEP}]"