summaryrefslogtreecommitdiff
path: root/app-emulation/crun
diff options
context:
space:
mode:
Diffstat (limited to 'app-emulation/crun')
-rw-r--r--app-emulation/crun/Manifest5
-rw-r--r--app-emulation/crun/crun-0.18.ebuild61
-rw-r--r--app-emulation/crun/crun-0.19.1-r1.ebuild (renamed from app-emulation/crun/crun-0.19.1.ebuild)9
-rw-r--r--app-emulation/crun/files/libcrun-linkage.patch29
4 files changed, 40 insertions, 64 deletions
diff --git a/app-emulation/crun/Manifest b/app-emulation/crun/Manifest
index 70212b3d5402..07304e3fb5f7 100644
--- a/app-emulation/crun/Manifest
+++ b/app-emulation/crun/Manifest
@@ -1,5 +1,4 @@
-DIST crun-0.18.tar.gz 1394857 BLAKE2B db4f0407aaf5e4c5b9069ad5ae6a76308665d91559d92bf370b964e0914f337a84af896f1c1e00184ef4b0625bd1c0f1e2fc3295074c7f5524c5359ce54ba6b4 SHA512 94610d9d4ef95a9be708c6cf8cc38587c9c3b847d9da5cf9dfa4a2eddddb7e6724e39ffb222ed5d6c61bad8374ae50dc9e92d95b6d03ce0b185d5123afeeca46
+AUX libcrun-linkage.patch 1155 BLAKE2B b815ada4c90e61ac36e878ba0072f2dc3944e8f82d827e47cc8907fce0931e2134af690261cf75e193fbcb47b4822955d26f3e9950b674c5fafde85f25700032 SHA512 2a1936f3ac3a45cc2fcef61d097c86c78e94ee71ff15dc68d6037bf6be174a6bff725c04ccefff805c9059db3e4db1285c785658b7f6cf4b610739f11e82cfed
DIST crun-0.19.1.tar.gz 1870594 BLAKE2B 1780a2936ff39ec80836c4c9ae072e2fc30703a31a79786337290c62dd433b5a35dcfa953be370703d1baab3de93fdb376c99ab76dff1470883c61726c313144 SHA512 f93f79d1d63d6749bcf92d48542d9555f3ad47657c959c7c06701861d7a5a4171969f00f6dff3878286970a48aba3314c25e35c005463e606533b0ff7843d994
-EBUILD crun-0.18.ebuild 1393 BLAKE2B 202766c3cd321d12f35214d28cb7dde3c7bd5ba916106ec7523923e54d5f6070d66a7486e198f137a2808684ee9ad2f3acc2c25434ed445a4255519ff04adebf SHA512 db0ffd3ae2a3b9a725c25694095b6c5ee6cc7f96eaff1324f3209dd6d5fdf3e200c0072531bc537a063a5dddcfb1cdb6bcfdc9ef5e58c74204de2f624b4d7113
-EBUILD crun-0.19.1.ebuild 1391 BLAKE2B 12467ff7c6a8537132ed36cdb5113258c51c60242cb575429725d51759724b6eb3c4ab8915e21ae85e77aa2371c8897763087915c7906fa85719b377796394e2 SHA512 201aee36f5243014988103b8ae3f29e600cd10fdd68f413aa4b1eba371cd30646d73367de1a23e7a9ead4b41b3e1facc44a2f62f730489582c02a79b6cbdae51
+EBUILD crun-0.19.1-r1.ebuild 1511 BLAKE2B 56dc3607cfccf765c0be5357df9d51f43ad397359f82ce600eeefd39ee03cae12f96a44bcaf22c5f41a538991e577e2f1ff8cc44adf5e711ae869f5cd47e8fc5 SHA512 314589e661a047094b5eac396ec5c982d6b9f2bc25d63fb43e53a6420a4ccc2568fffc476d1a8777dca6bbf2511de16e37e52c28d29b67e9171381db74710857
MISC metadata.xml 1299 BLAKE2B cfa5ced999f15c2aabb6633865fb8bc2f2dc7c2d2b4fa61780de40f975c8a00ad87d7c1251517f7a50b01c3413d2afbe8bca2114ce9eb74d0437285ee6d19d91 SHA512 0f2109b828550df8807736022598f3fa36128ff5224aa61cbb4001689c344b670c124bb85805cdedf8b2e7173b4cc6bc29d7d46ef95f7c9f03c4a9b6e1c93493
diff --git a/app-emulation/crun/crun-0.18.ebuild b/app-emulation/crun/crun-0.18.ebuild
deleted file mode 100644
index bc97b2bddb13..000000000000
--- a/app-emulation/crun/crun-0.18.ebuild
+++ /dev/null
@@ -1,61 +0,0 @@
-# Copyright 2019-2021 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-PYTHON_COMPAT=( python3_{7..9} )
-
-inherit autotools python-any-r1
-
-DESCRIPTION="A fast and low-memory footprint OCI Container Runtime fully written in C"
-HOMEPAGE="https://github.com/containers/crun"
-SRC_URI="https://github.com/containers/${PN}/releases/download/${PV}/${P}.tar.gz"
-
-LICENSE="GPL-2+ LGPL-2.1+"
-SLOT="0"
-KEYWORDS="~amd64 ~arm ~arm64 ~ppc64"
-IUSE="+bpf +caps criu +seccomp systemd static-libs"
-
-DEPEND="
- sys-kernel/linux-headers
- >=dev-libs/yajl-2.0.0
- caps? ( sys-libs/libcap )
- criu? ( >=sys-process/criu-3.15 )
- seccomp? ( sys-libs/libseccomp )
- systemd? ( sys-apps/systemd:= )
-"
-RDEPEND="${DEPEND}"
-BDEPEND="
- ${PYTHON_DEPS}
-"
-
-# the crun test suite is comprehensive to the extent that tests will fail
-# within a sandbox environment, due to the nature of the privileges
-# required to create linux "containers".
-RESTRICT="test"
-
-DOCS=( README.md )
-
-src_configure() {
- local myeconfargs=(
- $(use_enable bpf)
- $(use_enable caps)
- $(use_enable criu)
- $(use_enable seccomp)
- $(use_enable systemd)
- $(usex static-libs '--enable-shared --enable-static' '--enable-shared --disable-static' '' '')
- )
-
- econf "${myeconfargs[@]}"
-}
-
-src_compile() {
- emake -C libocispec
- emake crun
-}
-
-src_install() {
- emake "DESTDIR=${D}" install-exec
- doman crun.1
- einstalldocs
-}
diff --git a/app-emulation/crun/crun-0.19.1.ebuild b/app-emulation/crun/crun-0.19.1-r1.ebuild
index 36091c997004..0590fee263af 100644
--- a/app-emulation/crun/crun-0.19.1.ebuild
+++ b/app-emulation/crun/crun-0.19.1-r1.ebuild
@@ -36,6 +36,15 @@ RESTRICT="test"
DOCS=( README.md )
+PATCHES=( "${FILESDIR}/libcrun-linkage.patch" )
+
+src_prepare() {
+ default
+
+ # for libcrun-linkage.patch
+ eautoreconf
+}
+
src_configure() {
local myeconfargs=(
$(use_enable bpf)
diff --git a/app-emulation/crun/files/libcrun-linkage.patch b/app-emulation/crun/files/libcrun-linkage.patch
new file mode 100644
index 000000000000..72156ac931c8
--- /dev/null
+++ b/app-emulation/crun/files/libcrun-linkage.patch
@@ -0,0 +1,29 @@
+From 7cfdf094071fcff038bab573c1eeee599fa17b16 Mon Sep 17 00:00:00 2001
+From: Georgy Yakovlev <gyakovlev@gentoo.org>
+Date: Mon, 2 Aug 2021 03:53:25 -0700
+Subject: [PATCH] Makefile.am: link libcrun to $(FOUND_LIBS)
+
+otherwise libcrun consumers fail at runtime with
+symbol lookup errors
+
+Closes: https://github.com/containers/crun/issues/711
+Issue: https://github.com/containers/crun/issues/340
+Downstream-bug: https://bugs.gentoo.org/717750
+Signed-off-by: Georgy Yakovlev <gyakovlev@gentoo.org>
+---
+ Makefile.am | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+diff --git a/Makefile.am b/Makefile.am
+index 150e933a..7e5a4406 100644
+--- a/Makefile.am
++++ b/Makefile.am
+@@ -46,7 +46,7 @@ libocispec/libocispec.la:
+
+ libcrun_la_SOURCES = $(libcrun_SOURCES)
+ libcrun_la_CFLAGS = -I $(abs_top_builddir)/libocispec/src -I $(abs_top_srcdir)/libocispec/src -fvisibility=hidden
+-libcrun_la_LIBADD = libocispec/libocispec.la $(maybe_libyajl.la)
++libcrun_la_LIBADD = libocispec/libocispec.la $(FOUND_LIBS) $(maybe_libyajl.la)
+ libcrun_la_LDFLAGS = -Wl,--version-script=$(abs_top_srcdir)/libcrun.lds
+
+ # build a version with all the symbols visible for testing