summaryrefslogtreecommitdiff
path: root/app-emulation/containerd/containerd-1.0.3_p20180223.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'app-emulation/containerd/containerd-1.0.3_p20180223.ebuild')
-rw-r--r--app-emulation/containerd/containerd-1.0.3_p20180223.ebuild54
1 files changed, 0 insertions, 54 deletions
diff --git a/app-emulation/containerd/containerd-1.0.3_p20180223.ebuild b/app-emulation/containerd/containerd-1.0.3_p20180223.ebuild
deleted file mode 100644
index 3c7eee7d07d2..000000000000
--- a/app-emulation/containerd/containerd-1.0.3_p20180223.ebuild
+++ /dev/null
@@ -1,54 +0,0 @@
-# Copyright 1999-2018 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-EGO_PN="github.com/containerd/${PN}"
-
-inherit toolchain-funcs
-
-if [[ ${PV} == *9999 ]]; then
- inherit golang-vcs
-else
- MY_PV="${PV/_rc/-rc.}"
- EGIT_COMMIT="v${MY_PV}"
- CONTAINERD_COMMIT="4ac4fd0b6a268fe6f38b2b2e32e40daa7e424fac"
- SRC_URI="https://${EGO_PN}/archive/${CONTAINERD_COMMIT}.tar.gz -> ${P}.tar.gz"
- KEYWORDS="~amd64 ~arm ~arm64 ~ppc64"
- inherit golang-vcs-snapshot
-fi
-
-DESCRIPTION="A daemon to control runC"
-HOMEPAGE="https://containerd.tools"
-
-LICENSE="Apache-2.0"
-SLOT="0"
-IUSE="+btrfs hardened"
-
-DEPEND="btrfs? ( sys-fs/btrfs-progs )"
-RDEPEND="|| ( >=app-emulation/docker-runc-1.0.0_rc4
- >=app-emulation/runc-1.0.0_rc4 )
- sys-libs/libseccomp"
-
-S=${WORKDIR}/${P}/src/${EGO_PN}
-
-RESTRICT="test"
-
-src_prepare() {
- default
- if [[ ${PV} != *9999* ]]; then
- sed -i -e "s/git describe --match.*$/echo ${PV})/"\
- -e "s/git rev-parse HEAD.*$/echo $CONTAINERD_COMMIT)/"\
- -e "s/-s -w//" \
- Makefile || die
- fi
-}
-
-src_compile() {
- local options=( $(usex btrfs "" "no_btrfs") )
- export GOPATH="${WORKDIR}/${P}" # ${PWD}/vendor
- LDFLAGS=$(usex hardened '-extldflags -fno-PIC' '') emake BUILDTAGS="${options[@]}"
-}
-
-src_install() {
- dobin bin/containerd{-shim,-stress,} bin/ctr
-}