summaryrefslogtreecommitdiff
path: root/app-emacs
diff options
context:
space:
mode:
Diffstat (limited to 'app-emacs')
-rw-r--r--app-emacs/Manifest.gzbin76959 -> 76973 bytes
-rw-r--r--app-emacs/counsel/Manifest2
-rw-r--r--app-emacs/counsel/counsel-0.15.0.ebuild48
-rw-r--r--app-emacs/ivy/Manifest3
-rw-r--r--app-emacs/ivy/files/ivy-0.15.0-ivy-test.patch11
-rw-r--r--app-emacs/ivy/ivy-0.15.0.ebuild65
-rw-r--r--app-emacs/swiper/Manifest2
-rw-r--r--app-emacs/swiper/swiper-0.15.0.ebuild47
8 files changed, 178 insertions, 0 deletions
diff --git a/app-emacs/Manifest.gz b/app-emacs/Manifest.gz
index 11b17c681482..01964c243ac6 100644
--- a/app-emacs/Manifest.gz
+++ b/app-emacs/Manifest.gz
Binary files differ
diff --git a/app-emacs/counsel/Manifest b/app-emacs/counsel/Manifest
index 7360191640fd..bf0e9d8b8387 100644
--- a/app-emacs/counsel/Manifest
+++ b/app-emacs/counsel/Manifest
@@ -1,4 +1,6 @@
AUX 50counsel-gentoo.el 110 BLAKE2B 223dc0b9991156d3494e9e954624ec060515231f5ca979345864dad802ccaaaff02eb43e13a7af5eed581e4189005493bbda3d849ef8c7b9b877993f9e096a78 SHA512 be21f737978b64065af31df15320ddb06f255a258d05d75227f4762a35a6eb86b0012561a40f7f72f154af58c0ce240c50958a8020d3a0dc5054c6b5834b80c8
DIST swiper-0.14.2.tar.gz 250059 BLAKE2B 8a5437726c729398a689266d138f271f5f7329f9c58613c4e0cfabd16b99421035c4b522d0ea4c60c0369362cb076bcae05ff4155d33d186172fd0ac2258495d SHA512 e125a3747abc4e6ecc98f539cf5dde11851d6c8a58b8988e165300bce7822fc91257cae09c973bd43435fb08dc24af9a1bd4b3e51083b45654b1605d80973d74
+DIST swiper-0.15.0.gh.tar.gz 255140 BLAKE2B becd63e0c291eccaf6b9520b0b50201aecbc5245128285384780ad8124294c3f7103ae7197db766b69c2ee3f32b5039fea47bd1303fab90d15ef8c109388e533 SHA512 c37c7482aae8d595181dab11ae613c52ae917c909033e3534ac5c78d090d1f67e2f36917a76b0dd4cfc8a339ed76c2480a7ca26a033b8be69dc3a128a0ccf00f
EBUILD counsel-0.14.2.ebuild 768 BLAKE2B e9ec9d5be3fcefb8d76b2a30a51586be3c97eeb180ff850383e6e778452964d5a2442fa76ceb00f1be5222d780af7f384f91346fe614b6e28ced2d5082b24908 SHA512 10c946c5738a21480032572f14e8248a52c4ecbc4a9b5ea11700d8f0c1f91fa250a5d1a3da87218254926307980ec4457feba0ab5f9d46018e3172c9c3e2ed31
+EBUILD counsel-0.15.0.ebuild 918 BLAKE2B a693dd5ca9288495d0c62ea75ea33da6af93a2a673606667603bbab15dd9f077f7f50f0258863decaffdaebd7376740ee744ae2180834d4b3b7a27ccc41716cb SHA512 78f3fe36a0a07832709e5446aecc4a805f23fb6a4caca0c4e59eef3b0c4ce0c70af5064f854c46b458d5473fdf5db7f88316b378889d7a1b69aefbec9c5017b2
MISC metadata.xml 597 BLAKE2B 596d80d3c2fd29ce075b056874d9f6357dfb0ae03442cf2dde601a799a1f531fbcd6c13be5d4f3dcbd2c0f842e88db2835ce796c5e420e2042760c0c14ea826e SHA512 a798bc29542e614a8f09e5f080fa2e67268f787c1bf7e399ac851d7d1c8c14843a82ec35578e7036b3897f13b0bc4286ce1d2b2c31632daf1331670e0abe46ee
diff --git a/app-emacs/counsel/counsel-0.15.0.ebuild b/app-emacs/counsel/counsel-0.15.0.ebuild
new file mode 100644
index 000000000000..f638c6e986cd
--- /dev/null
+++ b/app-emacs/counsel/counsel-0.15.0.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2025 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit elisp
+
+DESCRIPTION="Versions of common Emacs commands customized to make the best use of ivy"
+HOMEPAGE="https://github.com/abo-abo/swiper/"
+
+if [[ "${PV}" == *9999* ]] ; then
+ inherit git-r3
+
+ EGIT_REPO_URI="https://github.com/abo-abo/swiper"
+else
+ SRC_URI="https://github.com/abo-abo/swiper/archive/${PV}.tar.gz
+ -> swiper-${PV}.gh.tar.gz"
+ S="${WORKDIR}/swiper-${PV}"
+
+ KEYWORDS="~amd64 ~x86"
+fi
+
+LICENSE="GPL-3+"
+SLOT="0"
+RESTRICT="test" # Ivy, Swiper and Counsel tests are performed in "app-emacs/ivy".
+
+RDEPEND="
+ >=app-emacs/ivy-${PV}
+ >=app-emacs/swiper-${PV}
+"
+BDEPEND="
+ ${RDEPEND}
+"
+
+SITEFILE="50${PN}-gentoo.el"
+
+src_compile() {
+ elisp-compile "${PN}.el"
+}
+
+src_test() {
+ :
+}
+
+src_install() {
+ elisp-install "${PN}" "${PN}.el"{,c}
+ elisp-site-file-install "${FILESDIR}/${SITEFILE}"
+}
diff --git a/app-emacs/ivy/Manifest b/app-emacs/ivy/Manifest
index 921f1641d01d..7dee1b971614 100644
--- a/app-emacs/ivy/Manifest
+++ b/app-emacs/ivy/Manifest
@@ -1,4 +1,7 @@
AUX 50ivy-gentoo.el 98 BLAKE2B 4d474a2c101b1cee20da1c56e5336b31df2a75cf5bf24251ba4c72c9d7cfb6cad9cac61923ca1d5ae83370e94cae545cb276cfa6df3f7bd528bd36fdb9e3156a SHA512 ccd9987b868c613535465b9c3041fb2a8c44561b678fe7bf40a276dff272deafb4bc14ce61228ed9cc27f2d0439652aa888e07c0120f6e2a246b0b5fa30a246e
+AUX ivy-0.15.0-ivy-test.patch 371 BLAKE2B 24c54641696328dae49de0cada8bb3d38073f05defa54ae1de3aea4409b608bd2d2575a244ee664992a1c69e8c147aba18f434f218e4f4ff0529bcf0f1606abf SHA512 e880a2377bccf80de6536020c2ac5dd084bf499dbcc45e5619a0804394770d20b527316e3d3694b90bb7f9952b8f7c836a847108661d3a6930390d56c227bb76
DIST swiper-0.14.2.tar.gz 250059 BLAKE2B 8a5437726c729398a689266d138f271f5f7329f9c58613c4e0cfabd16b99421035c4b522d0ea4c60c0369362cb076bcae05ff4155d33d186172fd0ac2258495d SHA512 e125a3747abc4e6ecc98f539cf5dde11851d6c8a58b8988e165300bce7822fc91257cae09c973bd43435fb08dc24af9a1bd4b3e51083b45654b1605d80973d74
+DIST swiper-0.15.0.gh.tar.gz 255140 BLAKE2B becd63e0c291eccaf6b9520b0b50201aecbc5245128285384780ad8124294c3f7103ae7197db766b69c2ee3f32b5039fea47bd1303fab90d15ef8c109388e533 SHA512 c37c7482aae8d595181dab11ae613c52ae917c909033e3534ac5c78d090d1f67e2f36917a76b0dd4cfc8a339ed76c2480a7ca26a033b8be69dc3a128a0ccf00f
EBUILD ivy-0.14.2.ebuild 1166 BLAKE2B b05ebb90ebd7baa3d40eb610b2bf8d6d3574151d8be200ee47d44f8b92557c3b024558210f657050e2f4c6498e8728a751de8ada041cb76dd8a71efb92978ca3 SHA512 2390e00dbfe3da576c99f09b17807a83eb96a0b3e9d28a8c12e00202ae6df42304b73b3903286ab6f4306278d4abdca2a67fbe77937bfb7301bb450865f43fb7
+EBUILD ivy-0.15.0.ebuild 1337 BLAKE2B 0695adb6d853b5e892b4adbc656bf5510ffe0b4f5176429bb5e0c320bb7cd603aed27590871fb51d8bac8b7f7e09b702f51449179037aa47d0b4052ed9d20e95 SHA512 3a408f7cc0e7659d632f4f7d950ac68f55a06714b11cc27921b6ea0ffebfbfd8915de5ad70d4c009729e3c710a9e229014fe6c5ff41b50b60577ceb9d7167329
MISC metadata.xml 597 BLAKE2B 596d80d3c2fd29ce075b056874d9f6357dfb0ae03442cf2dde601a799a1f531fbcd6c13be5d4f3dcbd2c0f842e88db2835ce796c5e420e2042760c0c14ea826e SHA512 a798bc29542e614a8f09e5f080fa2e67268f787c1bf7e399ac851d7d1c8c14843a82ec35578e7036b3897f13b0bc4286ce1d2b2c31632daf1331670e0abe46ee
diff --git a/app-emacs/ivy/files/ivy-0.15.0-ivy-test.patch b/app-emacs/ivy/files/ivy-0.15.0-ivy-test.patch
new file mode 100644
index 000000000000..cf5dd7a4911f
--- /dev/null
+++ b/app-emacs/ivy/files/ivy-0.15.0-ivy-test.patch
@@ -0,0 +1,11 @@
+--- a/ivy-test.el
++++ b/ivy-test.el
+@@ -53,7 +53,7 @@ Intended as :after-while advice for `require'."
+
+ (setq ivy-last (make-ivy-state))
+
+-(ert-deftest ivy--lazy-load-ffap--ffap-url-p ()
++(defun ivy--lazy-load-ffap--ffap-url-p ()
+ (should (not (memq 'ffap ivy-features)))
+ (should (not (fboundp 'ffap-url-p)))
+ (should (string= (ivy-ffap-url-p "https://foo.org")
diff --git a/app-emacs/ivy/ivy-0.15.0.ebuild b/app-emacs/ivy/ivy-0.15.0.ebuild
new file mode 100644
index 000000000000..fd167e457832
--- /dev/null
+++ b/app-emacs/ivy/ivy-0.15.0.ebuild
@@ -0,0 +1,65 @@
+# Copyright 1999-2025 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit elisp
+
+DESCRIPTION="Generic completion mechanism for Emacs"
+HOMEPAGE="https://github.com/abo-abo/swiper/"
+
+if [[ "${PV}" == *9999* ]] ; then
+ inherit git-r3
+
+ EGIT_REPO_URI="https://github.com/abo-abo/swiper"
+else
+ SRC_URI="https://github.com/abo-abo/swiper/archive/${PV}.tar.gz
+ -> swiper-${PV}.gh.tar.gz"
+ S="${WORKDIR}/swiper-${PV}"
+
+ KEYWORDS="~amd64 ~x86"
+fi
+
+LICENSE="GPL-3+"
+SLOT="0"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+BDEPEND="
+ sys-apps/texinfo
+ test? (
+ app-emacs/avy
+ app-emacs/hydra
+ )
+"
+
+PATCHES=( "${FILESDIR}/ivy-0.15.0-ivy-test.patch" )
+
+DOCS=( CONTRIBUTING.org README.md doc/{Changelog,ivy-help,ivy}.org )
+SITEFILE="50${PN}-gentoo.el"
+
+# Main Ivy sources. Swiper, Counsel and Ivy extensions have their own packages.
+EL_SOURCES=( colir.el ivy{,-overlay,-faces}.el )
+
+elisp-enable-tests ert .
+
+src_prepare() {
+ elisp_src_prepare
+
+ # Wipe "elpa.el" to prevent initialization of the "package" library.
+ echo "" > elpa.el || die "failed to wipe \"elpa.el\""
+}
+
+src_compile() {
+ elisp-compile "${EL_SOURCES[@]}"
+
+ emake -C doc ivy.info
+}
+
+src_install() {
+ elisp-install "${PN}" "${EL_SOURCES[@]}" ./*.elc
+ elisp-site-file-install "${FILESDIR}/${SITEFILE}"
+
+ doinfo ./doc/ivy.info
+ einstalldocs
+}
diff --git a/app-emacs/swiper/Manifest b/app-emacs/swiper/Manifest
index 290937d2a83d..d6aee04a72ac 100644
--- a/app-emacs/swiper/Manifest
+++ b/app-emacs/swiper/Manifest
@@ -1,4 +1,6 @@
AUX 50swiper-gentoo.el 108 BLAKE2B fae1fd6258927f672a77b42eb6c826fa246d77e6ce5984c923d272001a6e7f4b523c47fcdec7103845e9705b43cea7e9a91904f6ef0f56fae4de8aa507d57d75 SHA512 1fab726ea0f7288a3f8daee32f2b70f4ca59de0e31144bc88c405a3418f342eb56d96c09754b118831aa33c55e64db8ee9e0df18821d20c1bbf2df4a4034142f
DIST swiper-0.14.2.tar.gz 250059 BLAKE2B 8a5437726c729398a689266d138f271f5f7329f9c58613c4e0cfabd16b99421035c4b522d0ea4c60c0369362cb076bcae05ff4155d33d186172fd0ac2258495d SHA512 e125a3747abc4e6ecc98f539cf5dde11851d6c8a58b8988e165300bce7822fc91257cae09c973bd43435fb08dc24af9a1bd4b3e51083b45654b1605d80973d74
+DIST swiper-0.15.0.gh.tar.gz 255140 BLAKE2B becd63e0c291eccaf6b9520b0b50201aecbc5245128285384780ad8124294c3f7103ae7197db766b69c2ee3f32b5039fea47bd1303fab90d15ef8c109388e533 SHA512 c37c7482aae8d595181dab11ae613c52ae917c909033e3534ac5c78d090d1f67e2f36917a76b0dd4cfc8a339ed76c2480a7ca26a033b8be69dc3a128a0ccf00f
EBUILD swiper-0.14.2.ebuild 695 BLAKE2B 6a12e3cf8c625e0c1a7302ab5326a94148901d99772c8b452cfcfb957395edc2688c96dcac787081888704706a37b211564288230ca3863b9c92c6348954109e SHA512 5f99175870cae2ccebbaf9732cbc104570b8488ab6fa0fb349132c4b42406de4a36925ae7225d56bd188c86efdda6bf832133094441c6dc0cad1167fcc98c958
+EBUILD swiper-0.15.0.ebuild 888 BLAKE2B 6862b28ee84a585b21380df6894782c72027f466de13c937b65b3bfcd7e488a4ea4b20e3b9735dbfecb734fe39896ce331f263eb893542d93d19c763b55c9ccd SHA512 1f56001e66ac689b53e82bc5a38fee3160a1fdb72c444fdbfc20f55e14f4a4d1a0bc9897da485386368b871ebec3564877c721e6f5af042befd98441b76820d8
MISC metadata.xml 597 BLAKE2B 596d80d3c2fd29ce075b056874d9f6357dfb0ae03442cf2dde601a799a1f531fbcd6c13be5d4f3dcbd2c0f842e88db2835ce796c5e420e2042760c0c14ea826e SHA512 a798bc29542e614a8f09e5f080fa2e67268f787c1bf7e399ac851d7d1c8c14843a82ec35578e7036b3897f13b0bc4286ce1d2b2c31632daf1331670e0abe46ee
diff --git a/app-emacs/swiper/swiper-0.15.0.ebuild b/app-emacs/swiper/swiper-0.15.0.ebuild
new file mode 100644
index 000000000000..1a0ced5c1feb
--- /dev/null
+++ b/app-emacs/swiper/swiper-0.15.0.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2025 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit elisp
+
+DESCRIPTION="Alternative to isearch that uses ivy to show overview of all matches"
+HOMEPAGE="https://github.com/abo-abo/swiper/"
+
+if [[ "${PV}" == *9999* ]] ; then
+ inherit git-r3
+
+ EGIT_REPO_URI="https://github.com/abo-abo/swiper"
+else
+ SRC_URI="https://github.com/abo-abo/swiper/archive/${PV}.tar.gz
+ -> swiper-${PV}.gh.tar.gz"
+ S="${WORKDIR}/swiper-${PV}"
+
+ KEYWORDS="~amd64 ~x86"
+fi
+
+LICENSE="GPL-3+"
+SLOT="0"
+RESTRICT="test" # Ivy, Swiper and Counsel tests are performed in "app-emacs/ivy".
+
+RDEPEND="
+ >=app-emacs/ivy-${PV}
+"
+BDEPEND="
+ ${RDEPEND}
+"
+
+SITEFILE="50${PN}-gentoo.el"
+
+src_compile() {
+ elisp-compile "${PN}.el"
+}
+
+src_test() {
+ :
+}
+
+src_install() {
+ elisp-install "${PN}" "${PN}.el"{,c}
+ elisp-site-file-install "${FILESDIR}/${SITEFILE}"
+}