summaryrefslogtreecommitdiff
path: root/app-emacs
diff options
context:
space:
mode:
Diffstat (limited to 'app-emacs')
-rw-r--r--app-emacs/Manifest.gzbin71793 -> 71793 bytes
-rw-r--r--app-emacs/pymacs/Manifest1
-rw-r--r--app-emacs/pymacs/pymacs-0.26-r4.ebuild62
3 files changed, 63 insertions, 0 deletions
diff --git a/app-emacs/Manifest.gz b/app-emacs/Manifest.gz
index 992a825b2e95..8d4f63f45180 100644
--- a/app-emacs/Manifest.gz
+++ b/app-emacs/Manifest.gz
Binary files differ
diff --git a/app-emacs/pymacs/Manifest b/app-emacs/pymacs/Manifest
index 2c63b27b1abe..4cd03b4ac09d 100644
--- a/app-emacs/pymacs/Manifest
+++ b/app-emacs/pymacs/Manifest
@@ -1,4 +1,5 @@
AUX 50pymacs-gentoo.el 183 BLAKE2B f1a4b874bb339b653c4fb6fb186bd7e531151c34d1df58be6963288d4443438fcae0f82c92a1667b4e7cb739bc2f7c6fd8d8d5f6d4e91413ee5bec47a609cc2e SHA512 f59fed86f859b796c901088b38fb570a5e5527d774a15456105ce75598c31fd20d0afaa62ad9cbf12063810fa592dbbd7c33aaece5871b36b488e5af6de0fac2
DIST pymacs-0.26.tar.gz 123373 BLAKE2B 0c467435d18ebcbe7b263e90096363e201dd84ba770fa702beefac4318a713954c316f335ee005ea88370be29c3710a7df04fb05b6efd3816beedbb88e38126d SHA512 ae245de130f435d947788c5ac11d8ce6534df80f70a4e35fff903f22d2b79b0f66925059ebaf53bde45cd6660ac0a8a224490f4f9e256a84e3a08f6468c14dd2
EBUILD pymacs-0.26-r3.ebuild 1191 BLAKE2B 7b4014b5c4745f13044242ecc0cb6f481705025cc42ee943e158ff25a4f5163d971958cb35d2c6271f1a430f50870cc86e71dfc69b097c02f5f2c01d3cfde29a SHA512 cb54a8043b4b196188808b6d93d44e49878b5a561f49bfba022742f41d2a702d9043adf43d5a001e820d637000197a22fc6c1cb9fa2a8c1931ae40274e570e85
+EBUILD pymacs-0.26-r4.ebuild 1225 BLAKE2B 2d6bdd3b1c58b013ea265dd66c5060ad0fa0dffc7ede85c71722b46fb8ec9937e6630344ea39fe9e4f0fe8dd86549ea364bc561edf5dee2d717a0e54eb3c1a7e SHA512 37ca1d2fb67de6b08c0fc8ce84906ce4b790f4b02353459b848fb0e12b4b2dc84c4a3f1c34417e7a0e5f1aa1dfc1c42578aef6c8d5ce047d07d8badef35f90ed
MISC metadata.xml 436 BLAKE2B 4239aac38b2303531a3792704946f0039b484aaa1561a336ffb4955aecd3a6881051a8de0a8d9c2b2c628e2ef45a448519fa70efd2698a64a4f07d38adb04b07 SHA512 4be8dd1573dee1c631449a512d6da4ff02f9917c4132477ad5383432521087a3f5468698d1a0b9906fc76367b75bca9d25e6da3ce0142be5fb4e4b7e225651d9
diff --git a/app-emacs/pymacs/pymacs-0.26-r4.ebuild b/app-emacs/pymacs/pymacs-0.26-r4.ebuild
new file mode 100644
index 000000000000..3f6d1c1d330d
--- /dev/null
+++ b/app-emacs/pymacs/pymacs-0.26-r4.ebuild
@@ -0,0 +1,62 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..11} )
+
+inherit elisp distutils-r1
+
+DESCRIPTION="A tool that allows both-side communication between Python and Emacs Lisp"
+HOMEPAGE="https://www.emacswiki.org/emacs/PyMacs
+ https://github.com/dgentry/Pymacs/"
+
+if [[ ${PV} == *9999* ]] ; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/dgentry/${PN^}.git"
+else
+ SRC_URI="https://github.com/dgentry/${PN^}/archive/v${PV}.tar.gz
+ -> ${P}.tar.gz"
+ S="${WORKDIR}"/${P^}
+ KEYWORDS="~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~x86 ~amd64-linux ~x86-linux ~ppc-macos"
+fi
+
+LICENSE="GPL-2+"
+SLOT="0"
+IUSE="doc"
+
+BDEPEND="
+ doc? (
+ >=dev-python/docutils-0.7
+ virtual/latex-base
+ )
+"
+
+DOCS=( ${PN}.rst )
+SITEFILE="50${PN}-gentoo.el"
+
+python_configure() {
+ emake PYSETUP=: PYTHON=${EPYTHON} prepare
+}
+
+src_prepare() {
+ distutils-r1_src_prepare
+ elisp_src_prepare
+}
+
+src_compile() {
+ distutils-r1_src_compile
+ elisp_src_compile
+
+ if use doc; then
+ VARTEXFONTS="${T}"/fonts emake RST2LATEX=rst2latex.py ${PN}.pdf
+ fi
+}
+
+src_install() {
+ distutils-r1_src_install
+ elisp_src_install
+
+ use doc && dodoc ${PN}.pdf
+}