summaryrefslogtreecommitdiff
path: root/app-emacs/speed-type/speed-type-20230206.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'app-emacs/speed-type/speed-type-20230206.ebuild')
-rw-r--r--app-emacs/speed-type/speed-type-20230206.ebuild26
1 files changed, 26 insertions, 0 deletions
diff --git a/app-emacs/speed-type/speed-type-20230206.ebuild b/app-emacs/speed-type/speed-type-20230206.ebuild
new file mode 100644
index 000000000000..90272f9b7952
--- /dev/null
+++ b/app-emacs/speed-type/speed-type-20230206.ebuild
@@ -0,0 +1,26 @@
+# Copyright 2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit elisp
+
+MY_COMMIT=4f8553632d71e827b4da6e091143779d2ad970a8
+DESCRIPTION="Practice touch and speed typing"
+HOMEPAGE="https://github.com/dakra/speed-type"
+SRC_URI="https://github.com/dakra/speed-type/archive/${MY_COMMIT}.tar.gz -> ${P}.tar.gz"
+S="${WORKDIR}"/${PN}-${MY_COMMIT}
+
+LICENSE="GPL-3+"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND=">=app-emacs/compat-29.1"
+DEPEND="${RDEPEND}"
+
+SITEFILE=50${PN}-gentoo.el
+
+src_compile() {
+ elisp_src_compile
+ elisp-make-autoload-file
+}