summaryrefslogtreecommitdiff
path: root/app-emacs/projectile/projectile-2.8.0.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'app-emacs/projectile/projectile-2.8.0.ebuild')
-rw-r--r--app-emacs/projectile/projectile-2.8.0.ebuild27
1 files changed, 27 insertions, 0 deletions
diff --git a/app-emacs/projectile/projectile-2.8.0.ebuild b/app-emacs/projectile/projectile-2.8.0.ebuild
new file mode 100644
index 000000000000..8d0320cd4ee2
--- /dev/null
+++ b/app-emacs/projectile/projectile-2.8.0.ebuild
@@ -0,0 +1,27 @@
+# Copyright 2021-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit elisp
+
+DESCRIPTION="A project interaction library for Emacs"
+HOMEPAGE="https://docs.projectile.mx
+ https://github.com/bbatsov/projectile/"
+SRC_URI="https://github.com/bbatsov/projectile/archive/v${PV}.tar.gz
+ -> ${P}.tar.gz"
+
+LICENSE="GPL-3+"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~x86"
+
+SITEFILE="50projectile-gentoo.el"
+DOCS=( README.md )
+
+elisp-enable-tests buttercup test
+
+src_test() {
+ mkdir -p "${HOME}"/.emacs.d || die # For "projectile--directory-p" test
+
+ elisp-test
+}