summaryrefslogtreecommitdiff
path: root/app-emacs/parsebib
diff options
context:
space:
mode:
Diffstat (limited to 'app-emacs/parsebib')
-rw-r--r--app-emacs/parsebib/Manifest2
-rw-r--r--app-emacs/parsebib/parsebib-4.3.ebuild24
2 files changed, 14 insertions, 12 deletions
diff --git a/app-emacs/parsebib/Manifest b/app-emacs/parsebib/Manifest
index 3cd6cad5db0f..fb4da08cb526 100644
--- a/app-emacs/parsebib/Manifest
+++ b/app-emacs/parsebib/Manifest
@@ -1,3 +1,3 @@
DIST parsebib-4.3.tar.gz 25195 BLAKE2B 9b3031f7f6b8d69b026d1301c95fde6279eedb4cb55a975294d9f32a57508ac14c33c5874da14da7e14de5c58fd7915d9a9132859fb46cf4910d37d963876929 SHA512 b036ff496d4d435cdb6fbcd57b1844601417d94faf34294b593ec7947e40a8f4807de12e17c659e8cc6b0a5a17f62d45c51671b5568cf27f1af9890298324215
-EBUILD parsebib-4.3.ebuild 586 BLAKE2B b8917e2ed193b97dc409e980dfd01e9aba0aad3790fdd4ecf52f42573e279fe2100a1128cf8644596fce41b293af65983970d797602f455e92ec4c1db75d6f9e SHA512 338ea8922ee2f4ebcc17429a543bd3158ad1d320a1939fb45ff3f021f6a1654f160922f385b9b742b1625ef1ac90af01d82a1bab23b586156947a0eac56d9968
+EBUILD parsebib-4.3.ebuild 576 BLAKE2B 313b811b8482882ab88e4d3cb46f1aa97b24195f6ad0850acb39d1811eb50e8ff426ffe9785cf6c92cd6165fcd3b529a9b86a324867f57779a02cb09088282a2 SHA512 bd00d628a088fbb3a0d9685a4257e838bfba9a487f7aa41d559dbd9ef5a62449f6907bc424f3d09499ac91e62ae0e774e63c595380e30141a347ea56b630ae55
MISC metadata.xml 627 BLAKE2B c720728d95d1210afc6015d7472134e9078fbc67f591e4991dd34a780c49c8b30c1dec30c6ce57d81034f71895aafb8637c8181d7cdc9e13819ecceea919cc98 SHA512 a991dcfa3ddc97afc341228c4483c888de999eb79f67cb174e12a8d9725da58468c6e1330d8f5e2ef7e947e108e6eba1edba4fceca7955793b6d8a0c223d1f4a
diff --git a/app-emacs/parsebib/parsebib-4.3.ebuild b/app-emacs/parsebib/parsebib-4.3.ebuild
index 86b48a11e4ab..eccdb4d8583f 100644
--- a/app-emacs/parsebib/parsebib-4.3.ebuild
+++ b/app-emacs/parsebib/parsebib-4.3.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2023 Gentoo Authors
+# Copyright 1999-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
@@ -7,20 +7,22 @@ inherit elisp
DESCRIPTION="Emacs Lisp library for reading .bib files"
HOMEPAGE="https://github.com/joostkremers/parsebib/"
-SRC_URI="https://github.com/joostkremers/${PN}/archive/${PV}.tar.gz
- -> ${P}.tar.gz"
+
+if [[ "${PV}" == *9999* ]] ; then
+ inherit git-r3
+
+ EGIT_REPO_URI="https://github.com/joostkremers/${PN}.git"
+else
+ SRC_URI="https://github.com/joostkremers/${PN}/archive/${PV}.tar.gz
+ -> ${P}.tar.gz"
+
+ KEYWORDS="amd64 ~x86"
+fi
LICENSE="BSD"
-KEYWORDS="amd64 ~x86"
SLOT="0"
-IUSE="test"
-RESTRICT="!test? ( test )"
-
-BDEPEND="test? ( app-emacs/ert-runner )"
DOCS=( README.md )
SITEFILE="50${PN}-gentoo.el"
-src_test() {
- ert-runner -L . -L test --reporter ert+duration --script test || die
-}
+elisp-enable-tests ert-runner test