summaryrefslogtreecommitdiff
path: root/app-emacs/ht/ht-2.3.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'app-emacs/ht/ht-2.3.ebuild')
-rw-r--r--app-emacs/ht/ht-2.3.ebuild28
1 files changed, 28 insertions, 0 deletions
diff --git a/app-emacs/ht/ht-2.3.ebuild b/app-emacs/ht/ht-2.3.ebuild
new file mode 100644
index 000000000000..2b56bec9cad3
--- /dev/null
+++ b/app-emacs/ht/ht-2.3.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit elisp
+
+IUSE=""
+
+DESCRIPTION="The missing hash table library for Emacs"
+HOMEPAGE="https://github.com/Wilfred/ht.el"
+SRC_URI="https://github.com/Wilfred/ht.el/archive/${PV}.tar.gz -> ${P}.tar.gz"
+LICENSE="GPL-3+"
+SLOT="0"
+KEYWORDS="~amd64"
+DOCS="CHANGELOG.md README.md"
+
+SITEFILE="50${PN}-gentoo.el"
+
+RDEPEND="
+ >=app-emacs/dash-2.12.0
+"
+DEPEND=${RDEPEND}
+
+S="${WORKDIR}/ht.el-${PV}"
+
+# Requires unpackaged dependencies, e.g. Cask
+RESTRICT="test"