summaryrefslogtreecommitdiff
path: root/app-emacs/howm/howm-1.4.5.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'app-emacs/howm/howm-1.4.5.ebuild')
-rw-r--r--app-emacs/howm/howm-1.4.5.ebuild30
1 files changed, 30 insertions, 0 deletions
diff --git a/app-emacs/howm/howm-1.4.5.ebuild b/app-emacs/howm/howm-1.4.5.ebuild
new file mode 100644
index 000000000000..389c61d210e3
--- /dev/null
+++ b/app-emacs/howm/howm-1.4.5.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit elisp
+
+DESCRIPTION="Note-taking tool on Emacs"
+HOMEPAGE="https://howm.sourceforge.jp/"
+SRC_URI="http://howm.sourceforge.jp/a/${P}.tar.gz"
+
+LICENSE="GPL-1+ GPL-2+"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86 ~amd64-linux ~x86-linux ~ppc-macos"
+
+SITEFILE="50${PN}-gentoo.el"
+
+src_configure() {
+ default
+}
+
+src_compile() {
+ emake -j1 </dev/null
+}
+
+src_install() {
+ emake -j1 DESTDIR="${D}" install </dev/null
+ elisp-site-file-install "${FILESDIR}/${SITEFILE}"
+ dodoc ChangeLog
+}