summaryrefslogtreecommitdiff
path: root/app-emacs/ghub/ghub-3.2.0.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'app-emacs/ghub/ghub-3.2.0.ebuild')
-rw-r--r--app-emacs/ghub/ghub-3.2.0.ebuild27
1 files changed, 27 insertions, 0 deletions
diff --git a/app-emacs/ghub/ghub-3.2.0.ebuild b/app-emacs/ghub/ghub-3.2.0.ebuild
new file mode 100644
index 000000000000..274ca19590d2
--- /dev/null
+++ b/app-emacs/ghub/ghub-3.2.0.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+NEED_EMACS=25
+
+inherit elisp
+
+DESCRIPTION="Minuscule client library for the Git forge APIs"
+HOMEPAGE="https://magit.vc/manual/ghub"
+SRC_URI="https://github.com/magit/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-3+"
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+
+SITEFILE="50${PN}-gentoo.el"
+ELISP_TEXINFO="*.texi"
+DOCS="README.md"
+
+RDEPEND="
+ >=app-emacs/dash-2.14.1
+ >=app-emacs/graphql-0.1.1
+ >=app-emacs/treepy-0.0.1
+"
+BDEPEND="${RDEPEND}
+ sys-apps/texinfo"