summaryrefslogtreecommitdiff
path: root/app-emacs/flycheck-guile/flycheck-guile-0.4.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'app-emacs/flycheck-guile/flycheck-guile-0.4.ebuild')
-rw-r--r--app-emacs/flycheck-guile/flycheck-guile-0.4.ebuild29
1 files changed, 29 insertions, 0 deletions
diff --git a/app-emacs/flycheck-guile/flycheck-guile-0.4.ebuild b/app-emacs/flycheck-guile/flycheck-guile-0.4.ebuild
new file mode 100644
index 000000000000..3fad71cd8539
--- /dev/null
+++ b/app-emacs/flycheck-guile/flycheck-guile-0.4.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+NEED_EMACS=25.1
+
+inherit elisp
+
+DESCRIPTION="Flycheck checker for the GNU Guile Scheme implementation"
+HOMEPAGE="https://github.com/flatwhatson/flycheck-guile/"
+SRC_URI="https://github.com/flatwhatson/${PN}/archive/${PV}.tar.gz
+ -> ${P}.tar.gz"
+
+LICENSE="GPL-3+"
+SLOT="0"
+KEYWORDS="~amd64"
+
+BDEPEND="
+ app-emacs/flycheck
+ app-emacs/geiser-guile
+"
+RDEPEND="
+ ${BDEPEND}
+ >=dev-scheme/guile-2.0.0
+"
+
+DOCS=( README.md )
+SITEFILE="50${PN}-gentoo.el"