summaryrefslogtreecommitdiff
path: root/app-emacs/consult/consult-0.19.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'app-emacs/consult/consult-0.19.ebuild')
-rw-r--r--app-emacs/consult/consult-0.19.ebuild25
1 files changed, 25 insertions, 0 deletions
diff --git a/app-emacs/consult/consult-0.19.ebuild b/app-emacs/consult/consult-0.19.ebuild
new file mode 100644
index 000000000000..d2a809943fab
--- /dev/null
+++ b/app-emacs/consult/consult-0.19.ebuild
@@ -0,0 +1,25 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+NEED_EMACS=27
+
+inherit elisp
+
+DESCRIPTION="Consulting complete-read"
+HOMEPAGE="https://github.com/minad/consult"
+SRC_URI="https://github.com/minad/${PN}/archive/refs/tags/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-3+"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND=">=app-emacs/compat-28.1"
+BDEPEND="${RDEPEND}"
+
+SITEFILE="50${PN}-gentoo.el"
+
+src_compile() {
+ elisp_src_compile
+ elisp-make-autoload-file
+}