summaryrefslogtreecommitdiff
path: root/app-emacs/closql
diff options
context:
space:
mode:
Diffstat (limited to 'app-emacs/closql')
-rw-r--r--app-emacs/closql/Manifest5
-rw-r--r--app-emacs/closql/closql-2.0.0.ebuild32
-rw-r--r--app-emacs/closql/closql-9999.ebuild32
-rw-r--r--app-emacs/closql/files/50closql-gentoo.el1
-rw-r--r--app-emacs/closql/metadata.xml19
5 files changed, 89 insertions, 0 deletions
diff --git a/app-emacs/closql/Manifest b/app-emacs/closql/Manifest
new file mode 100644
index 000000000000..6f4ab780129d
--- /dev/null
+++ b/app-emacs/closql/Manifest
@@ -0,0 +1,5 @@
+AUX 50closql-gentoo.el 38 BLAKE2B e96c6cf48d1522d89450e11d339c76210c672377208b56951791b83c6ef22b2c872d313084e199dd5d7b533a99106a87dbc7f15b5ee6126f71bf5f2e84165ffa SHA512 5c00bcabe2d7cc03013dc7a54b2c653940c08098ca5646d7c73624cb1ca04376ae9dcf88a7166b1925c69f0c5d192d90f6bd790fdef8ed8c3b0f9d163c987da5
+DIST closql-2.0.0.tar.gz 21841 BLAKE2B 605dc82c16be351385275ec086caf95a6096409c21e4a57a6f8694c6143c367b6a9bf56158b358fa1de72cb10f0ff86079d7abfe8689701ed423717656af7980 SHA512 2112f6d14d043a0bea7bc6e88ef30351f890b51ba84234f1c089266c77d919959fe7e3d6c515944553a4e28876700db2eed228441a873aa28523fc2df27cf440
+EBUILD closql-2.0.0.ebuild 612 BLAKE2B 66c59d62c16cde2275df60a47efb0c9348754dc964f001d569f17f05960969fe425cb1cb3b103582a471915cf7a671ce286703087d63da3c99f18c9f291a1087 SHA512 e64c20da190ba5056d558967281c174dfe4d8b6c8b07d9aaa3fd6ec9281445660f1d1f394aaf341f29a7cde9f706ecd2a069a2b9aec9fac208c2efbc7bb002ed
+EBUILD closql-9999.ebuild 612 BLAKE2B 66c59d62c16cde2275df60a47efb0c9348754dc964f001d569f17f05960969fe425cb1cb3b103582a471915cf7a671ce286703087d63da3c99f18c9f291a1087 SHA512 e64c20da190ba5056d558967281c174dfe4d8b6c8b07d9aaa3fd6ec9281445660f1d1f394aaf341f29a7cde9f706ecd2a069a2b9aec9fac208c2efbc7bb002ed
+MISC metadata.xml 598 BLAKE2B 5a7555cfb40dde0a8ebf878a52c34460e3c5a397b17c5118cb96d3b52d4648fce462349146fa89a1c7907ad959ab5f117682110debf080127807b622bca3700b SHA512 aad2882217e8ecdc8cdfae6652d90e77a05bde98d093dfd4607b3dc30ca3fa49c8afefa1e48f1e177c5de00510ce86d2f392de4d438c320eb975b4f99560fc75
diff --git a/app-emacs/closql/closql-2.0.0.ebuild b/app-emacs/closql/closql-2.0.0.ebuild
new file mode 100644
index 000000000000..b4284d3d6907
--- /dev/null
+++ b/app-emacs/closql/closql-2.0.0.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+NEED_EMACS=27.1
+
+inherit elisp
+
+DESCRIPTION="Store EIEIO objects using EmacSQL"
+HOMEPAGE="https://github.com/magit/closql"
+
+if [[ ${PV} == *9999* ]] ; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/magit/${PN}.git"
+else
+ SRC_URI="https://github.com/magit/${PN}/archive/v${PV}.tar.gz
+ -> ${P}.tar.gz"
+ KEYWORDS="~amd64"
+fi
+
+LICENSE="GPL-3+"
+SLOT="0"
+
+RDEPEND="
+ >=app-emacs/compat-30.0.0.0
+ >=app-emacs/emacsql-4.0.0
+"
+BDEPEND="${RDEPEND}"
+
+DOCS=( README.org )
+SITEFILE="50${PN}-gentoo.el"
diff --git a/app-emacs/closql/closql-9999.ebuild b/app-emacs/closql/closql-9999.ebuild
new file mode 100644
index 000000000000..b4284d3d6907
--- /dev/null
+++ b/app-emacs/closql/closql-9999.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+NEED_EMACS=27.1
+
+inherit elisp
+
+DESCRIPTION="Store EIEIO objects using EmacSQL"
+HOMEPAGE="https://github.com/magit/closql"
+
+if [[ ${PV} == *9999* ]] ; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/magit/${PN}.git"
+else
+ SRC_URI="https://github.com/magit/${PN}/archive/v${PV}.tar.gz
+ -> ${P}.tar.gz"
+ KEYWORDS="~amd64"
+fi
+
+LICENSE="GPL-3+"
+SLOT="0"
+
+RDEPEND="
+ >=app-emacs/compat-30.0.0.0
+ >=app-emacs/emacsql-4.0.0
+"
+BDEPEND="${RDEPEND}"
+
+DOCS=( README.org )
+SITEFILE="50${PN}-gentoo.el"
diff --git a/app-emacs/closql/files/50closql-gentoo.el b/app-emacs/closql/files/50closql-gentoo.el
new file mode 100644
index 000000000000..431f7e90ae73
--- /dev/null
+++ b/app-emacs/closql/files/50closql-gentoo.el
@@ -0,0 +1 @@
+(add-to-list 'load-path "@SITELISP@")
diff --git a/app-emacs/closql/metadata.xml b/app-emacs/closql/metadata.xml
new file mode 100644
index 000000000000..62a4a4f10446
--- /dev/null
+++ b/app-emacs/closql/metadata.xml
@@ -0,0 +1,19 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>arsen@gentoo.org</email>
+ <description>Arsen Arsenović</description>
+ </maintainer>
+ <maintainer type="person">
+ <email>sam@gentoo.org</email>
+ <description>Sam James</description>
+ </maintainer>
+ <maintainer type="project">
+ <email>gnu-emacs@gentoo.org</email>
+ <name>Gentoo GNU Emacs project</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="github">magit/closql</remote-id>
+ </upstream>
+</pkgmetadata>