summaryrefslogtreecommitdiff
path: root/app-editors
diff options
context:
space:
mode:
Diffstat (limited to 'app-editors')
-rw-r--r--app-editors/Manifest.gzbin14104 -> 14105 bytes
-rw-r--r--app-editors/wily/Manifest2
-rw-r--r--app-editors/wily/files/wily-1.0-C23.patch101
-rw-r--r--app-editors/wily/wily-1.0-r3.ebuild48
-rw-r--r--app-editors/zed/Manifest6
-rw-r--r--app-editors/zed/zed-0.172.10.ebuild (renamed from app-editors/zed/zed-0.172.8.ebuild)4
6 files changed, 156 insertions, 5 deletions
diff --git a/app-editors/Manifest.gz b/app-editors/Manifest.gz
index c46efef2189b..ec1bef72e1b2 100644
--- a/app-editors/Manifest.gz
+++ b/app-editors/Manifest.gz
Binary files differ
diff --git a/app-editors/wily/Manifest b/app-editors/wily/Manifest
index 5c05d8d69676..6c889204cdd3 100644
--- a/app-editors/wily/Manifest
+++ b/app-editors/wily/Manifest
@@ -1,3 +1,5 @@
+AUX wily-1.0-C23.patch 2030 BLAKE2B 9cba93ab704454156e947e0871b0a283aea9ce53ea00e5355a8f36480ebde0e61f68d96a088d8b6569b60b10bff6d92067234fa156a2320b231e3a0ce98fc3be SHA512 853cd6b0cf5645dcbd2b54ce38f3346e50171bf07b36d85e470eba322ee2aaf5e71f1b7ee20096d98ba957b4d27b108a98f091ec9d8bba1e9ebc6e50f8fe4fba
DIST wily-9libs.tar.gz 125247 BLAKE2B 94f93d081c90f6543bb26d17f8fe053135be2df983a2280fdd15243c5e448f5f3265666692e0635156217b0e759e0d6f3bbc123cb857f1d7880ee3ee4f913a37 SHA512 3c06ef1d9c6e77a00037570f8b8bdbcdfc7648f691675db679ba83ac0ce092762a4020b0483acd325aa57810e9a386800a94c5e6e2b5002a963b4751a4d30a5b
EBUILD wily-1.0-r2.ebuild 717 BLAKE2B 367116115efc8030793919d04f4ff1aba70c8323484ef2b36ba3d4054fbf90ad274c8389a8ea48365a623d26a9b4f22f2d4d5f4fe8e71467c2fc116d2a7fa1d2 SHA512 585aa02b6b543a4105b4a0cd2ff3efd75ef4a2014efc256ddb0ddb463d132d0d7d995db68a6e9f110ebaac56085d2b542b78d4fd8717da996f1eeea9d728169b
+EBUILD wily-1.0-r3.ebuild 854 BLAKE2B 164c0b4f8791b0db51b3d54595f1aa305d234590ea638c7cac18b19d7069f2ff270921801c2defcd6b3e0cfea704ca928d69bb3b9e226eee8c8a25d62cdc216a SHA512 709fdd9695b29c7ac71d2593af81d1342d86c445d2cdf0f4f7eb133a419d763c9349ddd6388991129f2da2213b3561ee11920ab293c73df09f1f00828cdd49e5
MISC metadata.xml 167 BLAKE2B 868e3b584722eaacf68273db062bb773d8c7e5d7ab2b81ca7e8397643bf7cc106c3a1033594401c99c54f667bb45d6b73f9048fc335580bbd44b4589ad26a832 SHA512 30caadd1496c3b9969136038239a1d8e01f236726b4022c2d7e19ca7575f25f735e556835e581afbf44fbd3e4104c40f2b5ef5fa70118d75c881fdf871962d0a
diff --git a/app-editors/wily/files/wily-1.0-C23.patch b/app-editors/wily/files/wily-1.0-C23.patch
new file mode 100644
index 000000000000..8516c347fba5
--- /dev/null
+++ b/app-editors/wily/files/wily-1.0-C23.patch
@@ -0,0 +1,101 @@
+DO NOT EAT ERRORS AND CONTINUE
+--- a/Makefile.in
++++ b/Makefile.in
+@@ -4,12 +4,16 @@
+ srcdir=@srcdir@
+ VPATH=@srcdir@
+
+-subdirs=libmsg wily
++SUBDIRS=libmsg wily
++.PHONY: $(TOPTARGETS) $(SUBDIRS)
++
++wily: libmsg
+
+-all install clean nuke distclean::
+- for i in $(subdirs); do \
+- (cd $$i; $(MAKE) $(MFLAGS) $@); \
+- done
++TOPTARGETS=all install clean nuke distclean
++
++$(TOPTARGETS):: $(SUBDIRS)
++$(SUBDIRS):
++ $(MAKE) -C $@ $(MAKECMDGOALS)
+
+ nuke distclean::
+ rm -f wily.* config.cache config.h config.log config.status Makefile
+bug https://bugs.gentoo.org/729238
+Do not call ar directly
+--- a/configure.in
++++ b/configure.in
+@@ -95,6 +95,7 @@
+ AC_PROG_MAKE_SET
+ AM_PROG_CC_STDC
+ AC_PROG_RANLIB
++AC_PROG_AR
+
+ dnl Checks for libraries.
+ AC_PATH_XTRA
+--- a/libmsg/Makefile.in
++++ b/libmsg/Makefile.in
+@@ -7,7 +7,7 @@
+
+ CC=@CC@
+ CFLAGS=@CFLAGS@ -I.. -I$(INCLUDES) @NINE_CFLAGS@
+-AR=ar
++AR=@AR@
+ RANLIB=@RANLIB@
+ INCLUDES=$(top_srcdir)/include
+
+C23 porting for GCC-15
+--- a/include/msg.h
++++ b/include/msg.h
+@@ -3,7 +3,11 @@
+
+ typedef struct Msg Msg;
+ typedef int Id; /* Window identifier */
++#if __STDC_VERSION__ <= 201710L
+ typedef enum Bool {false, true} Bool;
++#else
++typedef bool Bool;
++#endif
+ typedef struct Range Range;
+
+ /* name of environment variable */
+--- a/wily/wily.h
++++ b/wily/wily.h
+@@ -9,6 +9,7 @@
+ #include <libc.h>
+ #include <libg.h>
+ #include <frame.h>
++#include <stdarg.h>
+ #include "config.h"
+ #include <msg.h>
+
+--- a/wily/include.c
++++ b/wily/include.c
+@@ -27,11 +27,11 @@
+ expanded = text_expand(t, r, notinclude);
+ len = RLEN(expanded);
+ if( len > (MAXPATH*UTFmax) || len < 2)
+- return false;
++ return NULL;
+ len = text_copyutf(t, expanded, buf);
+
+ if (!is_includebrackets(buf[0], buf[len-1]))
+- return false;
++ return NULL;
+
+ buf[len-1] = 0;
+ s = pathfind(getenv("INCLUDES"), buf+1);
+--- a/wily/wily.c
++++ b/wily/wily.c
+@@ -4,6 +4,8 @@
+
+ #include "wily.h"
+ #include "tile.h"
++
++extern void initfont(char *fixed); /* from font.c */
+
+ static int ncolumns = 2;
+ int tagheight;
+
diff --git a/app-editors/wily/wily-1.0-r3.ebuild b/app-editors/wily/wily-1.0-r3.ebuild
new file mode 100644
index 000000000000..81b7edac6086
--- /dev/null
+++ b/app-editors/wily/wily-1.0-r3.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2025 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+inherit autotools
+
+MY_P="${P/1.0/9libs}"
+
+DESCRIPTION="An emulation of ACME, Plan9's hybrid window system, shell and editor"
+HOMEPAGE="https://www.netlib.org/research/9libs/"
+SRC_URI="https://www.netlib.org/research/9libs/${MY_P}.tar.gz"
+S=${WORKDIR}/${MY_P}
+
+LICENSE="Artistic"
+SLOT="0"
+KEYWORDS="~amd64 ~riscv ~x86"
+
+DEPEND="
+ dev-libs/9libs
+"
+RDEPEND="
+ ${DEPEND}
+"
+DOCS=(
+ README
+)
+
+PATCHES=( "${FILESDIR}/${P}-C23.patch" )
+
+src_prepare() {
+ default
+
+ #bug https://bugs.gentoo.org/877123 and https://bugs.gentoo.org/906022
+ eautoreconf
+}
+
+src_configure() {
+ mhw_cv_mod_9libs_lib_path=/usr/$(get_libdir) \
+ mhw_cv_mod_9libs_inc_path=/usr/include/9libs \
+ econf
+}
+
+src_install() {
+ default
+
+ insinto /usr/share/${PN}
+ doins "${S}"/misc/*
+}
diff --git a/app-editors/zed/Manifest b/app-editors/zed/Manifest
index 9bcb73915d47..530b18596d4e 100644
--- a/app-editors/zed/Manifest
+++ b/app-editors/zed/Manifest
@@ -29,9 +29,9 @@ DIST zed-0.165.4-crates.tar.xz 100617284 BLAKE2B 2ae775115768befa1509f57a3c6177b
DIST zed-0.165.4.tar.gz 13286399 BLAKE2B 971ae47f9344d8fd07dbd0237a61a04b62f848f5f5eb84542e1d5e86ddae07603387c48af1e6068a94d3dea910a0234102f63a64f59b88d482398f4ed69346b5 SHA512 ab55422f05eeac551a485be147ee0336bdd790ac51ff21c719c1f432735e695be0e25f747bf2ba92e0f06bce520aa328f867300647d9828ce282bec87f61fe07
DIST zed-0.168.2-crates.tar.xz 102307616 BLAKE2B 07c3b4270cdb230c1821dcdbcf8d2412e22bcd83d0bcad8d920cb8a24fb7759c94ef631ae3aa043b9fe7435c36fdd4737dcfe88b4cf8e754c91901b2061c6fc3 SHA512 e0e347725001e6d30af3e19556ba698c058572550da928efb6cb8ad2525c25cb2a8234a0ae3bc6a7c3ad9abdeb9b84336b82e11fb0574ce1e3ef02a8b641d850
DIST zed-0.168.2.tar.gz 13487508 BLAKE2B 7e9f8a73eb461f852d85f9596f3db1af0ce56c5c994c413a90b270d5b2b5bb2e994f78853a17b5579ba9905f761cec11d56c67a686643ca5ae4a36dcd83cfb5f SHA512 c7a1c93e044879209dd19b00dba7e046b13175ed82a4968c1aabe1f1605a61605cb4d8d7906a186c61c6129d59a58e14dd2f336263b301f8b59d3e9f7b332f1b
-DIST zed-0.172.8-crates.tar.xz 101309808 BLAKE2B 98770d79f4cddda7c8215760a4856b42107414d50c0b28499e8dab334e36d7f1629034875f396cf3e342ccac562bf71d6be61e360f57388badca594fe691fcb0 SHA512 3b549b155ed160350852f71281f966a35900089f85fd05190d15bbdd9a257c124aa313ad1ddedc0c5f644d0f64f49d8c86091aebb0f897e5a51640bfe48d9007
-DIST zed-0.172.8.tar.gz 13619615 BLAKE2B 5cb194a6e234ac8273e81f2ec6991cea9956d7094940a0c3d932d6e4a7ae599dc48a82e7a60be182612b789dbb35e0b31690c76798dfe45751b5de680cfa5aa4 SHA512 c45ac9722a4db274b6a856442f8351ecd1955e07deb2e9efa250e9748ae7b10c8c69f53c6297d21790e74fa065e70e2731010c8dec74fea13a0bd6ae61a2cb04
+DIST zed-0.172.10-crates.tar.xz 101309808 BLAKE2B 98770d79f4cddda7c8215760a4856b42107414d50c0b28499e8dab334e36d7f1629034875f396cf3e342ccac562bf71d6be61e360f57388badca594fe691fcb0 SHA512 3b549b155ed160350852f71281f966a35900089f85fd05190d15bbdd9a257c124aa313ad1ddedc0c5f644d0f64f49d8c86091aebb0f897e5a51640bfe48d9007
+DIST zed-0.172.10.tar.gz 13621974 BLAKE2B df0fc8e93ca584c84281e86a86c5c4d9ae47d13aac3bfaa3c5837aa64677e9fccb0f6b6eabce8a5b953af5c2062a587e4e31bef8cebe0003ea5a78e1e98ecbc9 SHA512 4799a04191ac07a8da178252f79097def1f1959c4ecbbfef71999765d4ed6db41089b7445c529e1b6784c8598cd6c60707028048f8fdb2afbf96b99b7ad016e8
EBUILD zed-0.165.4.ebuild 9509 BLAKE2B 12979687e47d1b8df2affa08f32cc4cb118578477e5946649654dacbd763149194ea14e5ef250b82dd374bfa777d1308c78a2c6774403626a79ba21e1c7210cd SHA512 665ebb2c035faa9c5219bc057d45fe6e102f39d84649d67d2e0403949604fcd114128a5c57192fbc28a749fd583ab163121b7ca5f4a9715e9fd0d40539c51ce2
EBUILD zed-0.168.2.ebuild 11505 BLAKE2B 1b614242968c757bdece760f455d25e8b34502098d31523689fc36918b8228e9d85d60292af85f502338dc69d2139f2f9347bd1082deeabe8bccd54c5c92a538 SHA512 5592cafac8272ce0b21526041803b3100218f3133dcf937866b9fd3ccd987b5636ae3d7bd62963a4818b530c69c662cee00f27d0c95f617dfc92b8fde49d8fbe
-EBUILD zed-0.172.8.ebuild 12140 BLAKE2B 52fb899a51506d44ddf5998b1f34fac55718512b85ff5fb190f5f8e38ee3fd3cd1a3b3b37af2f7b6e94c745503e7f5ee3a9125e70ea1bf3454dd02142064616f SHA512 212d6b79ca5692cc0ee627ba56ef7ca6707144d2952d64ff68049baf0dd7feacd5f0ba9ab57bbfff7e2871207233afcfe1ea10d5b241b1d697a1412662cc8d15
+EBUILD zed-0.172.10.ebuild 12148 BLAKE2B f3fea80e65e909c8d6d846b6a69e052497969ce5c7d269f1637c8678ebeb009d4a984681a801e956e36aa323758c52f2dd0d2f0a24a506c2863c2e4802547fb6 SHA512 472b75f58cb3fbd9ac6dcc531179082c5dd48c208293cddd92f5d4a9712dca359582a42a5db8d3b37fce126b8143ab855d70e6602bc8ffa9b857d011d3d8c932
MISC metadata.xml 575 BLAKE2B 3793593f06424fd3986e23cd148b663bfcbf5c1dc0f76847a3991bbdde8badfdc863d0994ba1b59fc0e886243ded4e4421da4b4bf6d2951887801f78b0d6d290 SHA512 b0660a1a36d59dea6b9a6e25a239f0484e1cbf98a6569dd17d6bae1145f12d7e3ac2609bbce32627bf7ca6161581cd82c087d7deb17dd662c23bd81db6465a02
diff --git a/app-editors/zed/zed-0.172.8.ebuild b/app-editors/zed/zed-0.172.10.ebuild
index 6a96d8111b74..6718d4f851a5 100644
--- a/app-editors/zed/zed-0.172.8.ebuild
+++ b/app-editors/zed/zed-0.172.10.ebuild
@@ -1,7 +1,7 @@
# Copyright 2025 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-# Autogenerated by pycargoebuild 0.13.4
+# Autogenerated by pycargoebuild 0.13.5
EAPI=8
@@ -104,7 +104,7 @@ DEPEND="
app-arch/zstd:=
app-misc/jq
dev-db/sqlite:3
- dev-libs/libgit2:=
+ >=dev-libs/libgit2-1.9.0:=
dev-libs/mimalloc
dev-libs/openssl:0/3
dev-libs/protobuf