summaryrefslogtreecommitdiff
path: root/app-editors
diff options
context:
space:
mode:
Diffstat (limited to 'app-editors')
-rw-r--r--app-editors/Manifest.gzbin13574 -> 13414 bytes
-rw-r--r--app-editors/jext/Manifest5
-rw-r--r--app-editors/jext/files/jext-5.0-enum-as-keyword.patch173
-rw-r--r--app-editors/jext/files/jext-pre91
-rw-r--r--app-editors/jext/jext-5.0-r2.ebuild65
-rw-r--r--app-editors/jext/metadata.xml11
6 files changed, 0 insertions, 345 deletions
diff --git a/app-editors/Manifest.gz b/app-editors/Manifest.gz
index edd6afa7123a..f74c7c3bd590 100644
--- a/app-editors/Manifest.gz
+++ b/app-editors/Manifest.gz
Binary files differ
diff --git a/app-editors/jext/Manifest b/app-editors/jext/Manifest
deleted file mode 100644
index 94261e482e0f..000000000000
--- a/app-editors/jext/Manifest
+++ /dev/null
@@ -1,5 +0,0 @@
-AUX jext-5.0-enum-as-keyword.patch 5908 BLAKE2B c89cf37e0c340de7fc8ac0594af2e89de5a7b226a55dc7815d70009ae841ca4ef6feaa1f1fa3023c534d53c869d1a3d26f038d203f7e8860196c6b42df0d5d96 SHA512 22e06e0d57a11add9ca97dbfab54d9e6be9ae3d0c9ef216b5884a415d1c1f700cd86faf321a29852fca027ed05d9b5cd931b2febeba02a942c1b89bcb71372bf
-AUX jext-pre 2824 BLAKE2B 3356902e537037b6bdfa9157dd3756e701513681c609f47571ce3360ed5d1da798fc3a516446c6f82f2171d6b8664e4fb7f3bd17ac97fdc5ad760ad717e3c415 SHA512 f98efa43110d295a425750603dc59d94d734ba52a86323c908ebb50f60de36096c76a9b8c4f2572e60b57a256cf0b517636679e7e88062ae074872e767c3016f
-DIST jext-sources-5.0.tar.gz 1029772 BLAKE2B 632fca6aa3ff55979f1dee9fefd1505e0e19b38ca1ee0530472edd9fee95157df9cba56abb4ce4790807766d318a6d0ce29decb9b4a73d103bfe8127886fdf9d SHA512 ac66babfca05d112541e40b0aa8ebde33a69a3a97f42966be24a28232d3c100b9fe8007e26618909fd78111d3eb4ddecc2258599bff40e0e1959ea6632f43682
-EBUILD jext-5.0-r2.ebuild 1630 BLAKE2B 4ef52026adb68a68086c8d5a237146754ca370c6b5d5ca759de33a413c537aad2510747206537ee8f6b73851ff705f8b5cdf596e3bbc4ffc2650a4b8a434211b SHA512 51ebf0876b4c8f32bbcaa1afa092fa786e5ed9bed23c724b63cda7e74579c886c46986bf00cb1da4f48486058fd7f20a2af4a71f96b1bebb2b630612a09b0051
-MISC metadata.xml 310 BLAKE2B d9dca671dbd1763f6dde0d2553f42101b997bb8f8c8839b869d71c3cbe3e80a3204427bce32759569f21b8e7b804ec60dbe1e1bff07117c37f9963a3031fb1c3 SHA512 ed4dde3976952248a6abb4a921a09572bf52a0a3da8fbab99c16986593d7b40a058645557d6d80e43e8db6414d5d3296bb3f5cd034d88b91dbc96b8743f72f16
diff --git a/app-editors/jext/files/jext-5.0-enum-as-keyword.patch b/app-editors/jext/files/jext-5.0-enum-as-keyword.patch
deleted file mode 100644
index c773e571d182..000000000000
--- a/app-editors/jext/files/jext-5.0-enum-as-keyword.patch
+++ /dev/null
@@ -1,173 +0,0 @@
---- src/lib/org/gjt/sp/jedit/textarea/InputHandler.java.orig 2015-07-03 17:52:13.843000000 +0000
-+++ src/lib/org/gjt/sp/jedit/textarea/InputHandler.java 2015-07-03 17:52:59.746000000 +0000
-@@ -141,10 +141,10 @@
- */
- public static String getActionName(ActionListener listener)
- {
-- Enumeration enum = getActions();
-- while(enum.hasMoreElements())
-+ Enumeration myEnum = getActions();
-+ while(myEnum.hasMoreElements())
- {
-- String name = (String)enum.nextElement();
-+ String name = (String)myEnum.nextElement();
- ActionListener _listener = getAction(name);
- if(_listener == listener)
- return name;
---- src/lib/org/jext/options/OptionsDialog.java.orig 2015-07-03 17:54:19.179000000 +0000
-+++ src/lib/org/jext/options/OptionsDialog.java 2015-07-03 17:54:33.377000000 +0000
-@@ -297,11 +297,11 @@
-
- private void addOptionGroup(OptionGroup child, OptionGroup parent)
- {
-- ArrayList enum = child.getMembers();
-+ ArrayList myEnum = child.getMembers();
-
-- for (int i = 0; i < enum.size(); i++)
-+ for (int i = 0; i < myEnum.size(); i++)
- {
-- Object elem = enum.get(i);
-+ Object elem = myEnum.get(i);
-
- if (elem instanceof OptionPane)
- {
-@@ -669,4 +669,4 @@
-
- }
-
--// End of OptionsDialog.java
-\ No newline at end of file
-+// End of OptionsDialog.java
---- src/lib/org/jext/misc/VirtualFolders.java.orig 2015-07-03 17:49:57.731000000 +0000
-+++ src/lib/org/jext/misc/VirtualFolders.java 2015-07-03 17:51:11.418000000 +0000
-@@ -233,10 +233,10 @@
- ret.append(crlf).append("<folderlist>");
- }
-
-- Enumeration enum = parent.children();
-- while (enum.hasMoreElements())
-+ Enumeration myEnum = parent.children();
-+ while (myEnum.hasMoreElements())
- {
-- VirtualFolderNode child = (VirtualFolderNode) enum.nextElement();
-+ VirtualFolderNode child = (VirtualFolderNode) myEnum.nextElement();
- ret.append(toXML(child, depth + 1));
- }
-
-@@ -317,20 +317,20 @@
-
- private void fixVisible()
- {
-- Enumeration enum = root.depthFirstEnumeration();
-+ Enumeration myEnum = root.depthFirstEnumeration();
- VirtualFolderNode node = null;
-- while (enum.hasMoreElements())
-+ while (myEnum.hasMoreElements())
- {
-
-- node = (VirtualFolderNode)enum.nextElement();
-+ node = (VirtualFolderNode)myEnum.nextElement();
- TreePath path = new TreePath(node.getPath());
- tree.collapsePath(path);
- }
-
-- enum = root.depthFirstEnumeration();
-- while (enum.hasMoreElements())
-+ myEnum = root.depthFirstEnumeration();
-+ while (myEnum.hasMoreElements())
- {
-- node = (VirtualFolderNode)enum.nextElement();
-+ node = (VirtualFolderNode)myEnum.nextElement();
- if (node.shouldBeVisible())
- {
- TreePath path = new TreePath(((VirtualFolderNode)node.getParent()).getPath());
-@@ -392,10 +392,10 @@
- public static boolean folderExists(VirtualFolderNode parent, String name)
- {
- boolean exists = false;
-- Enumeration enum = parent.children();
-- while ((enum.hasMoreElements()) && !exists)
-+ Enumeration myEnum = parent.children();
-+ while ((myEnum.hasMoreElements()) && !exists)
- {
-- VirtualFolderNode child = (VirtualFolderNode) enum.nextElement();
-+ VirtualFolderNode child = (VirtualFolderNode) myEnum.nextElement();
- exists = child.toString().equals(name);
- }
- return exists;
-@@ -526,10 +526,10 @@
- } else {
- if (fromMenu)
- {
-- Enumeration enum = node.children();
-- while (enum.hasMoreElements())
-+ Enumeration myEnum = node.children();
-+ while (myEnum.hasMoreElements())
- {
-- VirtualFolderNode child = (VirtualFolderNode) enum.nextElement();
-+ VirtualFolderNode child = (VirtualFolderNode) myEnum.nextElement();
- openNode(child, fromMenu);
- }
- }
---- src/lib/com/microstar/xml/XmlParser.java.orig 2015-07-03 17:41:23.209000000 +0000
-+++ src/lib/com/microstar/xml/XmlParser.java 2015-07-03 17:46:30.296000000 +0000
-@@ -1346,7 +1346,7 @@
- {
- String name;
- int type;
-- String enum = null;
-+ String myEnum = null;
-
- // Read the attribute name.
- name = readNmtoken(true);
-@@ -1358,12 +1358,12 @@
- // Get the string of enumerated values
- // if necessary.
- if (type == ATTRIBUTE_ENUMERATED || type == ATTRIBUTE_NOTATION) {
-- enum = dataBufferToString();
-+ myEnum = dataBufferToString();
- }
-
- // Read the default value.
- requireWhitespace();
-- parseDefault(elementName, name, type, enum);
-+ parseDefault(elementName, name, type, myEnum);
- }
-
-
-@@ -1451,7 +1451,7 @@
- * Parse the default value for an attribute.
- * [62] Default ::= '#REQUIRED' | '#IMPLIED' | ((%'#FIXED' S)? %AttValue
- */
-- void parseDefault (String elementName, String name, int type, String enum)
-+ void parseDefault (String elementName, String name, int type, String myEnum)
- throws java.lang.Exception
- {
- int valueType = ATTRIBUTE_DEFAULT_SPECIFIED;
-@@ -1477,7 +1477,7 @@
- value = readLiteral(LIT_CHAR_REF);
- context = CONTEXT_DTD;
- }
-- setAttribute(elementName, name, type, enum, value, valueType);
-+ setAttribute(elementName, name, type, myEnum, value, valueType);
- }
-
-
-@@ -2714,7 +2714,7 @@
- * - int value type
- * *TODO: do something with attribute types.
- */
-- void setAttribute (String elName, String name, int type, String enumeration,
-+ void setAttribute (String elName, String name, int type, String myEnum,
- String value, int valueType)
- throws java.lang.Exception
- {
-@@ -2736,7 +2736,7 @@
- attribute[0] = new Integer(type);
- attribute[1] = value;
- attribute[2] = new Integer(valueType);
-- attribute[3] = enumeration;
-+ attribute[3] = myEnum;
- attribute[4] = null;
- attlist.put(name.intern(), attribute);
-
diff --git a/app-editors/jext/files/jext-pre b/app-editors/jext/files/jext-pre
deleted file mode 100644
index 5a02d4b71db8..000000000000
--- a/app-editors/jext/files/jext-pre
+++ /dev/null
@@ -1,91 +0,0 @@
-# This script launches Jext, the Java text editor.
-# It checks for a $HOME/.jext directory and eventually creates it.
-# Next it checks for a /etc/jextrc and $JEXT_CONFFILE (~/.jext/variables) files which define the JEXT_HOME JAVA_CMD JAVA_OPT CLASSPATH and ToShow variables. The first is system wide(used in RPM install mainly), the second is per user.
-# If this file doesn't exist the script creates it by asking the options to the user.
-
-# Sharpshooter 23/02/2002
-# Blaisorblade 18/11/2002
-
-#For special cases about different config files(for developers with working
-#copy and an unstable one to be tested).
-if [ "$JEXT_CONFFILE" = "" ]
-then
- JEXT_CONFFILE=~/.jext/variables
-fi
-
-# Help
-if [ "$1" = "--help" -o "$1" = "-h" ]
-then
- echo "This script launch Jext the Java text editor."
- echo "Usage : $0 [--reconf] [files]"
- echo "--reconf doesn't start jext but clears the"
- echo " $JEXT_CONFFILE file with the settings to start jext"
- echo " (jext & java location and jext options)."
- exit 0
-fi
-
-if [ "$1" = "--reconf" ]
-then
- echo "Clearing $JEXT_CONFFILE, you'll have to reenter jext & java \
-interpreter location"
- rm -f "$JEXT_CONFFILE"
- exit 0
-fi
-
-
-# Check for the user's ~/.jext directory.
-if ! [ -d ~/.jext ]
-then
- echo "It seems you don't have a .jext directory in your home dir."
- echo "I create it."
- echo
- mkdir -p ~/.jext/xinsert
-fi
-
-
-
-# Check for the $HOME/.jext/variables file.
-if ! [ -f $JEXT_CONFFILE -o -f /etc/jextrc ]
-then
- #Let's add some explaination in the config file.
- cat >$JEXT_CONFFILE <<EOM
-#This is included when launching Jext. It is a normal shell script \
-used to define env vars
-#Meanings of settings:
-#JEXT_HOME The home dir of jext(under which it finds the lib and so on dirs)
-#JAVA_CMD The complete path for the java command
-#JAVA_OPT The options to be passed to the java command(not to Jext itself!)
-#CLASSPATH The extra classpath to be specified(for cases such as AntWork plugin)
-#ToShow If this is set to y the output is not redirected to /dev/null;
-# Mainly for developers who want to trace Jext output(you could also use
-# the DickTracy plugin).
-EOM
-#----
- JEXT_HOME="/usr/share/jext/lib"
- echo "JEXT_HOME="$JEXT_HOME >> $JEXT_CONFFILE
-#----
- ToShow=
- echo "ToShow="$ToShow>>$JEXT_CONFFILE
-fi
-
-# Extract the contents of the $JEXT_CONFFILE file.
-[ -f /etc/jextrc ] && source /etc/jextrc
-[ -f $JEXT_CONFFILE ] && source $JEXT_CONFFILE
-
-#Needed to make Jext find his plugins(it searches them in `pwd`/plugins)
-for i in $@
-do
- if [ "${i:0:1}" != "/" -a "${i:0:1}" != "-" ]; then #If the first char of $i is not a / then
- files="$files `pwd`/$i" #it is a relative path so we must make it absolute.
- elif [ "$i" != "-" ]; then
- files="$files $i"
- else
- case "$i" in
- --reconf|--help|-h)
- ;;
- *)
- files="$files $i"
- ;;
- esac
- fi
-done
diff --git a/app-editors/jext/jext-5.0-r2.ebuild b/app-editors/jext/jext-5.0-r2.ebuild
deleted file mode 100644
index bec3821aed57..000000000000
--- a/app-editors/jext/jext-5.0-r2.ebuild
+++ /dev/null
@@ -1,65 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=5
-
-JAVA_PKG_IUSE="doc"
-inherit java-pkg-2 java-ant-2
-
-DESCRIPTION="A text editor written in Java"
-HOMEPAGE="https://sourceforge.net/projects/jext/"
-MY_PV="${PV/_}"
-SRC_URI="mirror://sourceforge/${PN}/${PN}-sources-${MY_PV}.tar.gz"
-LICENSE="|| ( GPL-2 JPython )"
-SLOT="0"
-KEYWORDS="amd64 x86"
-IUSE=""
-
-CDEPEND="dev-java/jython:2.7
- dev-java/jgoodies-looks:1.2
- dev-java/gnu-regexp:1"
-DEPEND=">=virtual/jdk-1.6
- ${CDEPEND}"
-RDEPEND=">=virtual/jre-1.6
- ${CDEPEND}"
-
-S="${WORKDIR}/${PN}-src-${MY_PV}"
-
-# Necessary otherwise it chokes on compiling with jdk-1.8
-# due to unmappable characters.
-JAVA_ANT_ENCODING="ISO-8859-1"
-
-java_prepare() {
- # bundles some com.microstar.xml who knows what's that
- # also com.jgoodies.uif_lite which is apparently some jgoodies-looks
- # example code which we don't package and there is probably no point
- rm -v "${S}"/extplugins/Admin/*.jar || die
- rm -rf src/lib/gnu || die
-
- # Fix "enum as a keyword" error.
- epatch "${FILESDIR}"/"${P}"-enum-as-keyword.patch
-}
-
-src_compile() {
- cd "${S}/src" || die
- eant jar $(use_doc javadocs) \
- -Dclasspath="$(java-pkg_getjars jython-2.7,jgoodies-looks-1.2,gnu-regexp-1)"
-}
-
-src_install() {
- java-pkg_newjar lib/${P}.jar
- java-pkg_dojar lib/dawn*.jar
-
- java-pkg_dolauncher ${PN} \
- --main org.jext.Jext \
- --java_args '-Dpython.path=$(java-config --classpath=jython-2.7)' \
- -pre "${FILESDIR}/${PN}-pre"
-
- if use doc; then
- java-pkg_dohtml -r docs/api
- fi
-}
-
-pkg_postinst() {
- elog "Plugins are currently not built/installed. Patches welcome."
-}
diff --git a/app-editors/jext/metadata.xml b/app-editors/jext/metadata.xml
deleted file mode 100644
index 1db813e89d5f..000000000000
--- a/app-editors/jext/metadata.xml
+++ /dev/null
@@ -1,11 +0,0 @@
-<?xml version="1.0" encoding="UTF-8"?>
-<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
-<pkgmetadata>
- <maintainer type="project">
- <email>java@gentoo.org</email>
- <name>Java</name>
- </maintainer>
- <upstream>
- <remote-id type="sourceforge">jext</remote-id>
- </upstream>
-</pkgmetadata>